aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
commit3b7bd0a1490f574288fc9a02617a19cf238254e0 (patch)
treec05d182f965de6bace293ed87ece71bd45e7c422 /audio
parent913e08e52dca0eafb130dc0942c6275a178095ea (diff)
downloadports-3b7bd0a1490f574288fc9a02617a19cf238254e0.tar.gz
ports-3b7bd0a1490f574288fc9a02617a19cf238254e0.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/adplay/Makefile6
-rw-r--r--audio/cueplayer/Makefile8
-rw-r--r--audio/dumb/Makefile2
-rw-r--r--audio/esound/Makefile1
-rw-r--r--audio/gmpc/Makefile2
-rw-r--r--audio/goobox/Makefile2
-rw-r--r--audio/gqradio/Makefile2
-rw-r--r--audio/hydrogen/Makefile4
-rw-r--r--audio/hydrogen/files/patch-Sconstruct12
-rw-r--r--audio/mixxx/files/patch-build__depends.py4
-rw-r--r--audio/osd-lyrics/Makefile4
-rw-r--r--audio/raop_play/Makefile4
-rw-r--r--audio/ripperx/Makefile14
-rw-r--r--audio/shairport/Makefile1
14 files changed, 47 insertions, 19 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index 1ff497127589..2a1e20d2d318 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -3,7 +3,7 @@
PORTNAME= adplay
PORTVERSION= 1.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF/adplug/AdPlay_UNIX/${PORTVERSION}:main \
SF/adplug/Database/2006-07-06:db
@@ -19,13 +19,14 @@ LIB_DEPENDS= libadplug.so:${PORTSDIR}/audio/libadplug \
libbinio.so:${PORTSDIR}/devel/libbinio
GNU_CONFIGURE= yes
+USES= libtool
WANT_SDL= yes
DBFILE= adplug.db
DBVERSION= 2006-07-07
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libbinio
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lbinio
CONFIGURE_ARGS+= --sharedstatedir=${DATADIR}
@@ -43,6 +44,7 @@ CONFIGURE_ARGS+= --disable-output-sdl
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's/-lstdc++//g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|^\(adplug_data_dir.*\)/.*|\1|' \
${WRKSRC}/src/Makefile.in
@${RM} ${WRKSRC}/src/getopt.h
diff --git a/audio/cueplayer/Makefile b/audio/cueplayer/Makefile
index 74d57f6140c4..de96eacb28ba 100644
--- a/audio/cueplayer/Makefile
+++ b/audio/cueplayer/Makefile
@@ -15,6 +15,7 @@ LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
USES= pkgconfig qmake
USE_QT4= gui xml uic_build moc_build rcc_build network
USE_GSTREAMER= flac good dvd lame ugly ffmpeg taglib ogg vorbis soup libmms wavpack
+USE_XORG= x11
LICENSE= GPLv3
@@ -23,10 +24,11 @@ DESKTOP_ENTRIES="Cueplayer" "Lightweight media player based on Qt and Gstreamer"
"AudioVideo;Audio;Video;" true
post-patch:
- cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,/usr/share/cueplayer/,${DATADIR}/,g' \
- main.cpp ${PORTNAME}.pro
- ${REINPLACE_CMD} -e 's,/usr/share,${PREFIX},g' \
+ @${REINPLACE_CMD} -e 's,/usr/share/cueplayer/,${DATADIR}/,g' \
+ ${WRKSRC}/main.cpp ${WRKSRC}/${PORTNAME}.pro
+ @${REINPLACE_CMD} -e 's,/usr/share,${PREFIX},g' \
${WRKSRC}/${PORTNAME}.pro
+ @${ECHO_CMD} 'PKGCONFIG += x11' >> ${WRKSRC}/${PORTNAME}.pro
post-install:
${INSTALL_DATA} ${WRKSRC}/images/${PORTNAME}.png ${STAGEDIR}${DATADIR}
diff --git a/audio/dumb/Makefile b/audio/dumb/Makefile
index 0f291c0d0d87..9cf4697b7af3 100644
--- a/audio/dumb/Makefile
+++ b/audio/dumb/Makefile
@@ -21,7 +21,7 @@ ALLEGRO_DESC= Enable allegro support
LIB_DEPENDS+= liballeg.so:${PORTSDIR}/devel/allegro
PLIST_SUB+= ALLEGRO=""
MAKE_ARGS= _PORT_ALLEGRO_CFLAGS="`allegro-config --cflags`"
-MAKE_ARGS+= LINK_ALLEGRO="`allegro-config --libs`"
+MAKE_ARGS+= LINK_ALLEGRO="`allegro-config --libs` -lm"
PKGNAMESUFFIX= -allegro
CONFLICTS= dumb-[0-9]*
.else
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index f13487b18d87..80a3d3415ef7 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -24,6 +24,7 @@ CONFLICTS= py*-ro-[0-9]*
post-patch:
@${REINPLACE_CMD} -e 's|esdconf_DATA = esd.conf|esdconf_DATA = |g' \
+ -e '/^esd_LDADD =/s/$$/ -lm/' \
${WRKSRC}/Makefile.in
post-install:
diff --git a/audio/gmpc/Makefile b/audio/gmpc/Makefile
index 820c5f2136f6..9fc0ac69d3a0 100644
--- a/audio/gmpc/Makefile
+++ b/audio/gmpc/Makefile
@@ -26,7 +26,7 @@ USE_GNOME= glib20 gtk20 libglade2
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --enable-system-libsexy
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lm
OPTIONS_DEFINE= MMKEYS XSPF
OPTIONS_DEFAULT= MMKEYS
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
index 7483d1826a07..8ed829cd6d29 100644
--- a/audio/goobox/Makefile
+++ b/audio/goobox/Makefile
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lm
INSTALL_TARGET= install-strip
GCONF_SCHEMAS= goobox.schemas
diff --git a/audio/gqradio/Makefile b/audio/gqradio/Makefile
index 7ac5385d278d..527f4967e66e 100644
--- a/audio/gqradio/Makefile
+++ b/audio/gqradio/Makefile
@@ -17,7 +17,7 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lm
OPTIONS_DEFINE= DOCS V4L
diff --git a/audio/hydrogen/Makefile b/audio/hydrogen/Makefile
index d4974c968fea..b5b368cc28cf 100644
--- a/audio/hydrogen/Makefile
+++ b/audio/hydrogen/Makefile
@@ -28,7 +28,7 @@ OPTIONS_DEFAULT= JACK
LIBARCHIVE_DESC= LibArchive support
post-patch:
- ${REINPLACE_CMD} -e "s|includes = \[\]|includes = \['-I${QT_INCDIR}/QtCore', '-I${QT_INCDIR}/QtXml', '-I${QT_INCDIR}/QtGui', '-I${QT_INCDIR}', '-I${QT_INCDIR}/Qt', '-I${LOCALBASE}/include', '-I${LOCALBASE}/include/raptor2'\]|g; s|ldflags = \[\]|ldflags = \['-L${QT_LIBDIR}','-L${LOCALBASE}/lib'\,'-lQtCore', '-lQtGui', '-lQtXml', '-lQtNetwork', '${PTHREAD_LIBS}']|g" ${WRKSRC}/Sconstruct
+ ${REINPLACE_CMD} -e "s|includes = \[\]|includes = \['-I${QT_INCDIR}/QtCore', '-I${QT_INCDIR}/QtXml', '-I${QT_INCDIR}/QtGui', '-I${QT_INCDIR}', '-I${QT_INCDIR}/Qt', '-I${LOCALBASE}/include', '-I${LOCALBASE}/include/raptor2'\]|g; s|ldflags = \[\]|ldflags = \['-L${QT_LIBDIR}','-L${LOCALBASE}/lib'\,'-lQtCore', '-lQtGui', '-lQtXml', '-lQtNetwork']|g" ${WRKSRC}/Sconstruct
.include <bsd.port.options.mk>
@@ -36,8 +36,6 @@ MAKE_ARGS+= oss=1
.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= libjack.so:${PORTSDIR}/audio/jack
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
MAKE_ARGS+= jack=1
.else
MAKE_ARGS+= jack=0
diff --git a/audio/hydrogen/files/patch-Sconstruct b/audio/hydrogen/files/patch-Sconstruct
index cce4295e0f11..f817238e3c03 100644
--- a/audio/hydrogen/files/patch-Sconstruct
+++ b/audio/hydrogen/files/patch-Sconstruct
@@ -18,12 +18,21 @@
ldflags.append('-lpthread')
ldflags.append('-lasound')
# ldflags.append('-lrubberband')
-
+
+ elif sys.platform > 'freebsd' :
+ print "Alsa disabled; nothing to do"
elif sys.platform == "win32":
includes.append( '3rdparty\libsndfile-1_0_17' )
includes.append( 'build\pthreads\include' )
+@@ -279,7 +281,7 @@
+ if str(env['lash']) == "1":
+ env.ParseConfig('pkg-config --cflags --libs lash-1.0')
+
+- if sys.platform == "darwin" or sys.platform == "linux2" or sys.platform == "linux3":
++ if sys.platform == "darwin" or sys.platform == "linux2" or sys.platform == "linux3" or sys.platform > "freebsd":
+ env.Append( LIBS = ["z"] )
+ env.Append( LIBS = ["pthread"] )
+
@@ -299,7 +301,7 @@
for N in glob.glob('./data/i18n/hydrogen.*'):
@@ -46,4 +55,3 @@
print ""
-
diff --git a/audio/mixxx/files/patch-build__depends.py b/audio/mixxx/files/patch-build__depends.py
index bdcdfb98cd15..4102f892f831 100644
--- a/audio/mixxx/files/patch-build__depends.py
+++ b/audio/mixxx/files/patch-build__depends.py
@@ -67,7 +67,7 @@
elif build.toolchain_is_msvs:
# Validate the specified winlib directory exists
mixxx_lib_path = SCons.ARGUMENTS.get('winlib', '..\\..\\..\\mixxx-win32lib-msvc100-release')
-@@ -851,16 +847,19 @@
+@@ -851,16 +847,20 @@
elif build.platform_is_bsd:
build.env.Append(CPPDEFINES='__BSD__')
@@ -77,7 +77,7 @@
- build.env.Append(LIBPATH=['/usr/lib/',
- '/usr/local/lib',
- '/usr/X11R6/lib'])
-- build.env.Append(LIBS='pthread')
+ build.env.Append(LIBS='pthread')
+ build.env.Append(CPPPATH=['%%LOCALBASE%%/include/portaudio2',
+ '%%LOCALBASE%%/include/qt4',
+ '%%LOCALBASE%%/include'])
diff --git a/audio/osd-lyrics/Makefile b/audio/osd-lyrics/Makefile
index 087150075218..873393d81c4e 100644
--- a/audio/osd-lyrics/Makefile
+++ b/audio/osd-lyrics/Makefile
@@ -47,8 +47,8 @@ AMAROK_CONFIGURE_ENABLE= amarok1
post-patch:
.for i in src/Makefile.in src/tests/Makefile.in
- @${REINPLACE_CMD} -e \
- '/-lstdc++/d' ${WRKSRC}/${i}
+ @${REINPLACE_CMD} -e '/-lstdc++/d' -e '/^CCLD =/s/=.*/= $$(CXX)/' \
+ ${WRKSRC}/${i}
.endfor
.for i in lib/chardetect/Makefile.in
@${REINPLACE_CMD} -e \
diff --git a/audio/raop_play/Makefile b/audio/raop_play/Makefile
index 47c452c81444..7286ec42d186 100644
--- a/audio/raop_play/Makefile
+++ b/audio/raop_play/Makefile
@@ -23,6 +23,10 @@ LDFLAGS+= `fltk-config --ldflags`
USES= gmake
USE_GNOME= glib20
+post-patch:
+ @${REINPLACE_CMD} 's/-lssl/-lcrypto/' \
+ ${WRKSRC}/configure ${WRKSRC}/raop_play/Makefile.in
+
pre-build:
${CP} ${FILESDIR}/getline.c ${FILESDIR}/getline.h ${WRKSRC}/rendezvous/
diff --git a/audio/ripperx/Makefile b/audio/ripperx/Makefile
index 395ad969b51b..c0bf4d304fe9 100644
--- a/audio/ripperx/Makefile
+++ b/audio/ripperx/Makefile
@@ -15,8 +15,20 @@ LIB_DEPENDS= libid3.so:${PORTSDIR}/audio/id3lib
RUN_DEPENDS= cdparanoia:${PORTSDIR}/audio/cdparanoia
GNU_CONFIGURE= yes
-CFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= ac_cv_lib_id3_ID3Tag_Link=yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
USES= gmake pathfix pkgconfig
USE_GNOME= gtk20
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+post-patch:
+ @${REINPLACE_CMD} 's/-lstdc++/-lm/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^CCLD =/s/=.*/= $$(CXX)/' \
+ ${WRKSRC}/plugins/Makefile.in ${WRKSRC}/src/Makefile.in
+
.include <bsd.port.mk>
diff --git a/audio/shairport/Makefile b/audio/shairport/Makefile
index e8e1486e83d3..d81e74754b2e 100644
--- a/audio/shairport/Makefile
+++ b/audio/shairport/Makefile
@@ -41,6 +41,7 @@ post-patch:
-e 's|$$FindBin.*|"${PREFIX}/bin/hairtunes";|' \
-e '/use FindBin;/d;s|/usr/bin/env perl|${PERL}|' \
${WRKSRC}/shairport.c ${WRKSRC}/shairport.pl
+ @${REINPLACE_CMD} 's/-lssl/-lcrypto/' ${WRKSRC}/Makefile
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin