aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-12-05 21:18:03 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-12-05 21:18:03 +0000
commit2fb1ced42484bd4c8c359b72f1302a586b1d706b (patch)
tree48f68afe9ee73e0ebb4c2762514b4275b2881d1e /audio
parent39a407a2c68c2c3d7ada16ecf9a22b5965481e5c (diff)
downloadports-2fb1ced42484bd4c8c359b72f1302a586b1d706b.tar.gz
ports-2fb1ced42484bd4c8c359b72f1302a586b1d706b.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/musicpd/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index d09d75f7c194..502402be149e 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -35,6 +35,7 @@ SUB_FILES= pkg-message
OPTIONS= FLAC "Support FLAC audio format" on \
VORBIS "Support OGG Vorbis audio format" on \
+ TREMOR "Support Tremor (integer-only Vorbis)" off \
WAV "Support WAV audio format" on \
AAC "Support MP4/AAC audio format" off \
MUSEPACK "Support MPC audio format" off \
@@ -63,6 +64,11 @@ CONFIGURE_ARGS+=--disable-ogg
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
.endif
+.if defined(WITH_TREMOR)
+CONFIGURE_ARGS+=--with-tremor
+LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
+.endif
+
.if defined(WITHOUT_WAV)
CONFIGURE_ARGS+=--disable-audiofile
.else
@@ -119,7 +125,11 @@ LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
CONFIGURE_ARGS+=--disable-jack
.endif
-.if defined(WITHOUT_SHOUTCAST)
+# libshout streaming support will be disabled by configure script when built
+# also with tremor since the latter does not support vorbis encoding
+.if defined(WITH_SHOUTCAST) && !defined(WITH_TREMOR)
+LIB_DEPENDS+= shout.5:${PORTSDIR}/audio/libshout2
+.else
CONFIGURE_ARGS+=--disable-shout
.endif