aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-02-04 22:07:47 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-02-04 22:07:47 +0000
commit534e24316eadc8f47b01d3dc98b74fac1cfaf24f (patch)
treec0d99e4eea09b9a903a84bb9a1309484ea1c7d72 /audio
parent7fba08199bd0364ec03a98a9d16b1c89596f95a9 (diff)
downloadports-534e24316eadc8f47b01d3dc98b74fac1cfaf24f.tar.gz
ports-534e24316eadc8f47b01d3dc98b74fac1cfaf24f.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/aqualung/Makefile12
-rw-r--r--audio/aqualung/distinfo6
-rw-r--r--audio/aqualung/files/patch-src__playlist.c11
-rw-r--r--audio/aqualung/pkg-plist4
4 files changed, 27 insertions, 6 deletions
diff --git a/audio/aqualung/Makefile b/audio/aqualung/Makefile
index 83868254e98c..060b9c831caf 100644
--- a/audio/aqualung/Makefile
+++ b/audio/aqualung/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= aqualung
-DISTVERSION= 0.9beta6
+DISTVERSION= 0.9beta7
CATEGORIES= audio
MASTER_SITES= SF
@@ -26,21 +26,27 @@ LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
mac.2:${PORTSDIR}/audio/mac \
tag.5:${PORTSDIR}/audio/taglib \
lrdf.2:${PORTSDIR}/textproc/liblrdf \
+ cdio.7:${PORTSDIR}/sysutils/libcdio \
+ mp3lame.0:${PORTSDIR}/audio/lame \
+ avcodec.1:${PORTSDIR}/multimedia/ffmpeg-devel \
+ strfunc.9:${PORTSDIR}/devel/libstrfunc \
cddb.3:${PORTSDIR}/audio/libcddb
USE_GETTEXT= yes
USE_GNOME= pkgconfig gtk20 libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-transform-name="" --with-alsa=no --with-ifp=no --with-systray=no
+CONFIGURE_ARGS= --program-transform-name="" --with-alsa=no --with-ifp=no --with-systray=no \
+ --with-cdda=no
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+LDFLAGS= -L${LOCALBASE}/lib -lstrfunc
PORTDOCS= README manual.lyx manual.pdf
MAN1= ${PORTNAME}.1
post-patch:
@${REINPLACE_CMD} -e '/^docdir/s!=.*!= ${DOCSDIR}!' ${WRKSRC}/doc/Makefile.in
+# @${REINPLACE_CMD} -e 's/libcdio_paranoia/libcdda_paranoia/g' ${WRKSRC}/configure
.ifdef NOPORTDOCS
@${REINPLACE_CMD} -e '/^install-data-am/s!install-docDATA!!' ${WRKSRC}/doc/Makefile.in
.endif
diff --git a/audio/aqualung/distinfo b/audio/aqualung/distinfo
index 5d33abf8eebf..748e7160f4e3 100644
--- a/audio/aqualung/distinfo
+++ b/audio/aqualung/distinfo
@@ -1,3 +1,3 @@
-MD5 (aqualung-0.9beta6.tar.gz) = 4a019e923316615ad117548a87d4792e
-SHA256 (aqualung-0.9beta6.tar.gz) = beffef1349d6382033178f2252bca250f47557fbc29bfae2b04ebbe2f75f23d8
-SIZE (aqualung-0.9beta6.tar.gz) = 980248
+MD5 (aqualung-0.9beta7.tar.gz) = f5de05de722c713b78968854a47c54b2
+SHA256 (aqualung-0.9beta7.tar.gz) = 826da77ddb6426428db56b43b2e1c7a6df13372be2879c641fce0edf9f85060c
+SIZE (aqualung-0.9beta7.tar.gz) = 1064151
diff --git a/audio/aqualung/files/patch-src__playlist.c b/audio/aqualung/files/patch-src__playlist.c
new file mode 100644
index 000000000000..0f512e772868
--- /dev/null
+++ b/audio/aqualung/files/patch-src__playlist.c
@@ -0,0 +1,11 @@
+--- ./src/playlist.c.orig Mon Feb 5 00:46:43 2007
++++ ./src/playlist.c Mon Feb 5 00:47:06 2007
+@@ -51,6 +51,8 @@
+ #include "playlist.h"
+ #include "ifp_device.h"
+
++#include <strfunc.h>
++
+ extern options_t options;
+
+ extern void assign_audio_fc_filters(GtkFileChooser *fc);
diff --git a/audio/aqualung/pkg-plist b/audio/aqualung/pkg-plist
index c3386943198f..a853f1285cee 100644
--- a/audio/aqualung/pkg-plist
+++ b/audio/aqualung/pkg-plist
@@ -3,6 +3,7 @@ share/locale/hu/LC_MESSAGES/aqualung.mo
share/locale/de/LC_MESSAGES/aqualung.mo
share/locale/uk/LC_MESSAGES/aqualung.mo
%%DATADIR%%/appearance.png
+%%DATADIR%%/cdda.png
%%DATADIR%%/cddb.png
%%DATADIR%%/drag.png
%%DATADIR%%/dsp.png
@@ -15,6 +16,9 @@ share/locale/uk/LC_MESSAGES/aqualung.mo
%%DATADIR%%/logo.png
%%DATADIR%%/metadata.png
%%DATADIR%%/ms-artist.png
+%%DATADIR%%/ms-cdda.png
+%%DATADIR%%/ms-cdda-disk.png
+%%DATADIR%%/ms-cdda-nodisk.png
%%DATADIR%%/ms-record.png
%%DATADIR%%/ms-store.png
%%DATADIR%%/ms-track.png