aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-12-17 01:26:48 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-12-17 01:26:48 +0000
commit6984f7b2cb9c3eab761d01f30c86de5d7b89ef73 (patch)
tree573fe8f5bb83acc4fa7f656f5dcf4b8c443c6f7c /audio
parent4865f3ecf06e83c04ab0887cccb61ace9707971b (diff)
downloadports-6984f7b2cb9c3eab761d01f30c86de5d7b89ef73.tar.gz
ports-6984f7b2cb9c3eab761d01f30c86de5d7b89ef73.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/py-xmms/Makefile5
-rw-r--r--audio/py-xmms/distinfo2
-rw-r--r--audio/py-xmms/files/patch-setup.py27
3 files changed, 9 insertions, 25 deletions
diff --git a/audio/py-xmms/Makefile b/audio/py-xmms/Makefile
index 6e1a81038a95..d7f45eb3e4df 100644
--- a/audio/py-xmms/Makefile
+++ b/audio/py-xmms/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmms
-PORTVERSION= 2.00
+PORTVERSION= 2.02
CATEGORIES= audio python
MASTER_SITES= http://people.via.ecp.fr/~flo/2002/PyXMMS/dist/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -25,7 +25,4 @@ USE_GNOME= glib12
XMMS_CONFIG?= ${X11BASE}/bin/xmms-config
MAKE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" XMMS_CONFIG="${XMMS_CONFIG}"
-post-patch:
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} patch
-
.include <bsd.port.mk>
diff --git a/audio/py-xmms/distinfo b/audio/py-xmms/distinfo
index 561b89929191..5cd01aa1d21a 100644
--- a/audio/py-xmms/distinfo
+++ b/audio/py-xmms/distinfo
@@ -1 +1 @@
-MD5 (pyxmms-2.00.tar.bz2) = 42540506b82381a48219f3e1cb90a049
+MD5 (pyxmms-2.02.tar.bz2) = 57d5d475c0458613ac385affaea788bb
diff --git a/audio/py-xmms/files/patch-setup.py b/audio/py-xmms/files/patch-setup.py
index 779a41da0d69..21eca83fc6b3 100644
--- a/audio/py-xmms/files/patch-setup.py
+++ b/audio/py-xmms/files/patch-setup.py
@@ -1,38 +1,25 @@
---- setup.py.orig Sun Nov 9 12:15:24 2003
-+++ setup.py Mon Nov 10 20:55:24 2003
+--- setup.py.orig Wed Nov 19 19:52:54 2003
++++ setup.py Wed Dec 17 10:24:39 2003
@@ -20,7 +20,7 @@
# Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA.
-import os, string, sys, distutils.dist
-+import os, string, sys, re, distutils.dist
++import os, string, sys, distutils.dist, re
from distutils.core import setup, Extension
# Note:
-@@ -30,9 +30,21 @@
- # run the Distutils from Python 2.1, you will get License: UNKNOWN. This
- # problem does not appear with the versions included in Python 2.2 and 2.3.
+@@ -32,7 +32,8 @@
-+def patch4gcc3(fname):
-+ instr = 0
-+ cont = open(fname).readlines()
-+ of = open(fname, 'w')
-+ for l in cont:
-+ instr = (instr+len(re.findall(r'(^")|([^\\]")', l))) % 2
-+ print >>of, l[:-1] + ((not l.startswith('/*') and instr) and "\\n\\" or "")
-+if 'patch' in sys.argv:
-+ patch4gcc3('src/_xmmscontrolmodule.c')
-+ raise SystemExit
-+
PACKAGE = "pyxmms"
- VERSION = "2.00"
+ VERSION = "2.02"
-GLIB_CONFIG = "glib-config"
+GLIB_CONFIG = os.environ['GLIB_CONFIG']
+XMMS_CONFIG = os.environ['XMMS_CONFIG']
def get_glib_config():
-@@ -70,13 +82,16 @@
+@@ -70,13 +71,16 @@
def setup_args():
"""Craft appropriate arguments for distutils.setup."""
(glib_include_dirs, glib_compile_args, glib_link_args) = get_glib_config()
@@ -51,7 +38,7 @@
extra_link_args=glib_link_args)]
if sys.hexversion < 0x02020000:
-@@ -92,9 +107,9 @@
+@@ -92,9 +96,9 @@
# This module requires Python >= 2.2
ext_modules.append(Extension("xmms._xmmsconfig",
["src/_xmmsconfigmodule.c"],