aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-07-21 21:11:05 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-07-21 21:11:05 +0000
commita03ba739b7e112dfe6bee5620b31ab05def63294 (patch)
tree42c6145d4417747ec7b955b654e55f63a2ebf9fc /audio
parent7556ce58aebad0a281cc18df6df65571ed79bf75 (diff)
downloadports-a03ba739b7e112dfe6bee5620b31ab05def63294.tar.gz
ports-a03ba739b7e112dfe6bee5620b31ab05def63294.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/kexis/Makefile24
-rw-r--r--audio/kexis/distinfo3
-rw-r--r--audio/kexis/files/patch-Makefile10
-rw-r--r--audio/kexis/pkg-descr5
5 files changed, 43 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1f9a10c0cc8b..a99da19e972f 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -277,6 +277,7 @@
SUBDIR += juke
SUBDIR += jxm
SUBDIR += k3bmonkeyaudioplugin
+ SUBDIR += kexis
SUBDIR += klira
SUBDIR += kmp
SUBDIR += ksmp3play
diff --git a/audio/kexis/Makefile b/audio/kexis/Makefile
new file mode 100644
index 000000000000..f7c2ab76d2f6
--- /dev/null
+++ b/audio/kexis/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: kexis
+# Date created: 22 July 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kexis
+PORTVERSION= 0.2.2
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Lossless WAV file compressor
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/kexis
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/kexis ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/audio/kexis/distinfo b/audio/kexis/distinfo
new file mode 100644
index 000000000000..e1b24d5ff632
--- /dev/null
+++ b/audio/kexis/distinfo
@@ -0,0 +1,3 @@
+MD5 (kexis-0.2.2.tgz) = 87cd9bb0ef53bc0f7ed44d148011785a
+SHA256 (kexis-0.2.2.tgz) = 059d77fc009fae9c2f3ece906f0f4c8de792a5071d7b7c958e2b434c7d54b353
+SIZE (kexis-0.2.2.tgz) = 39350
diff --git a/audio/kexis/files/patch-Makefile b/audio/kexis/files/patch-Makefile
new file mode 100644
index 000000000000..51df7bc2456c
--- /dev/null
+++ b/audio/kexis/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- ./Makefile.orig Sat Jul 22 00:55:52 2006
++++ ./Makefile Sat Jul 22 00:56:34 2006
+@@ -1,7 +1,5 @@
+-DESTDIR =
+ SOURCE=encode.c decode.c header.c predictor.c bits.c rice.c kexis.c
+ OBJ = $(SOURCE:.c=.o)
+-CC=gcc
+
+ #PROFILE_OPTS = -g3 -pg -a
+
diff --git a/audio/kexis/pkg-descr b/audio/kexis/pkg-descr
new file mode 100644
index 000000000000..b820a22fb574
--- /dev/null
+++ b/audio/kexis/pkg-descr
@@ -0,0 +1,5 @@
+Kexis - A lossless WAV file compressor. Kexis' main goal is to develop
+prediction and encoding schemes to minimize compressed file size. Kexis
+strives to be the premier lossless sound encoder.
+
+WWW: http://sourceforge.net/projects/kexis/