aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-01-31 13:22:07 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-01-31 13:22:07 +0000
commit0fce276e946009d15b0db50247cc4600820562f4 (patch)
tree52c493112250b96a1a0ef6b94cc2194bbce3ca3b /audio
parentdc82288622d34560e7b5b3f567149805d8e2488d (diff)
downloadports-0fce276e946009d15b0db50247cc4600820562f4.tar.gz
ports-0fce276e946009d15b0db50247cc4600820562f4.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/dap/Makefile29
-rw-r--r--audio/dap/pkg-plist6
2 files changed, 25 insertions, 10 deletions
diff --git a/audio/dap/Makefile b/audio/dap/Makefile
index 55473bd5a9ab..9edc99d38d27 100644
--- a/audio/dap/Makefile
+++ b/audio/dap/Makefile
@@ -9,7 +9,8 @@ PORTNAME= dap
PORTVERSION= 2.1.5
PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= http://www.sourcefiles.org/Multimedia/Soundfile_Editors/
+MASTER_SITES= http://cvsup1.theplanet.com/distfiles/ \
+ http://www.sourcefiles.org/Multimedia/Soundfile_Editors/
EXTRACT_SUFX=.tgz
MAINTAINER= ports@FreeBSD.org
@@ -22,12 +23,32 @@ USE_XORG= xpm
MAKE_ENV+= OTHER_INCLUDE_DIR=. OTHER_LIBRARY_DIR=.
+PORTDOCS= COPYING README THANKS TODO
+PORTEXAMPLES= testautopan.dsp \
+ testmodulateddelay.dsp \
+ testphaser.dsp \
+ teststereoecho.dsp \
+ testflanger.dsp \
+ testmultitapdelay.dsp \
+ testreverb.dsp \
+ weirdflanger.dsp
+PLIST_FILES= bin/DAP
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/main/DAP ${PREFIX}/bin/
+
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/DAP/
- ${INSTALL_MAN} ${WRKSRC}/COPYING ${WRKSRC}/README \
- ${WRKSRC}/THANKS ${WRKSRC}/TODO ${PREFIX}/share/doc/DAP/
+ @${MKDIR} ${DOCSDIR}
+.for _DOC in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${_DOC} ${DOCSDIR}/${_DOC}
+.endfor
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for _EXAMPLE in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/main/effects/${_EXAMPLE} ${EXAMPLESDIR}/${_EXAMPLE}
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/audio/dap/pkg-plist b/audio/dap/pkg-plist
deleted file mode 100644
index da7d68587b78..000000000000
--- a/audio/dap/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/DAP
-%%PORTDOCS%%share/doc/DAP/COPYING
-%%PORTDOCS%%share/doc/DAP/README
-%%PORTDOCS%%share/doc/DAP/THANKS
-%%PORTDOCS%%share/doc/DAP/TODO
-%%PORTDOCS%%@dirrm share/doc/DAP