aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-29 17:31:14 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-29 17:31:14 +0000
commit8ef903640a256ab43495f880f2948117d54f4261 (patch)
tree303da4e7865822665cc0cced7094de15de85c61e /audio
parente75a8ad50f8f7569f4cc38b652cffd6188607c8b (diff)
downloadports-8ef903640a256ab43495f880f2948117d54f4261.tar.gz
ports-8ef903640a256ab43495f880f2948117d54f4261.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp-player/Makefile38
-rw-r--r--audio/mp-player/distinfo2
-rw-r--r--audio/mp-player/files/patch-mp.c19
-rw-r--r--audio/mp-player/pkg-descr10
5 files changed, 70 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index abcc272d7cb4..2eefe4d75d42 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -286,6 +286,7 @@
SUBDIR += mixxx
SUBDIR += moc
SUBDIR += modplugplay
+ SUBDIR += mp-player
SUBDIR += mp32ogg
SUBDIR += mp3_check
SUBDIR += mp3asm
diff --git a/audio/mp-player/Makefile b/audio/mp-player/Makefile
new file mode 100644
index 000000000000..877520ac8ba7
--- /dev/null
+++ b/audio/mp-player/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mp-player
+# Date created: 26 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp-player
+PORTVERSION= 0.6
+CATEGORIES= audio
+MASTER_SITES= http://mp.waw.cx/ \
+ http://critical.ch/distfiles/
+DISTNAME= mp-current
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A curses based module tracker using libmikmod
+
+LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lmikmod -pthread -lncurses -lpanel
+DEFINES= -D_REENTRANT
+
+WRKSRC= ${WRKDIR}/mp-beta-06
+
+PLIST_FILES= bin/mp-player
+
+post-patch:
+ @${RM} ${WRKSRC}/mp
+
+do-build:
+ ${CC} ${CFLAGS} ${LDFLAGS} ${DEFINES} ${WRKSRC}/mp.c -o ${WRKSRC}/mp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mp ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/audio/mp-player/distinfo b/audio/mp-player/distinfo
new file mode 100644
index 000000000000..8eb1b3ce4775
--- /dev/null
+++ b/audio/mp-player/distinfo
@@ -0,0 +1,2 @@
+MD5 (mp-current.tgz) = 276831a73c69bb30cc8a64e17b3305b9
+SIZE (mp-current.tgz) = 65370
diff --git a/audio/mp-player/files/patch-mp.c b/audio/mp-player/files/patch-mp.c
new file mode 100644
index 000000000000..d74b2eaeb994
--- /dev/null
+++ b/audio/mp-player/files/patch-mp.c
@@ -0,0 +1,19 @@
+--- mp.c.orig Fri Aug 26 09:59:36 2005
++++ mp.c Fri Aug 26 09:59:57 2005
+@@ -27,7 +27,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+
+ #include <curses.h>
+ #include <panel.h>
+@@ -41,6 +41,7 @@
+ ******************************************************************************/
+
+ #define VERSION "0.6" /* here it is */
++#define NAME_MAX 255
+
+
+ /*** Various. ***/
diff --git a/audio/mp-player/pkg-descr b/audio/mp-player/pkg-descr
new file mode 100644
index 000000000000..1d3047dd6499
--- /dev/null
+++ b/audio/mp-player/pkg-descr
@@ -0,0 +1,10 @@
+MP is a module player using libmikmod. It is able to play 18 module formats,
+such as MOD, XM, S3M, and IT.
+
+MP features real volume gauges, sound effects control, various options,
+easy-to-manage playing lists, and more.
+
+WWW: http://mp.waw.cx/
+
+- ehaupt
+ehaupt@critical.ch