aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-09 07:53:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-09 07:53:16 +0000
commitaffe8bbb8ad69fdb97e20f0507b0a88e6ae0d1dc (patch)
tree3db2972b8b19202c6d3cf05cca1b4ff41d3a5154 /audio
parent2628991f09ec9f6f349f5b993b4aee27aaaf1805 (diff)
downloadports-affe8bbb8ad69fdb97e20f0507b0a88e6ae0d1dc.tar.gz
ports-affe8bbb8ad69fdb97e20f0507b0a88e6ae0d1dc.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3val/Makefile27
-rw-r--r--audio/mp3val/distinfo3
-rw-r--r--audio/mp3val/pkg-descr18
4 files changed, 49 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 802ad6adee2f..f73b9e764a2e 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -476,6 +476,7 @@
SUBDIR += mp3stat
SUBDIR += mp3towav-bundle
SUBDIR += mp3unicode
+ SUBDIR += mp3val
SUBDIR += mp3wrap
SUBDIR += mpc
SUBDIR += mpdas
diff --git a/audio/mp3val/Makefile b/audio/mp3val/Makefile
new file mode 100644
index 000000000000..a220e5b5db10
--- /dev/null
+++ b/audio/mp3val/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mp3val
+# Date created: 2010-04-19
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3val
+PORTVERSION= 0.1.8
+CATEGORIES= audio
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= A program for MPEG audio stream validation
+
+ALL_TARGET= mp3val
+MAKEFILE= ${WRKSRC}/Makefile.linux
+PLIST_FILES= bin/mp3val
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/mp3val ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/audio/mp3val/distinfo b/audio/mp3val/distinfo
new file mode 100644
index 000000000000..829c07b43a2e
--- /dev/null
+++ b/audio/mp3val/distinfo
@@ -0,0 +1,3 @@
+MD5 (mp3val-0.1.8-src.tar.gz) = dc8adad909d0b8734ed22029b2de2cb4
+SHA256 (mp3val-0.1.8-src.tar.gz) = 95a16efe3c352bb31d23d68ee5cb8bb8ebd9868d3dcf0d84c96864f80c31c39f
+SIZE (mp3val-0.1.8-src.tar.gz) = 21406
diff --git a/audio/mp3val/pkg-descr b/audio/mp3val/pkg-descr
new file mode 100644
index 000000000000..2552c981f85f
--- /dev/null
+++ b/audio/mp3val/pkg-descr
@@ -0,0 +1,18 @@
+MP3val is a small, high-speed, free software tool for checking MPEG audio
+files' integrity. It can be useful for finding corrupted files (e.g.
+incompletely downloaded, truncated, containing garbage). MP3val is also able
+to fix most of the problems. Being a multiplatform application, MP3val can be
+runned both under Windows and under Linux (or BSD).
+
+The most common MPEG audio file type is MPEG 1 Layer III (mp3), but MP3val
+supports also other MPEG versions and layers. The tool is also aware of the
+most common types of tags (ID3v1, ID3v2, APEv2).
+
+The core component of MP3val is an application with command-line interface.
+There are also two graphical frontends for it: MP3val-frontend is a native
+Windows application (it is also included in the latest binary releases for
+Windows), mp3valgui is a multi-platform Python script (can be downloaded
+separately), written by an independent developer. Installing the latter under
+Windows is a bit tricky, so for Windows the first frontend is recommended.
+
+WWW: http://mp3val.sourceforge.net/