aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-25 07:59:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-25 07:59:21 +0000
commite3122c9ae2116e3b2c9e65a090a927e0a6103651 (patch)
tree496a8b3dca254189d5d80866f6dc7f93c4c52232 /audio
parent10cb7d0c7375277e1de9e5bed814f31f437216d2 (diff)
downloadports-e3122c9ae2116e3b2c9e65a090a927e0a6103651.tar.gz
ports-e3122c9ae2116e3b2c9e65a090a927e0a6103651.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/disc-cover/Makefile45
-rw-r--r--audio/disc-cover/distinfo1
-rw-r--r--audio/disc-cover/pkg-comment1
-rw-r--r--audio/disc-cover/pkg-descr7
-rw-r--r--audio/disc-cover/pkg-plist2
6 files changed, 57 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index e77788e4075e..3fb7a19a8a74 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -39,6 +39,7 @@
SUBDIR += dap
SUBDIR += darkice
SUBDIR += denemo
+ SUBDIR += disc-cover
SUBDIR += easytag
SUBDIR += ecasound
SUBDIR += ecawave
diff --git a/audio/disc-cover/Makefile b/audio/disc-cover/Makefile
new file mode 100644
index 000000000000..0960acd6d44a
--- /dev/null
+++ b/audio/disc-cover/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: disc-cover
+# Date created: 20 Jan 2002
+# Whom: Miguel Mendez <flynn@energyhq.homeip.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= disc-cover
+PORTVERSION= 1.0.1
+CATEGORIES= audio
+MASTER_SITES= http://www.liacs.nl/~jvhemert/disc-cover/download/stable/
+
+MAINTAINER= flynn@energyhq.homeip.net
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/FreeDB.pm:${PORTSDIR}/audio/p5-FreeDB \
+ latex:${PORTSDIR}/print/latex \
+ dvips:${PORTSDIR}/print/dvips \
+ convert:${PORTSDIR}/graphics/ImageMagick
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_REINPLACE= yes
+
+MAN1= disc-cover.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's@/etc/disc-cover.conf@${LOCALBASE}/etc/disc-cover.conf@g' ${WRKSRC}/disc-cover
+ @${ECHO_CMD} "all:" > ${WRKSRC}/Makefile
+ @${ECHO_CMD} >> ${WRKSRC}/Makefile
+ @${ECHO_CMD} "install:" >> ${WRKSRC}/Makefile
+
+# This port doesn't have a Makefile, and we need to fix some stuff (like the conf file name)
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/disc-cover ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/example.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
+ @${INSTALL_MAN} ${WRKSRC}/disc-cover.1 ${MANPREFIX}/man/man1
+ @${ECHO_CMD}
+ @${ECHO_CMD} " ############################################################"
+ @${ECHO_CMD} " You can set your preferences by editing the file ${PORTNAME}.conf.sample"
+ @${ECHO_CMD} " in ${PREFIX}/etc and renaming it to ${PORTNAME}.conf"
+ @${ECHO_CMD} " ############################################################"
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/audio/disc-cover/distinfo b/audio/disc-cover/distinfo
new file mode 100644
index 000000000000..38208f942888
--- /dev/null
+++ b/audio/disc-cover/distinfo
@@ -0,0 +1 @@
+MD5 (disc-cover-1.0.1.tar.gz) = 605aa577d2f0164bdabb7a631bae8251
diff --git a/audio/disc-cover/pkg-comment b/audio/disc-cover/pkg-comment
new file mode 100644
index 000000000000..f65dd1ff4e6c
--- /dev/null
+++ b/audio/disc-cover/pkg-comment
@@ -0,0 +1 @@
+Tool to produce covers from audio CDs using FreeDB
diff --git a/audio/disc-cover/pkg-descr b/audio/disc-cover/pkg-descr
new file mode 100644
index 000000000000..cdecbca0f825
--- /dev/null
+++ b/audio/disc-cover/pkg-descr
@@ -0,0 +1,7 @@
+disc-cover provides an easy way to produce covers for audio cds. It scans
+audio cds and uses information from the freedb database to build a back and
+front cover for the cd. The cover is output is in Latex, Dvi, Pdf or
+Postscript.
+
+WWW: http://www.liacs.nl/~jvhemert/disc-cover/
+Miguel Mendez <flynn@energyhq.homeip.net>
diff --git a/audio/disc-cover/pkg-plist b/audio/disc-cover/pkg-plist
new file mode 100644
index 000000000000..fb0791a327c7
--- /dev/null
+++ b/audio/disc-cover/pkg-plist
@@ -0,0 +1,2 @@
+bin/disc-cover
+etc/disc-cover.conf.sample