aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-03-19 13:04:30 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-03-19 13:04:30 +0000
commit334eb0fc61312986b1d9f56b24c7518920f81462 (patch)
treeeba3c1f7e94497327507881e3b0eb623013d377e /audio
parentaf5cd17df996051954e3a13bcaba16d71c593585 (diff)
downloadports-334eb0fc61312986b1d9f56b24c7518920f81462.tar.gz
ports-334eb0fc61312986b1d9f56b24c7518920f81462.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/aubio/Makefile2
-rw-r--r--audio/ccaudio2/Makefile2
-rw-r--r--audio/celt/Makefile2
-rw-r--r--audio/dssi/Makefile2
-rw-r--r--audio/esound/Makefile2
-rw-r--r--audio/ksmp3play/Makefile2
-rw-r--r--audio/libaudiofile/Makefile2
-rw-r--r--audio/libcddb/Makefile2
-rw-r--r--audio/libgig/Makefile2
-rw-r--r--audio/liblo/Makefile2
-rw-r--r--audio/liblscp/Makefile2
-rw-r--r--audio/libmtp/Makefile2
-rw-r--r--audio/libnjb/Makefile2
-rw-r--r--audio/libofa/Makefile2
-rw-r--r--audio/libogg/Makefile2
-rw-r--r--audio/libsamplerate/Makefile2
-rw-r--r--audio/libsidplay2/Makefile2
-rw-r--r--audio/libvorbis/Makefile2
-rw-r--r--audio/linuxsampler/Makefile2
-rw-r--r--audio/opencore-amr/Makefile2
-rw-r--r--audio/opus/Makefile2
-rw-r--r--audio/paman/Makefile2
-rw-r--r--audio/sdl_mixer/Makefile2
-rw-r--r--audio/taglib-sharp/Makefile2
24 files changed, 24 insertions, 24 deletions
diff --git a/audio/aubio/Makefile b/audio/aubio/Makefile
index 00cda36029d6..5deb87727517 100644
--- a/audio/aubio/Makefile
+++ b/audio/aubio/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
# --disable-complex: does not compile due to missing carg(3) et al.
CONFIGURE_ARGS= --disable-complex
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
USE_PKGCONFIG= build
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
index c508927b411c..26836222f7f6 100644
--- a/audio/ccaudio2/Makefile
+++ b/audio/ccaudio2/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= ccgnu2:${PORTSDIR}/devel/commoncpp \
CONFLICTS= ccaudio-[0-9]*
USE_PKGCONFIG= build
-USE_GNOME= gnomehack
+USES= pathfix
USE_CMAKE= yes
CMAKE_OUTSOURCE=yes
USE_LDCONFIG= yes
diff --git a/audio/celt/Makefile b/audio/celt/Makefile
index b5c2ae60b9ba..0b060343dd6f 100644
--- a/audio/celt/Makefile
+++ b/audio/celt/Makefile
@@ -23,6 +23,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ogg=${LOCALBASE}
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack
+USES= pathfix
.include <bsd.port.mk>
diff --git a/audio/dssi/Makefile b/audio/dssi/Makefile
index 0f276129d340..235e202969b2 100644
--- a/audio/dssi/Makefile
+++ b/audio/dssi/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
OPTIONS_DEFINE= QT4
-USE_GNOME= gnomehack
+USES= pathfix
USE_GMAKE= yes
USE_PKGCONFIG= build
GNU_CONFIGURE= yes
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index e6a7f089be46..4e02dfa4efea 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_PKGCONFIG= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/audio/ksmp3play/Makefile b/audio/ksmp3play/Makefile
index 1abbb8d560e1..bdb4068599d0 100644
--- a/audio/ksmp3play/Makefile
+++ b/audio/ksmp3play/Makefile
@@ -13,7 +13,7 @@ COMMENT= Curses-based MP3 player
LIB_DEPENDS= smpeg:${PORTSDIR}/multimedia/smpeg
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_SDL= sdl
NO_WRKSUBDIR= yes
diff --git a/audio/libaudiofile/Makefile b/audio/libaudiofile/Makefile
index af705e96ee5b..95822320bb86 100644
--- a/audio/libaudiofile/Makefile
+++ b/audio/libaudiofile/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A sound library for SGI audio file
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/audio/libcddb/Makefile b/audio/libcddb/Makefile
index 95ab751ef345..e0014e1234b4 100644
--- a/audio/libcddb/Makefile
+++ b/audio/libcddb/Makefile
@@ -12,7 +12,7 @@ COMMENT= A library to access data on a CDDB server
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_PKGCONFIG= build
USE_ICONV= yes
USE_LDCONFIG= yes
diff --git a/audio/libgig/Makefile b/audio/libgig/Makefile
index 8b35131607ee..e30d17b6c351 100644
--- a/audio/libgig/Makefile
+++ b/audio/libgig/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= FLAC.10:${PORTSDIR}/audio/flac \
uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
USE_BZIP2= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/audio/liblo/Makefile b/audio/liblo/Makefile
index 659d75a16a91..605acff2b694 100644
--- a/audio/liblo/Makefile
+++ b/audio/liblo/Makefile
@@ -16,6 +16,6 @@ COMMENT= Lightweight Open Sound Control implementation
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack
+USES= pathfix
.include <bsd.port.mk>
diff --git a/audio/liblscp/Makefile b/audio/liblscp/Makefile
index 036fcdab4338..59585e1b4eb7 100644
--- a/audio/liblscp/Makefile
+++ b/audio/liblscp/Makefile
@@ -16,7 +16,7 @@ COMMENT= Wrapper around the LSCP network protocol
LICENSE= LGPL21
-USE_GNOME= gnomehack
+USES= pathfix
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/audio/libmtp/Makefile b/audio/libmtp/Makefile
index 00bf3b0678bb..fa9d5cab5eed 100644
--- a/audio/libmtp/Makefile
+++ b/audio/libmtp/Makefile
@@ -15,7 +15,7 @@ OPTIONS_DEFINE= MTPZ
OPTIONS_DEFAULT= MTPZ
MTPZ_DESC= Enable functionality to connect to MTPZ devices
-USE_GNOME= gnomehack
+USES= pathfix
USE_ICONV= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/audio/libnjb/Makefile b/audio/libnjb/Makefile
index 00762b9a6f0b..f13f8cbfa160 100644
--- a/audio/libnjb/Makefile
+++ b/audio/libnjb/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS_DEFINE= DOCS
-USE_GNOME= gnomehack
+USES= pathfix
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/audio/libofa/Makefile b/audio/libofa/Makefile
index 3631208ece3c..bef9697d14e6 100644
--- a/audio/libofa/Makefile
+++ b/audio/libofa/Makefile
@@ -28,7 +28,7 @@ LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
PROJECTHOST= musicip-libofa
USE_DOS2UNIX= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack
+USES= pathfix
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/audio/libogg/Makefile b/audio/libogg/Makefile
index 367b411d1c41..0c99c98b8053 100644
--- a/audio/libogg/Makefile
+++ b/audio/libogg/Makefile
@@ -12,7 +12,7 @@ COMMENT= Ogg bitstream library
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/audio/libsamplerate/Makefile b/audio/libsamplerate/Makefile
index 4a8899227f14..629ae9f3ea3a 100644
--- a/audio/libsamplerate/Makefile
+++ b/audio/libsamplerate/Makefile
@@ -13,7 +13,7 @@ COMMENT= Secret Rabbit Code: a Sample Rate Converter for audio
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNOME= gnomehack
+USES= pathfix
USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/audio/libsidplay2/Makefile b/audio/libsidplay2/Makefile
index 4c68292f68d1..bcf6e17ba934 100644
--- a/audio/libsidplay2/Makefile
+++ b/audio/libsidplay2/Makefile
@@ -15,7 +15,7 @@ DISTNAME= sidplay-libs-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to play Commodore 64 SID-tunes cycle accurate
-USE_GNOME= gnomehack
+USES= pathfix
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_PKGCONFIG= yes
diff --git a/audio/libvorbis/Makefile b/audio/libvorbis/Makefile
index 7572d10142d3..c6e659674561 100644
--- a/audio/libvorbis/Makefile
+++ b/audio/libvorbis/Makefile
@@ -14,7 +14,7 @@ COMMENT= Audio compression codec library
LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
USE_XZ= yes
diff --git a/audio/linuxsampler/Makefile b/audio/linuxsampler/Makefile
index 847b057a188b..931a91d50a7b 100644
--- a/audio/linuxsampler/Makefile
+++ b/audio/linuxsampler/Makefile
@@ -23,7 +23,7 @@ DSSI_DESC= Enable DSSI support
LV2CORE_DESC= Enable LV2 support
USE_BZIP2= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_SQLITE= 3
USE_PKGCONFIG= build
USE_GMAKE= yes
diff --git a/audio/opencore-amr/Makefile b/audio/opencore-amr/Makefile
index 70c89c19a70a..1e0faeede480 100644
--- a/audio/opencore-amr/Makefile
+++ b/audio/opencore-amr/Makefile
@@ -17,7 +17,7 @@ LICENSE= AL2
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/audio/opus/Makefile b/audio/opus/Makefile
index 472c2ab1c12e..089254b1ae54 100644
--- a/audio/opus/Makefile
+++ b/audio/opus/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= naddy@FreeBSD.org
COMMENT= IETF audio codec
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/audio/paman/Makefile b/audio/paman/Makefile
index 48ca82e943ce..1f4c3ee71ac4 100644
--- a/audio/paman/Makefile
+++ b/audio/paman/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USES= pathfix
CONFIGURE_ARGS= --disable-lynx
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 3834ad287481..39622ee1e809 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -16,7 +16,7 @@ LICENSE= ZLIB
USE_AUTOTOOLS= libtool
USE_SDL= sdl
USE_PKGCONFIG= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_GMAKE= yes
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/audio/taglib-sharp/Makefile b/audio/taglib-sharp/Makefile
index a5447adc5034..6cf7613b46ce 100644
--- a/audio/taglib-sharp/Makefile
+++ b/audio/taglib-sharp/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_PKGCONFIG= build
PLIST_SUB+= PORTVERSION="${PORTVERSION}" \