aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-06 11:06:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-06 11:06:48 +0000
commit65eaf47a9bf44056be1e4d37c33417df6bcb75c0 (patch)
tree39ca394345af82184485bbac307a4e87519374dc /audio
parentf5491cd4d655c54dafa20ba4d9db6a4088cdd470 (diff)
downloadports-65eaf47a9bf44056be1e4d37c33417df6bcb75c0.tar.gz
ports-65eaf47a9bf44056be1e4d37c33417df6bcb75c0.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/festalon/Makefile1
-rw-r--r--audio/libcddb/Makefile10
-rw-r--r--audio/libconvolve/Makefile7
-rw-r--r--audio/libsamplerate/Makefile9
-rw-r--r--audio/lmms/Makefile1
-rw-r--r--audio/rubberband/Makefile2
6 files changed, 11 insertions, 19 deletions
diff --git a/audio/festalon/Makefile b/audio/festalon/Makefile
index 53729d109be6..1fc1a170b45a 100644
--- a/audio/festalon/Makefile
+++ b/audio/festalon/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
+USE_PKGCONFIG= build
MAKE_JOBS_SAFE= yes
diff --git a/audio/libcddb/Makefile b/audio/libcddb/Makefile
index 41a7afd0f493..91aecc3b7ebb 100644
--- a/audio/libcddb/Makefile
+++ b/audio/libcddb/Makefile
@@ -1,10 +1,5 @@
-# New ports collection makefile for: libcddb
-# Date created: Mon Mar 1 00:48:58 EST 2004
-# Whom: Michael Johnson <ahze@ahze.net>
-#
+# Created by: Michael Johnson <ahze@ahze.net>
# $FreeBSD$
-# $MCom: ports-stable/audio/libcddb/Makefile,v 1.1 2005/08/09 04:21:26 ahze Exp $
-# $Id: Makefile 17 2006-10-17 02:09:55Z buhnux $
PORTNAME= libcddb
PORTVERSION= 1.3.2
@@ -17,7 +12,8 @@ COMMENT= A library to access data on a CDDB server
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack
+USE_PKGCONFIG= bild
USE_ICONV= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --without-cdio
diff --git a/audio/libconvolve/Makefile b/audio/libconvolve/Makefile
index de4b773c694f..88b3bb46734a 100644
--- a/audio/libconvolve/Makefile
+++ b/audio/libconvolve/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libconvolve
-# Date created: 2007-04-02
-# Whom: trasz <trasz@pin.if.uz.zgora.pl>
-#
+# Created by: trasz <trasz@pin.if.uz.zgora.pl>
# $FreeBSD$
-#
PORTNAME= libconvolve
PORTVERSION= 0.0.8
@@ -25,5 +21,6 @@ LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
USE_GMAKE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
.include <bsd.port.mk>
diff --git a/audio/libsamplerate/Makefile b/audio/libsamplerate/Makefile
index 77b53086057c..4a8899227f14 100644
--- a/audio/libsamplerate/Makefile
+++ b/audio/libsamplerate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libsamplerate
-# Date created: 2 February 2003
-# Whom: <dmagda+libsamplerate@ee.ryerson.ca>
-#
+# Created by: <dmagda+libsamplerate@ee.ryerson.ca>
# $FreeBSD$
-#
PORTNAME= libsamplerate
PORTVERSION= 0.1.8
@@ -17,7 +13,8 @@ COMMENT= Secret Rabbit Code: a Sample Rate Converter for audio
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack
+USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/audio/lmms/Makefile b/audio/lmms/Makefile
index 5d1cc85dced4..cff7d158aea9 100644
--- a/audio/lmms/Makefile
+++ b/audio/lmms/Makefile
@@ -36,6 +36,7 @@ OPTIONS= JACK "Enable JACK support" OFF \
SDL "Enable SDL support" OFF
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
USE_BZIP2= yes
USE_XORG= xft
USE_QT4= corelib gui xml moc_build uic_build rcc_build \
diff --git a/audio/rubberband/Makefile b/audio/rubberband/Makefile
index 7ca540f4d8cd..56eaa6bca209 100644
--- a/audio/rubberband/Makefile
+++ b/audio/rubberband/Makefile
@@ -32,6 +32,6 @@ CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= build
.include <bsd.port.mk>