aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-29 19:26:52 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-29 19:26:52 +0000
commit1cf3b6123a79e95c57f01ade87b08b95a5870f93 (patch)
tree067daa3ef62c0e419270ef1024e3746b95540d93 /audio
parentaa2777931138e124fa6474cce9c8601f82b30fd3 (diff)
downloadports-1cf3b6123a79e95c57f01ade87b08b95a5870f93.tar.gz
ports-1cf3b6123a79e95c57f01ade87b08b95a5870f93.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/py-sdl_mixer/Makefile4
-rw-r--r--audio/py-sdl_mixer/files/patch-setup.py19
2 files changed, 23 insertions, 0 deletions
diff --git a/audio/py-sdl_mixer/Makefile b/audio/py-sdl_mixer/Makefile
index 5615c3dfc024..ca977e9eac89 100644
--- a/audio/py-sdl_mixer/Makefile
+++ b/audio/py-sdl_mixer/Makefile
@@ -30,6 +30,10 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-sdl-mixer
post-patch:
@${REINPLACE_CMD} -e 's,"SDL","SDL-1.1",g' ${WRKSRC}/setup.py
@${REINPLACE_CMD} -e 's,SDL/SDL,SDL11/SDL,g' ${WRKSRC}/sdl_mixer.c
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/setup.py
post-install:
.if !defined(NOPORTDOCS)
diff --git a/audio/py-sdl_mixer/files/patch-setup.py b/audio/py-sdl_mixer/files/patch-setup.py
new file mode 100644
index 000000000000..2825bbe40d53
--- /dev/null
+++ b/audio/py-sdl_mixer/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py.orig Fri Oct 28 00:13:10 2005
++++ setup.py Fri Oct 28 00:14:18 2005
+@@ -17,12 +17,14 @@
+
+ INCDIR = [
+ "/usr/include",
+- "/usr/local/include",
++ "%%LOCALBASE%%/include",
++ "%%X11BASE%%/include",
+ "/sw/include", # For Mac OS X
+ ]
+ LIBDIR = [
+ "/usr/lib",
+- "/usr/local/lib",
++ "%%LOCALBASE%%/lib",
++ "%%X11BASE%%/lib",
+ "/sw/lib/", # For Mac OS X
+ ]
+