aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-01 00:29:53 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-01 00:29:53 +0000
commit93f5de35defe9c2ffb8c7ae1cd0395d98c472f31 (patch)
tree6553bd2a07ec728af4b458c3c1b9b19893d0c103 /audio
parent976f4ae4707ec9e27c9c05b1c0ff56d76bd4ef46 (diff)
downloadports-93f5de35defe9c2ffb8c7ae1cd0395d98c472f31.tar.gz
ports-93f5de35defe9c2ffb8c7ae1cd0395d98c472f31.zip
MFH: r516205
- Produce meaningful error when timidity is built without required option - Add USES=sdl PR: 238080 Reported by: list1@gjunka.com Approved by: ports-secteam (with hat)
Notes
Notes: svn path=/branches/2019Q4/; revision=516206
Diffstat (limited to 'audio')
-rw-r--r--audio/sdl_sound/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/audio/sdl_sound/Makefile b/audio/sdl_sound/Makefile
index e9fb7826b84c..090e9447b67d 100644
--- a/audio/sdl_sound/Makefile
+++ b/audio/sdl_sound/Makefile
@@ -14,7 +14,7 @@ COMMENT= SDL audio library and player for some popular sound file formats
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= libtool localbase
+USES= libtool localbase sdl
GNU_CONFIGURE= yes
USE_SDL= sdl
INSTALL_TARGET= install-strip
@@ -49,14 +49,21 @@ SPEEX_LIB_DEPENDS= libspeex.so:audio/speex \
SPEEX_CONFIGURE_ENABLE= speex
MIDI_DESC= Software MIDI music
-MIDI_RUN_DEPENDS= ${LOCALBASE}/lib/timidity/goemon.cfg:audio/timidity
-MIDI_BUILD_DEPENDS= ${LOCALBASE}/lib/timidity/goemon.cfg:audio/timidity
+MIDI_RUN_DEPENDS= timidity>=0:audio/timidity
+MIDI_BUILD_DEPENDS= timidity>=0:audio/timidity
MIDI_CONFIGURE_ENABLE= midi
VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg
VORBIS_CONFIGURE_ENABLE=ogg
+pre-configure-MIDI-on:
+ @if ! [ -e "${LOCALBASE}/lib/timidity/goemon.cfg" ]; then \
+ ${ECHO_CMD} 'MIDI support requires audio/timidity port to be built with GOEMON option enabled, which is not the case'; \
+ ${ECHO_CMD} 'Please, run `make -C ${PORTSDIR}/audio/timidity config` and enable GOEMON option to continue'; \
+ ${FALSE}; \
+ fi
+
post-patch:
@${REINPLACE_CMD} 's|timidity.cfg|${PREFIX}/share/timidity/&|' \
${WRKSRC}/decoders/timidity/options.h