aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2012-10-27 15:48:57 +0000
committerJason E. Hale <jhale@FreeBSD.org>2012-10-27 15:48:57 +0000
commitaaab263f360a2acc677117ed0bf83301ff260a2a (patch)
tree65c2b2280dfb54379d9ff921f0cc0a0fde54889c /audio
parent59d5b6f0115119c0bac15276622275e9fb9f40f7 (diff)
downloadports-aaab263f360a2acc677117ed0bf83301ff260a2a.tar.gz
ports-aaab263f360a2acc677117ed0bf83301ff260a2a.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/chromaprint/Makefile26
-rw-r--r--audio/chromaprint/distinfo2
-rw-r--r--audio/chromaprint/pkg-descr6
-rw-r--r--audio/chromaprint/pkg-plist6
5 files changed, 41 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index d1de5ce5454e..74ca324d20ee 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -94,6 +94,7 @@
SUBDIR += checkmate
SUBDIR += cheesetracker
SUBDIR += chordpack
+ SUBDIR += chromaprint
SUBDIR += clementine-player
SUBDIR += clunk
SUBDIR += cmp3
diff --git a/audio/chromaprint/Makefile b/audio/chromaprint/Makefile
new file mode 100644
index 000000000000..412034f9e759
--- /dev/null
+++ b/audio/chromaprint/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= chromaprint
+PORTVERSION= 0.7
+CATEGORIES= audio
+MASTER_SITES= http://cloud.github.com/downloads/lalinsky/${PORTNAME}/
+
+MAINTAINER= jhale@FreeBSD.org
+COMMENT= AcoustID audio fingerprinting library
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= avcodec:${PORTSDIR}/multimedia/ffmpeg
+
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=ON \
+ -DWITH_AVFFT:BOOL=ON
+
+post-patch:
+ ${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/audio/chromaprint/distinfo b/audio/chromaprint/distinfo
new file mode 100644
index 000000000000..019e3e70ea03
--- /dev/null
+++ b/audio/chromaprint/distinfo
@@ -0,0 +1,2 @@
+SHA256 (chromaprint-0.7.tar.gz) = 4e52c3fd443c91a5c429557753d4ba3f9d31d183810412c0d8600892f3975501
+SIZE (chromaprint-0.7.tar.gz) = 543811
diff --git a/audio/chromaprint/pkg-descr b/audio/chromaprint/pkg-descr
new file mode 100644
index 000000000000..cd0a5ca842a5
--- /dev/null
+++ b/audio/chromaprint/pkg-descr
@@ -0,0 +1,6 @@
+Chromaprint is the core component of the AcoustID project. It is
+a client-side library that implements a custom algorithm for
+extracting fingerprints from any audio source. Also included is
+fpcalc, a small utility for calculating AcoustID fingerprints.
+
+WWW: http://acoustid.org/chromaprint
diff --git a/audio/chromaprint/pkg-plist b/audio/chromaprint/pkg-plist
new file mode 100644
index 000000000000..13edddd072e4
--- /dev/null
+++ b/audio/chromaprint/pkg-plist
@@ -0,0 +1,6 @@
+bin/fpcalc
+include/chromaprint.h
+lib/libchromaprint.so
+lib/libchromaprint.so.0
+lib/libchromaprint.so.0.2.0
+libdata/pkgconfig/libchromaprint.pc