aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-17 19:56:46 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-17 19:56:46 +0000
commitdb1d046ac8c54e372295abbce31cabfe362775d7 (patch)
tree128c583930a4c954218c889dd2ef1c4912e488db /audio
parent54e2a19b7fa2e806ac7f99e01884fe42c098a894 (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/jalv/Makefile41
-rw-r--r--audio/jalv/distinfo3
-rw-r--r--audio/jalv/files/patch-wscript11
-rw-r--r--audio/jalv/pkg-descr9
-rw-r--r--audio/jalv/pkg-plist9
6 files changed, 74 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1b44c4777cd4..4906fe99474a 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -336,6 +336,7 @@
SUBDIR += jack_ghero
SUBDIR += jack_mixer
SUBDIR += jack_umidi
+ SUBDIR += jalv
SUBDIR += jamin
SUBDIR += jid3lib
SUBDIR += jmusic
diff --git a/audio/jalv/Makefile b/audio/jalv/Makefile
new file mode 100644
index 000000000000..2a77404306bc
--- /dev/null
+++ b/audio/jalv/Makefile
@@ -0,0 +1,41 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= jalv
+PORTVERSION= 1.6.0
+CATEGORIES= audio
+MASTER_SITES= http://download.drobilla.net/
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Simple but fully featured LV2 plugin host for Jack
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>=1.14.0:audio/lv2
+LIB_DEPENDS= liblilv-0.so:audio/lilv \
+ libsratom-0.so:audio/sratom \
+ libsuil-0.so:audio/suil \
+ libjack.so:audio/jack \
+ libsord-0.so:devel/sord \
+ libserd-0.so:devel/serd \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= compiler:c++11-lang waf tar:bz2 pkgconfig
+CONFIGURE_ARGS= --no-qt4
+USE_CXXSTD= c++11
+USE_QT5= core gui widgets buildtools_build
+USE_GNOME= atk atkmm cairo cairomm pango pangomm libsigc++20 \
+ gdkpixbuf2 glib20 glibmm gtk20 gtk30 gtkmm24
+QT_NONSTANDARD= yes
+
+post-patch:
+ @${REINPLACE_CMD} 's|$${MANDIR}|${MAN1PREFIX}/man|' \
+ ${WRKSRC}/wscript
+
+post-install:
+ @${GZIP_CMD} ${STAGEDIR}${MAN1PREFIX}/man/man1/*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/jalv*
+
+.include <bsd.port.mk>
diff --git a/audio/jalv/distinfo b/audio/jalv/distinfo
new file mode 100644
index 000000000000..24281b5b8d03
--- /dev/null
+++ b/audio/jalv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501816961
+SHA256 (jalv-1.6.0.tar.bz2) = 914625972bb2e99552a0bb0ae3b5d27f70901b92fab1f6daf8fb31d1ffbf5cf4
+SIZE (jalv-1.6.0.tar.bz2) = 157726
diff --git a/audio/jalv/files/patch-wscript b/audio/jalv/files/patch-wscript
new file mode 100644
index 000000000000..5222c2ee37b2
--- /dev/null
+++ b/audio/jalv/files/patch-wscript
@@ -0,0 +1,11 @@
+--- wscript.orig 2017-08-04 04:48:22 UTC
++++ wscript
+@@ -61,7 +61,7 @@ def configure(conf):
+ atleast_version='0.6.0', mandatory=True)
+ autowaf.check_pkg(conf, 'sratom-0', uselib_store='SRATOM',
+ atleast_version='0.6.0', mandatory=True)
+- if Options.options.portaudio:
++ if False and Options.options.portaudio:
+ autowaf.check_pkg(conf, 'portaudio-2.0', uselib_store='PORTAUDIO',
+ atleast_version='2.0.0', mandatory=False)
+ else:
diff --git a/audio/jalv/pkg-descr b/audio/jalv/pkg-descr
new file mode 100644
index 000000000000..e5e3555a0caa
--- /dev/null
+++ b/audio/jalv/pkg-descr
@@ -0,0 +1,9 @@
+Jalv runs LV2 plugins and exposes their ports as Jack ports, essentially
+making any LV2 plugin function as a Jack application.
+
+Jalv is a small program which is useful, but also intended to be an appropriate
+test host for plugin development. It runs plugins from the command line with no
+user interaction, is light enough to run in valgrind, and is capable of dumping
+all plugin to/from UI communication in a human readable format.
+
+WWW: https://drobilla.net/software/jalv
diff --git a/audio/jalv/pkg-plist b/audio/jalv/pkg-plist
new file mode 100644
index 000000000000..dd6fb70ac513
--- /dev/null
+++ b/audio/jalv/pkg-plist
@@ -0,0 +1,9 @@
+bin/jalv
+bin/jalv.gtk
+bin/jalv.gtk3
+bin/jalv.gtkmm
+bin/jalv.qt5
+man/man1/jalv.1.gz
+man/man1/jalv.gtk.1.gz
+man/man1/jalv.gtkmm.1.gz
+man/man1/jalv.qt.1.gz