aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-17 19:42:59 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-17 19:42:59 +0000
commite139ff390ab61965631b25f27c2dbf31ec0be046 (patch)
treeba3cb44c6b9b6cb69ea773bf07b86e3ee6e9a40c /audio
parentf919b17732ea95008dad6438c324d73b81e9485b (diff)
downloadports-e139ff390ab61965631b25f27c2dbf31ec0be046.tar.gz
ports-e139ff390ab61965631b25f27c2dbf31ec0be046.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/stk/Makefile26
-rw-r--r--audio/stk/distinfo3
-rw-r--r--audio/stk/files/patch-configure.ac66
-rw-r--r--audio/stk/files/patch-src_RtAudio.cpp23
-rw-r--r--audio/stk/pkg-descr5
-rw-r--r--audio/stk/pkg-plist105
7 files changed, 229 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 4fc86d4f449b..df49311adfe5 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -751,6 +751,7 @@
SUBDIR += splaytk
SUBDIR += squash
SUBDIR += sratom
+ SUBDIR += stk
SUBDIR += streamripper
SUBDIR += streamtranscoder
SUBDIR += stymulator
diff --git a/audio/stk/Makefile b/audio/stk/Makefile
new file mode 100644
index 000000000000..795da754cadd
--- /dev/null
+++ b/audio/stk/Makefile
@@ -0,0 +1,26 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= stk
+PORTVERSION= 4.5.1
+CATEGORIES= audio
+MASTER_SITES= http://ccrma.stanford.edu/software/stk/release/
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Synthesis ToolKit in C++
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libjack.so:audio/jack
+
+USES= autoreconf dos2unix gmake pkgconfig localbase
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-jack
+DOS2UNIX_GLOB= *.cpp *.h
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libstk-${PORTVERSION}.so
+
+.include <bsd.port.mk>
diff --git a/audio/stk/distinfo b/audio/stk/distinfo
new file mode 100644
index 000000000000..b72a8faebb46
--- /dev/null
+++ b/audio/stk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502358993
+SHA256 (stk-4.5.1.tar.gz) = 3466860901a181120d3bd0407e4aeb5ab24127a4350c314af106778c1db88594
+SIZE (stk-4.5.1.tar.gz) = 2413113
diff --git a/audio/stk/files/patch-configure.ac b/audio/stk/files/patch-configure.ac
new file mode 100644
index 000000000000..92b8f950ed66
--- /dev/null
+++ b/audio/stk/files/patch-configure.ac
@@ -0,0 +1,66 @@
+--- configure.ac.orig 2016-02-23 01:51:06 UTC
++++ configure.ac
+@@ -85,7 +85,6 @@ if test "$debug" = "yes"; then
+ else
+ AC_SUBST( debug, [no] )
+ AC_SUBST( cppflag, [] )
+- AC_SUBST( cxxflag, [-O3] )
+ AC_SUBST( object_path, [Release] )
+ fi
+ AC_MSG_RESULT($debug)
+@@ -100,7 +99,7 @@ fi
+ CPPFLAGS="$CPPFLAGS $cppflag"
+
+ # For debugging and optimization ... overwrite default because it has both -g and -O2
+-CXXFLAGS="$cxxflag"
++CXXFLAGS="$CXXFLAGS $cxxflag"
+
+ # Check compiler and use -Wall if gnu.
+ if [test $GXX = "yes" ;] then
+@@ -127,31 +126,31 @@ if test $realtime = yes; then
+ # Checks for package options and external software
+ AC_MSG_CHECKING(for audio API)
+ case $host in
+- *-*-linux*)
++ *-*-freebsd*)
+ AC_ARG_WITH(jack, [ --with-jack = choose JACK server support (mac and linux only)], [
+ api="$api -D__UNIX_JACK__"
+ AC_MSG_RESULT(using JACK)
+ AC_CHECK_LIB(jack, jack_client_open, , AC_MSG_ERROR(JACK support requires the jack library!))
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))], )
++ #AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))], )
+
+ # Look for ALSA flag
+- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)], [
+- api="$api -D__LINUX_ALSA__"
+- AC_MSG_RESULT(using ALSA)
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
++ #AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)], [
++ #api="$api -D__LINUX_ALSA__"
++ #AC_MSG_RESULT(using ALSA)
++ #AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
+
+ # Look for OSS flag
+- AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (linux only)], [
+- api="$api -D__LINUX_OSS__ -D__LINUX_ALSA__"
+- AC_MSG_RESULT(using OSS)
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(OSS support requires ALSA for RtMidi!))], )
++ #AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (linux only)], [
++ #api="$api -D__LINUX_OSS__"
++ #AC_MSG_RESULT(using OSS)
++ #AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(OSS support requires ALSA for RtMidi!))], )
+
+ # If no audio api flags specified, use ALSA
+- if [test "$api" == "";] then
+- AC_MSG_RESULT(using ALSA)
+- AC_SUBST( api, [-D__LINUX_ALSA__] )
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
+- fi
++ #if [test "$api" == "";] then
++ # AC_MSG_RESULT(using ALSA)
++ # AC_SUBST( api, [-D__LINUX_ALSA__] )
++ # AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
++ #fi
+
+ AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtAudio requires the pthread library!))
+ ;;
diff --git a/audio/stk/files/patch-src_RtAudio.cpp b/audio/stk/files/patch-src_RtAudio.cpp
new file mode 100644
index 000000000000..0cfd68e67346
--- /dev/null
+++ b/audio/stk/files/patch-src_RtAudio.cpp
@@ -0,0 +1,23 @@
+--- src/RtAudio.cpp.orig 2016-02-23 01:51:06 UTC
++++ src/RtAudio.cpp
+@@ -47,6 +47,11 @@
+ #include <climits>
+ #include <algorithm>
+
++#if defined(__FreeBSD__)
++#include <sys/soundcard.h>
++#define AFMT_FLOAT 0x00004000
++#endif
++
+ // Static variable definitions.
+ const unsigned int RtApi::MAX_SAMPLE_RATES = 14;
+ const unsigned int RtApi::SAMPLE_RATES[] = {
+@@ -9023,7 +9028,7 @@ bool RtApiOss :: probeDeviceOpen( unsign
+ }
+
+ // Verify the sample rate setup worked.
+- if ( abs( srate - sampleRate ) > 100 ) {
++ if ( abs( (int)(srate - sampleRate) ) > 100 ) {
+ close( fd );
+ errorStream_ << "RtApiOss::probeDeviceOpen: device (" << ainfo.name << ") does not support sample rate (" << sampleRate << ").";
+ errorText_ = errorStream_.str();
diff --git a/audio/stk/pkg-descr b/audio/stk/pkg-descr
new file mode 100644
index 000000000000..beda19204257
--- /dev/null
+++ b/audio/stk/pkg-descr
@@ -0,0 +1,5 @@
+The Synthesis ToolKit in C++ (STK) is a set of open source audio signal
+processing and algorithmic synthesis classes written in the C++ programming
+language.
+
+WWW: https://ccrma.stanford.edu/software/stk
diff --git a/audio/stk/pkg-plist b/audio/stk/pkg-plist
new file mode 100644
index 000000000000..975074edde5b
--- /dev/null
+++ b/audio/stk/pkg-plist
@@ -0,0 +1,105 @@
+include/stk/ADSR.h
+include/stk/Asymp.h
+include/stk/BandedWG.h
+include/stk/BeeThree.h
+include/stk/BiQuad.h
+include/stk/Blit.h
+include/stk/BlitSaw.h
+include/stk/BlitSquare.h
+include/stk/BlowBotl.h
+include/stk/BlowHole.h
+include/stk/BowTable.h
+include/stk/Bowed.h
+include/stk/Brass.h
+include/stk/Chorus.h
+include/stk/Clarinet.h
+include/stk/Cubic.h
+include/stk/Delay.h
+include/stk/DelayA.h
+include/stk/DelayL.h
+include/stk/Drummer.h
+include/stk/Echo.h
+include/stk/Effect.h
+include/stk/Envelope.h
+include/stk/FM.h
+include/stk/FMVoices.h
+include/stk/FileLoop.h
+include/stk/FileRead.h
+include/stk/FileWrite.h
+include/stk/FileWvIn.h
+include/stk/FileWvOut.h
+include/stk/Filter.h
+include/stk/Fir.h
+include/stk/Flute.h
+include/stk/FormSwep.h
+include/stk/FreeVerb.h
+include/stk/Function.h
+include/stk/Generator.h
+include/stk/Granulate.h
+include/stk/Guitar.h
+include/stk/HevyMetl.h
+include/stk/Iir.h
+include/stk/InetWvIn.h
+include/stk/InetWvOut.h
+include/stk/Instrmnt.h
+include/stk/JCRev.h
+include/stk/JetTable.h
+include/stk/LentPitShift.h
+include/stk/Mandolin.h
+include/stk/Mesh2D.h
+include/stk/Messager.h
+include/stk/MidiFileIn.h
+include/stk/Modal.h
+include/stk/ModalBar.h
+include/stk/Modulate.h
+include/stk/Moog.h
+include/stk/Mutex.h
+include/stk/NRev.h
+include/stk/Noise.h
+include/stk/OnePole.h
+include/stk/OneZero.h
+include/stk/PRCRev.h
+include/stk/PercFlut.h
+include/stk/Phonemes.h
+include/stk/PitShift.h
+include/stk/Plucked.h
+include/stk/PoleZero.h
+include/stk/ReedTable.h
+include/stk/Resonate.h
+include/stk/Rhodey.h
+include/stk/RtAudio.h
+include/stk/RtMidi.h
+include/stk/RtWvIn.h
+include/stk/RtWvOut.h
+include/stk/SKINImsg.h
+include/stk/SKINItbl.h
+include/stk/Sampler.h
+include/stk/Saxofony.h
+include/stk/Shakers.h
+include/stk/Simple.h
+include/stk/SineWave.h
+include/stk/SingWave.h
+include/stk/Sitar.h
+include/stk/Skini.h
+include/stk/Socket.h
+include/stk/Sphere.h
+include/stk/StifKarp.h
+include/stk/Stk.h
+include/stk/TapDelay.h
+include/stk/TcpClient.h
+include/stk/TcpServer.h
+include/stk/Thread.h
+include/stk/TubeBell.h
+include/stk/Twang.h
+include/stk/TwoPole.h
+include/stk/TwoZero.h
+include/stk/UdpSocket.h
+include/stk/Vector3D.h
+include/stk/VoicForm.h
+include/stk/Voicer.h
+include/stk/Whistle.h
+include/stk/Wurley.h
+include/stk/WvIn.h
+include/stk/WvOut.h
+lib/libstk-4.5.1.so
+lib/libstk.so