aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-21 06:57:50 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-21 06:57:50 +0000
commite13f98a7301e7287f982242681c434c13ef053e1 (patch)
treee586e23207f72745724cc621bf73a2919c592ec2 /audio
parentd6198832660e3325d1589256dc4360d7e47f2d8b (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/qsynth/Makefile37
-rw-r--r--audio/qsynth/distinfo5
-rw-r--r--audio/qsynth/files/patch-src_qsynthOptions.cpp25
-rw-r--r--audio/qsynth/pkg-plist1
4 files changed, 23 insertions, 45 deletions
diff --git a/audio/qsynth/Makefile b/audio/qsynth/Makefile
index 1daaba46bd12..7dafb56d55df 100644
--- a/audio/qsynth/Makefile
+++ b/audio/qsynth/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qsynth
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.4
CATEGORIES= audio
MASTER_SITES= SF
@@ -14,8 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
-USES= gmake
-QT_NONSTANDARD= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_ac_cv_qmake=${QMAKE} \
ac_cv_path_ac_moc=${MOC} \
@@ -24,30 +23,32 @@ CONFIGURE_ENV= ac_cv_path_ac_cv_qmake=${QMAKE} \
ac_cv_path_ac_lrelease=${LRELEASE}
CONFIGURE_ARGS= --localedir=${DATADIR} \
--with-fluidsynth=${LOCALBASE}
+USE_CXXSTD= c++11
+USE_QT5= core gui widgets buildtools_build linguisttools_build qmake_build
+USE_GL= gl
+INSTALLS_ICONS= yes
-OPTIONS_DEFINE= GRADIENT SYSTEM_TRAY
-OPTIONS_SINGLE= TOOLKIT
-OPTIONS_SINGLE_TOOLKIT= QT4 QT5
-OPTIONS_DEFAULT= GRADIENT QT4 SYSTEM_TRAY
+OPTIONS_DEFINE= GRADIENT SYSTEM_TRAY XUNIQUE
+OPTIONS_DEFAULT=GRADIENT SYSTEM_TRAY XUNIQUE
GRADIENT_DESC= Gradient eye-candy
GRADIENT_CONFIGURE_ENABLE= gradient
-QT4_USE= qt4=corelib,gui \
- qt4=linguisttools_build \
- qt4=moc_build,qmake_build,rcc_build,uic_build
-QT4_CONFIGURE_ENABLE= qt4
-QT5_USE= qt5=core,gui,widgets,x11extras \
- qt5=buildtools_build,linguisttools_build,qmake_build
-QT5_CONFIGURE_ENABLE= qt5
SYSTEM_TRAY_DESC= System-tray icon support
SYSTEM_TRAY_CONFIGURE_ENABLE= system-tray
-TOOLKIT_DESC= Qt toolkit
+XUNIQUE_DESC= X11 unique/single instance
+XUNIQUE_CONFIGURE_ENABLE= xunique
+XUNIQUE_USE= XORG=x11
+
+post-patch:
+ @${REINPLACE_CMD} -e ' \
+ s|oss,alsa,alsa_seq,|jack,oss,|; \
+ s|alsa,jack,oss,dsound,|jack,oss,dsound,|; \
+ s|"/MidiDriver", "alsa_seq"|"/MidiDriver", "jack"|; \
+ s|m_settings.value("/SoundFontDir").toString();|m_settings.value("/SoundFontDir").toString().isEmpty() ? "${LOCALBASE}/share/sounds/sf2" : m_settings.value("/SoundFontDir").toString();|' \
+ ${WRKSRC}/src/qsynthOptions.cpp
post-configure:
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -o qsynth.mak \
${QMAKE_ARGS})
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qsynth
-
.include <bsd.port.mk>
diff --git a/audio/qsynth/distinfo b/audio/qsynth/distinfo
index c2001a7d9048..6692f6f0b55f 100644
--- a/audio/qsynth/distinfo
+++ b/audio/qsynth/distinfo
@@ -1,2 +1,3 @@
-SHA256 (qsynth-0.4.1.tar.gz) = 50f4e36e0c5a7e092429e1cafbd8989346127b8b0c0868566addcacc5735970c
-SIZE (qsynth-0.4.1.tar.gz) = 251821
+TIMESTAMP = 1502579710
+SHA256 (qsynth-0.4.4.tar.gz) = 0ef914447b1f3a3ecd9c38101f06fc9c67e1d8367202a3f7a494f5d167b40e62
+SIZE (qsynth-0.4.4.tar.gz) = 260482
diff --git a/audio/qsynth/files/patch-src_qsynthOptions.cpp b/audio/qsynth/files/patch-src_qsynthOptions.cpp
deleted file mode 100644
index ec3d4e63af43..000000000000
--- a/audio/qsynth/files/patch-src_qsynthOptions.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/qsynthOptions.cpp.orig 2016-04-05 15:57:45 UTC
-+++ src/qsynthOptions.cpp
-@@ -172,11 +172,11 @@ void qsynthOptions::print_usage ( const
- out << " -n, --no-midi-in" + sEot +
- QObject::tr("Don't create a midi driver to read MIDI input events [default = yes]") + sEol;
- out << " -m, --midi-driver=[label]" + sEot +
-- QObject::tr("The name of the midi driver to use [oss,alsa,alsa_seq,...]") + sEol;
-+ QObject::tr("The name of the midi driver to use [jack,oss,...]") + sEol;
- out << " -K, --midi-channels=[num]" + sEot +
- QObject::tr("The number of midi channels [default = 16]") + sEol;
- out << " -a, --audio-driver=[label]" + sEot +
-- QObject::tr("The audio driver [alsa,jack,oss,dsound,...]") + sEol;
-+ QObject::tr("The audio driver [jack,oss,dsound,...]") + sEol;
- out << " -j, --connect-jack-outputs" + sEot +
- QObject::tr("Attempt to connect the jack outputs to the physical ports") + sEol;
- out << " -L, --audio-channels=[num]" + sEot +
-@@ -479,7 +479,7 @@ void qsynthOptions::loadSetup ( qsynthSe
- pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 512).toInt();
- pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 8).toInt();
- #else
-- pSetup->sMidiDriver = m_settings.value("/MidiDriver", "alsa_seq").toString();
-+ pSetup->sMidiDriver = m_settings.value("/MidiDriver", "jack").toString();
- pSetup->sAudioDriver = m_settings.value("/AudioDriver", "jack").toString();
- pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 64).toInt();
- pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 2).toInt();
diff --git a/audio/qsynth/pkg-plist b/audio/qsynth/pkg-plist
index d8d41081355c..bf70b69a8422 100644
--- a/audio/qsynth/pkg-plist
+++ b/audio/qsynth/pkg-plist
@@ -1,5 +1,6 @@
bin/qsynth
man/man1/qsynth.1.gz
+man/man1/qsynth.fr.1.gz
share/appdata/qsynth.appdata.xml
share/applications/qsynth.desktop
share/icons/hicolor/32x32/apps/qsynth.png