aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /audio
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/cmus/Makefile1
-rw-r--r--audio/cmus/files/patch-scripts-checks.sh20
-rw-r--r--audio/id3mtag/files/patch-charconv.cpp11
-rw-r--r--audio/mp3unicode/files/patch-mp3unicode.cpp11
-rw-r--r--audio/tagutil/Makefile2
-rw-r--r--audio/tagutil/files/patch-FindIconv.cmake31
-rw-r--r--audio/xmms-wavpack/Makefile4
-rw-r--r--audio/xmms-wavpack/files/patch-src_libwavpack.cpp9
8 files changed, 66 insertions, 23 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index fc8b84a581d8..0f8c43ba9522 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cmus
PORTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= h.skuhra@gmail.com
diff --git a/audio/cmus/files/patch-scripts-checks.sh b/audio/cmus/files/patch-scripts-checks.sh
new file mode 100644
index 000000000000..15b27cba2112
--- /dev/null
+++ b/audio/cmus/files/patch-scripts-checks.sh
@@ -0,0 +1,20 @@
+--- scripts/checks.sh.orig 2014-08-11 07:48:28 UTC
++++ scripts/checks.sh
+@@ -677,11 +677,15 @@ check_dl()
+ check_iconv()
+ {
+ HAVE_ICONV=n
+- if check_library ICONV "" "-liconv"
++ if check_function iconv
++ then
++ echo "libc contains iconv"
++ makefile_var ICONV_CFLAGS ""
++ makefile_var ICONV_LIBS ""
++ elif check_library ICONV "" "-liconv"
+ then
+ echo "taking iconv from libiconv"
+ else
+- echo "assuming libc contains iconv"
+ makefile_var ICONV_CFLAGS ""
+ makefile_var ICONV_LIBS ""
+ fi
diff --git a/audio/id3mtag/files/patch-charconv.cpp b/audio/id3mtag/files/patch-charconv.cpp
new file mode 100644
index 000000000000..828a5008dc49
--- /dev/null
+++ b/audio/id3mtag/files/patch-charconv.cpp
@@ -0,0 +1,11 @@
+--- charconv.cpp.orig 2015-01-29 23:00:00 UTC
++++ charconv.cpp
+@@ -109,7 +109,7 @@ namespace charset {
+
+ bool recode(char* out, size_t avail, const void* src, size_t len, const char* to, const char* from)
+ {
+- const char* in = (const char*)src;
++ char* in = (char*)src;
+
+ iconv_t cvt = iconv_open(to, from);
+ if(cvt == (iconv_t)-1)
diff --git a/audio/mp3unicode/files/patch-mp3unicode.cpp b/audio/mp3unicode/files/patch-mp3unicode.cpp
deleted file mode 100644
index 164200b65130..000000000000
--- a/audio/mp3unicode/files/patch-mp3unicode.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./mp3unicode.cpp.orig 2012-05-07 12:03:19.000000000 +0000
-+++ ./mp3unicode.cpp 2014-05-13 20:16:40.053475428 +0000
-@@ -229,7 +229,7 @@
- if (
- iconv (
- cd,
-- (char **)&from,
-+ &from,
- &from_size,
- &to,
- &to_size
diff --git a/audio/tagutil/Makefile b/audio/tagutil/Makefile
index 7449c9ea7d84..0fa64c6834b7 100644
--- a/audio/tagutil/Makefile
+++ b/audio/tagutil/Makefile
@@ -2,7 +2,7 @@
PORTNAME= tagutil
PORTVERSION= 3.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MAINTAINER= alex@kaworu.ch
diff --git a/audio/tagutil/files/patch-FindIconv.cmake b/audio/tagutil/files/patch-FindIconv.cmake
new file mode 100644
index 000000000000..2cbf4f8c659d
--- /dev/null
+++ b/audio/tagutil/files/patch-FindIconv.cmake
@@ -0,0 +1,31 @@
+--- FindIconv.cmake.orig 2014-07-23 14:37:21 UTC
++++ FindIconv.cmake
+@@ -9,6 +9,7 @@
+ # ICONV_SECOND_ARGUMENT_IS_CONST - the second argument for iconv() is const
+ #
+ include(CheckCSourceCompiles)
++include(CheckFunctionExists)
+
+ IF (ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+ # Already in cache, be silent
+@@ -17,11 +18,15 @@ ENDIF (ICONV_INCLUDE_DIR AND ICONV_LIBRA
+
+ FIND_PATH(ICONV_INCLUDE_DIR iconv.h)
+
+-FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2 c)
+-
+-IF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+- SET(ICONV_FOUND TRUE)
+-ENDIF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
++IF(ICONV_INCLUDE_DIR)
++ CHECK_FUNCTION_EXISTS(iconv ICONV_FOUND)
++ IF(NOT ICONV_FOUND)
++ FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2)
++ IF(ICONV_LIBRARIES)
++ SET(ICONV_FOUND TRUE)
++ ENDIF(ICONV_LIBRARIES)
++ ENDIF(NOT ICONV_FOUND)
++ENDIF(ICONV_INCLUDE_DIR)
+
+ set(CMAKE_REQUIRED_INCLUDES ${ICONV_INCLUDE_DIR})
+ set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBRARIES})
diff --git a/audio/xmms-wavpack/Makefile b/audio/xmms-wavpack/Makefile
index c95b6b419734..20e3acc8e2df 100644
--- a/audio/xmms-wavpack/Makefile
+++ b/audio/xmms-wavpack/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xmms-wavpack
PORTVERSION= 1.0.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://www.wavpack.com/
@@ -12,7 +12,7 @@ COMMENT= XMMS input plugin to play WavPack files
LIB_DEPENDS= libwavpack.so:${PORTSDIR}/audio/wavpack \
libxmms.so:${PORTSDIR}/multimedia/xmms
-USES= libtool pkgconfig tar:bzip2
+USES= iconv libtool pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/audio/xmms-wavpack/files/patch-src_libwavpack.cpp b/audio/xmms-wavpack/files/patch-src_libwavpack.cpp
index 276ada4593c8..198778322aca 100644
--- a/audio/xmms-wavpack/files/patch-src_libwavpack.cpp
+++ b/audio/xmms-wavpack/files/patch-src_libwavpack.cpp
@@ -18,12 +18,3 @@
float *fptr = (float *) input;
int32_t *lptr = input;
int cnt = tsamples;
-@@ -362,7 +362,7 @@ convertUTF8toLocale(char *utf8)
- size_t in_left = strlen(utf8);
- size_t out_left = 2 * in_left + 1;
- char *buf = (char *)g_malloc(out_left);
--#if 1
-+#if 0
- char *in = utf8;
- #else
- const char *in = (const char *) utf8; // some systems (freeBSD?) require const here