aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /audio
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/gnome-media/Makefile17
-rw-r--r--audio/gnome-media/distinfo6
-rw-r--r--audio/gnome-media/files/patch-configure11
-rw-r--r--audio/gnome-media/files/patch-gnome-cd_gst-cdparanoia-cdrom.c49
-rw-r--r--audio/gnome-media/pkg-plist6
-rw-r--r--audio/gnomemedia2/Makefile17
-rw-r--r--audio/gnomemedia2/distinfo6
-rw-r--r--audio/gnomemedia2/files/patch-configure11
-rw-r--r--audio/gnomemedia2/files/patch-gnome-cd_gst-cdparanoia-cdrom.c49
-rw-r--r--audio/gnomemedia2/pkg-plist6
-rw-r--r--audio/sound-juicer/Makefile14
-rw-r--r--audio/sound-juicer/distinfo6
-rw-r--r--audio/sound-juicer/files/patch-src::Makefile.in19
-rw-r--r--audio/sound-juicer/pkg-plist23
14 files changed, 65 insertions, 175 deletions
diff --git a/audio/gnome-media/Makefile b/audio/gnome-media/Makefile
index 5a0e07959981..9834f8e5f892 100644
--- a/audio/gnome-media/Makefile
+++ b/audio/gnome-media/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/gnomemedia2/Makefile,v 1.79 2005/09/04 21:49:55 marcus Exp $
+# $MCom: ports/audio/gnomemedia2/Makefile,v 1.95 2006/04/13 07:52:30 bland Exp $
#
PORTNAME= gnomemedia2
-PORTVERSION= 2.12.0
-PORTREVISION= 1
+PORTVERSION= 2.14.0
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-media/2.12
+MASTER_SITE_SUBDIR= sources/gnome-media/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-media-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,16 +18,16 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Multimedia applications for the GNOME 2 desktop
USE_BZIP2= yes
+USE_GETTEXT= yes
INSTALLS_OMF= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
GNOME_DESKTOP_VERSION=2
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop \
gail nautiluscdburner
-USE_GSTREAMER= esound cdparanoia gconf
+USE_GSTREAMER= esound gconf good
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -42,9 +41,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|[$$][(]CDROM_HOST[)]|freebsd|g' \
${WRKSRC}/gnome-cd/Makefile.in
.if ${OSVERSION} > 501107
- @${REINPLACE_CMD} -e 's|%%CDROM%%|acd0|' ${WRKSRC}/configure
-.else
- @${REINPLACE_CMD} -e 's|%%CDROM%%|acd0c|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|acd0c|acd0|' ${WRKSRC}/configure
.endif
.include <bsd.port.post.mk>
diff --git a/audio/gnome-media/distinfo b/audio/gnome-media/distinfo
index c1d48b7bf36d..595a5ad12fa6 100644
--- a/audio/gnome-media/distinfo
+++ b/audio/gnome-media/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-media-2.12.0.tar.bz2) = 74d9a78f7269602e033ab1a4a144afdf
-SHA256 (gnome2/gnome-media-2.12.0.tar.bz2) = 47956491973b0ace77e22f93f4141fd5a49c294f68f427e00fb4df8c1dc542ad
-SIZE (gnome2/gnome-media-2.12.0.tar.bz2) = 3444233
+MD5 (gnome2/gnome-media-2.14.0.tar.bz2) = e1304b3fb5e069025bb2c1ea3f9f8b62
+SHA256 (gnome2/gnome-media-2.14.0.tar.bz2) = f43324636c0ee8b7485a9a5d2baf8e3fb5db0cc87c55afdb350774dfafc8b280
+SIZE (gnome2/gnome-media-2.14.0.tar.bz2) = 2933013
diff --git a/audio/gnome-media/files/patch-configure b/audio/gnome-media/files/patch-configure
deleted file mode 100644
index e2224d9308de..000000000000
--- a/audio/gnome-media/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue Jun 1 17:42:05 2004
-+++ configure Tue Jun 1 18:38:15 2004
-@@ -24584,7 +24584,7 @@
- *FreeBSD*)
- CDROM_HOST=bsd
- CDROM_HOST_BSD=true
-- default_cd_device="/dev/acd0c"
-+ default_cd_device="/dev/%%CDROM%%"
- ;;
- *NetBSD*)
- CDROM_HOST=bsd
diff --git a/audio/gnome-media/files/patch-gnome-cd_gst-cdparanoia-cdrom.c b/audio/gnome-media/files/patch-gnome-cd_gst-cdparanoia-cdrom.c
deleted file mode 100644
index 8d49db7bc871..000000000000
--- a/audio/gnome-media/files/patch-gnome-cd_gst-cdparanoia-cdrom.c
+++ /dev/null
@@ -1,49 +0,0 @@
---- gnome-cd/gst-cdparanoia-cdrom.c.orig Mon Apr 4 16:25:49 2005
-+++ gnome-cd/gst-cdparanoia-cdrom.c Mon Apr 4 16:26:14 2005
-@@ -1224,6 +1224,16 @@
- *status = NULL;
- return FALSE;
- }
-+#else
-+ if (ioctl (cdrom->fd, CDIOREADTOCHEADER, priv->tochdr) < 0) {
-+ realstatus->cd = GNOME_CDROM_STATUS_NO_DISC;
-+ realstatus->audio = GNOME_CDROM_AUDIO_NOTHING;
-+ realstatus->track = -1;
-+
-+ gst_cdparanoia_cdrom_close (lcd);
-+ return TRUE;
-+ }
-+ realstatus->cd = GNOME_CDROM_STATUS_OK;
- #endif
-
- gst_cdparanoia_cdrom_close (lcd);
-@@ -1421,15 +1431,18 @@
- return FALSE;
- }
-
-+#if !defined(__FreeBSD__)
-+ /* XXX: One cannot send CDIOCCAPABILITY to an atapicam CD-ROM
-+ * device.
-+ */
-+
- fd = open (device, O_RDONLY | O_NONBLOCK);
- if (fd < 0) {
- return FALSE;
- }
-
- /* Fire a harmless ioctl at the device. */
--#if defined(__FreeBSD__)
-- if (ioctl (fd, CDIOCCAPABILITY, 0) < 0) {
--#elif defined(__NetBSD__) || defined(__OpenBSD__)
-+#if defined(__NetBSD__) || defined(__OpenBSD__)
- if (ioctl (fd, CDIOCGETVOL, 0) < 0) {
- #else
- if (ioctl (fd, CDROM_GET_CAPABILITY, 0) < 0) {
-@@ -1441,6 +1454,7 @@
- }
-
- close (fd);
-+#endif /* __FreeBSD__ */
-
- return TRUE;
- }
diff --git a/audio/gnome-media/pkg-plist b/audio/gnome-media/pkg-plist
index e531ad4428e7..a52495291e52 100644
--- a/audio/gnome-media/pkg-plist
+++ b/audio/gnome-media/pkg-plist
@@ -472,6 +472,7 @@ share/locale/id/LC_MESSAGES/gnome-media-2.0.mo
share/locale/it/LC_MESSAGES/gnome-media-2.0.mo
share/locale/ja/LC_MESSAGES/gnome-media-2.0.mo
share/locale/ko/LC_MESSAGES/gnome-media-2.0.mo
+share/locale/ku/LC_MESSAGES/gnome-media-2.0.mo
share/locale/lt/LC_MESSAGES/gnome-media-2.0.mo
share/locale/lv/LC_MESSAGES/gnome-media-2.0.mo
share/locale/mk/LC_MESSAGES/gnome-media-2.0.mo
@@ -505,6 +506,7 @@ share/locale/vi/LC_MESSAGES/gnome-media-2.0.mo
share/locale/wa/LC_MESSAGES/gnome-media-2.0.mo
share/locale/xh/LC_MESSAGES/gnome-media-2.0.mo
share/locale/zh_CN/LC_MESSAGES/gnome-media-2.0.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-media-2.0.mo
share/locale/zh_TW/LC_MESSAGES/gnome-media-2.0.mo
@dirrm share/gnome/pixmaps/gnome-cd/themes/red-lcd
@dirrm share/gnome/pixmaps/gnome-cd/themes/media
@@ -524,8 +526,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-media-2.0.mo
@dirrm share/gnome/help/grecord/zh_CN
@dirrm share/gnome/help/grecord/sv/figures
@dirrm share/gnome/help/grecord/sv
-@dirrm share/gnome/help/gnome-cd/nl/figures
-@dirrm share/gnome/help/gnome-cd/nl
@dirrm share/gnome/help/grecord/ko/figures
@dirrm share/gnome/help/grecord/ko
@dirrm share/gnome/help/grecord/ja/figures
@@ -557,6 +557,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-media-2.0.mo
@dirrm share/gnome/help/gnome-cd/uk
@dirrm share/gnome/help/gnome-cd/sv/figures
@dirrm share/gnome/help/gnome-cd/sv
+@dirrm share/gnome/help/gnome-cd/nl/figures
+@dirrm share/gnome/help/gnome-cd/nl
@dirrm share/gnome/help/gnome-cd/ko/figures
@dirrm share/gnome/help/gnome-cd/ko
@dirrm share/gnome/help/gnome-cd/ja/figures
diff --git a/audio/gnomemedia2/Makefile b/audio/gnomemedia2/Makefile
index 5a0e07959981..9834f8e5f892 100644
--- a/audio/gnomemedia2/Makefile
+++ b/audio/gnomemedia2/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/gnomemedia2/Makefile,v 1.79 2005/09/04 21:49:55 marcus Exp $
+# $MCom: ports/audio/gnomemedia2/Makefile,v 1.95 2006/04/13 07:52:30 bland Exp $
#
PORTNAME= gnomemedia2
-PORTVERSION= 2.12.0
-PORTREVISION= 1
+PORTVERSION= 2.14.0
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-media/2.12
+MASTER_SITE_SUBDIR= sources/gnome-media/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-media-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,16 +18,16 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Multimedia applications for the GNOME 2 desktop
USE_BZIP2= yes
+USE_GETTEXT= yes
INSTALLS_OMF= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
GNOME_DESKTOP_VERSION=2
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop \
gail nautiluscdburner
-USE_GSTREAMER= esound cdparanoia gconf
+USE_GSTREAMER= esound gconf good
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -42,9 +41,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|[$$][(]CDROM_HOST[)]|freebsd|g' \
${WRKSRC}/gnome-cd/Makefile.in
.if ${OSVERSION} > 501107
- @${REINPLACE_CMD} -e 's|%%CDROM%%|acd0|' ${WRKSRC}/configure
-.else
- @${REINPLACE_CMD} -e 's|%%CDROM%%|acd0c|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|acd0c|acd0|' ${WRKSRC}/configure
.endif
.include <bsd.port.post.mk>
diff --git a/audio/gnomemedia2/distinfo b/audio/gnomemedia2/distinfo
index c1d48b7bf36d..595a5ad12fa6 100644
--- a/audio/gnomemedia2/distinfo
+++ b/audio/gnomemedia2/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-media-2.12.0.tar.bz2) = 74d9a78f7269602e033ab1a4a144afdf
-SHA256 (gnome2/gnome-media-2.12.0.tar.bz2) = 47956491973b0ace77e22f93f4141fd5a49c294f68f427e00fb4df8c1dc542ad
-SIZE (gnome2/gnome-media-2.12.0.tar.bz2) = 3444233
+MD5 (gnome2/gnome-media-2.14.0.tar.bz2) = e1304b3fb5e069025bb2c1ea3f9f8b62
+SHA256 (gnome2/gnome-media-2.14.0.tar.bz2) = f43324636c0ee8b7485a9a5d2baf8e3fb5db0cc87c55afdb350774dfafc8b280
+SIZE (gnome2/gnome-media-2.14.0.tar.bz2) = 2933013
diff --git a/audio/gnomemedia2/files/patch-configure b/audio/gnomemedia2/files/patch-configure
deleted file mode 100644
index e2224d9308de..000000000000
--- a/audio/gnomemedia2/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue Jun 1 17:42:05 2004
-+++ configure Tue Jun 1 18:38:15 2004
-@@ -24584,7 +24584,7 @@
- *FreeBSD*)
- CDROM_HOST=bsd
- CDROM_HOST_BSD=true
-- default_cd_device="/dev/acd0c"
-+ default_cd_device="/dev/%%CDROM%%"
- ;;
- *NetBSD*)
- CDROM_HOST=bsd
diff --git a/audio/gnomemedia2/files/patch-gnome-cd_gst-cdparanoia-cdrom.c b/audio/gnomemedia2/files/patch-gnome-cd_gst-cdparanoia-cdrom.c
deleted file mode 100644
index 8d49db7bc871..000000000000
--- a/audio/gnomemedia2/files/patch-gnome-cd_gst-cdparanoia-cdrom.c
+++ /dev/null
@@ -1,49 +0,0 @@
---- gnome-cd/gst-cdparanoia-cdrom.c.orig Mon Apr 4 16:25:49 2005
-+++ gnome-cd/gst-cdparanoia-cdrom.c Mon Apr 4 16:26:14 2005
-@@ -1224,6 +1224,16 @@
- *status = NULL;
- return FALSE;
- }
-+#else
-+ if (ioctl (cdrom->fd, CDIOREADTOCHEADER, priv->tochdr) < 0) {
-+ realstatus->cd = GNOME_CDROM_STATUS_NO_DISC;
-+ realstatus->audio = GNOME_CDROM_AUDIO_NOTHING;
-+ realstatus->track = -1;
-+
-+ gst_cdparanoia_cdrom_close (lcd);
-+ return TRUE;
-+ }
-+ realstatus->cd = GNOME_CDROM_STATUS_OK;
- #endif
-
- gst_cdparanoia_cdrom_close (lcd);
-@@ -1421,15 +1431,18 @@
- return FALSE;
- }
-
-+#if !defined(__FreeBSD__)
-+ /* XXX: One cannot send CDIOCCAPABILITY to an atapicam CD-ROM
-+ * device.
-+ */
-+
- fd = open (device, O_RDONLY | O_NONBLOCK);
- if (fd < 0) {
- return FALSE;
- }
-
- /* Fire a harmless ioctl at the device. */
--#if defined(__FreeBSD__)
-- if (ioctl (fd, CDIOCCAPABILITY, 0) < 0) {
--#elif defined(__NetBSD__) || defined(__OpenBSD__)
-+#if defined(__NetBSD__) || defined(__OpenBSD__)
- if (ioctl (fd, CDIOCGETVOL, 0) < 0) {
- #else
- if (ioctl (fd, CDROM_GET_CAPABILITY, 0) < 0) {
-@@ -1441,6 +1454,7 @@
- }
-
- close (fd);
-+#endif /* __FreeBSD__ */
-
- return TRUE;
- }
diff --git a/audio/gnomemedia2/pkg-plist b/audio/gnomemedia2/pkg-plist
index e531ad4428e7..a52495291e52 100644
--- a/audio/gnomemedia2/pkg-plist
+++ b/audio/gnomemedia2/pkg-plist
@@ -472,6 +472,7 @@ share/locale/id/LC_MESSAGES/gnome-media-2.0.mo
share/locale/it/LC_MESSAGES/gnome-media-2.0.mo
share/locale/ja/LC_MESSAGES/gnome-media-2.0.mo
share/locale/ko/LC_MESSAGES/gnome-media-2.0.mo
+share/locale/ku/LC_MESSAGES/gnome-media-2.0.mo
share/locale/lt/LC_MESSAGES/gnome-media-2.0.mo
share/locale/lv/LC_MESSAGES/gnome-media-2.0.mo
share/locale/mk/LC_MESSAGES/gnome-media-2.0.mo
@@ -505,6 +506,7 @@ share/locale/vi/LC_MESSAGES/gnome-media-2.0.mo
share/locale/wa/LC_MESSAGES/gnome-media-2.0.mo
share/locale/xh/LC_MESSAGES/gnome-media-2.0.mo
share/locale/zh_CN/LC_MESSAGES/gnome-media-2.0.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-media-2.0.mo
share/locale/zh_TW/LC_MESSAGES/gnome-media-2.0.mo
@dirrm share/gnome/pixmaps/gnome-cd/themes/red-lcd
@dirrm share/gnome/pixmaps/gnome-cd/themes/media
@@ -524,8 +526,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-media-2.0.mo
@dirrm share/gnome/help/grecord/zh_CN
@dirrm share/gnome/help/grecord/sv/figures
@dirrm share/gnome/help/grecord/sv
-@dirrm share/gnome/help/gnome-cd/nl/figures
-@dirrm share/gnome/help/gnome-cd/nl
@dirrm share/gnome/help/grecord/ko/figures
@dirrm share/gnome/help/grecord/ko
@dirrm share/gnome/help/grecord/ja/figures
@@ -557,6 +557,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-media-2.0.mo
@dirrm share/gnome/help/gnome-cd/uk
@dirrm share/gnome/help/gnome-cd/sv/figures
@dirrm share/gnome/help/gnome-cd/sv
+@dirrm share/gnome/help/gnome-cd/nl/figures
+@dirrm share/gnome/help/gnome-cd/nl
@dirrm share/gnome/help/gnome-cd/ko/figures
@dirrm share/gnome/help/gnome-cd/ko
@dirrm share/gnome/help/gnome-cd/ja/figures
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index 0f6ca61cced3..e212a38eab09 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -3,32 +3,34 @@
# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/sound-juicer/Makefile,v 1.29 2005/09/19 13:18:32 marcus Exp $
+# $MCom: ports/audio/sound-juicer/Makefile,v 1.49 2006/04/14 15:06:00 ahze Exp $
#
PORTNAME= sound-juicer
-PORTVERSION= 2.12.3
+PORTVERSION= 2.14.3
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Clean, mean and lean CD ripper for GNOME2
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
- gnome-media-profiles.0:${PORTSDIR}/audio/gnomemedia2
+ gnome-media-profiles.0:${PORTSDIR}/audio/gnomemedia2 \
+ cdio.6:${PORTSDIR}/sysutils/libcdio
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
-USE_REINPLACE= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui nautiluscdburner \
gnomedocutils
USE_GSTREAMER= cdparanoia vorbis flac gconf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-ignore-missing-cd
+INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -36,5 +38,7 @@ GCONF_SCHEMAS= sound-juicer.schemas
post-patch:
@${REINPLACE_CMD} -e 's|^\(SUBDIRS = .*\)tests\(.*\)|\1\2|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|--parents|-p|g' \
+ ${WRKSRC}/data/Makefile.in
.include <bsd.port.mk>
diff --git a/audio/sound-juicer/distinfo b/audio/sound-juicer/distinfo
index 9e28d45b9b25..d43b5ed55c60 100644
--- a/audio/sound-juicer/distinfo
+++ b/audio/sound-juicer/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/sound-juicer-2.12.3.tar.bz2) = 395395c26b035d466f145dc908021a7f
-SHA256 (gnome2/sound-juicer-2.12.3.tar.bz2) = beae4a847e4c63bb8015a023751219dc2c7c0d23f931d19f2c8b957981c8db60
-SIZE (gnome2/sound-juicer-2.12.3.tar.bz2) = 802832
+MD5 (gnome2/sound-juicer-2.14.3.tar.bz2) = c525c4ef4e8cae163f7f1b6a28460e49
+SHA256 (gnome2/sound-juicer-2.14.3.tar.bz2) = f6b1e4af5b20bb3d986b40fa9d342e2cb422e43cff56a8f8541fd9f76ec64683
+SIZE (gnome2/sound-juicer-2.14.3.tar.bz2) = 875055
diff --git a/audio/sound-juicer/files/patch-src::Makefile.in b/audio/sound-juicer/files/patch-src::Makefile.in
index 187926fc41e3..189365e86d3f 100644
--- a/audio/sound-juicer/files/patch-src::Makefile.in
+++ b/audio/sound-juicer/files/patch-src::Makefile.in
@@ -1,20 +1,11 @@
---- src/Makefile.in.orig Tue Aug 23 20:23:29 2005
-+++ src/Makefile.in Tue Aug 23 20:23:57 2005
-@@ -63,7 +63,7 @@
- sj-about.$(OBJEXT) sj-extracting.$(OBJEXT) \
- bacon-volume.$(OBJEXT) $(am__objects_1) $(am__objects_2)
+--- src/Makefile.in.orig Mon Apr 3 23:40:45 2006
++++ src/Makefile.in Mon Apr 3 23:40:45 2006
+@@ -77,7 +77,7 @@ am_sound_juicer_OBJECTS = dummy.$(OBJEXT
+ gconf-bridge.$(OBJEXT) bacon-volume.$(OBJEXT) $(am__objects_2) \
+ $(am__objects_3) $(am__objects_4)
sound_juicer_OBJECTS = $(am_sound_juicer_OBJECTS)
-sound_juicer_LDADD = $(LDADD)
+sound_juicer_LDADD = $(LDADD) -lcam
DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
-@@ -257,7 +257,7 @@
- target_alias = @target_alias@
-
- # General compiler flags
--AM_CFLAGS = -Wall -export-dynamic -W -Wno-unused-parameter
-+AM_CFLAGS = -Wall -export-dynamic -W
-
- # General CPP flags. When I can demand automake 1.8, this can become
- # sound_juicer_CPPFLAGS.
diff --git a/audio/sound-juicer/pkg-plist b/audio/sound-juicer/pkg-plist
index 1b1ef9c77131..75ed982ba8e2 100644
--- a/audio/sound-juicer/pkg-plist
+++ b/audio/sound-juicer/pkg-plist
@@ -10,6 +10,11 @@ share/gnome/help/sound-juicer/es/figures/prefs.png
share/gnome/help/sound-juicer/es/figures/startup.png
share/gnome/help/sound-juicer/es/legal.xml
share/gnome/help/sound-juicer/es/sound-juicer.xml
+share/gnome/help/sound-juicer/nl/fdl-appendix.xml
+share/gnome/help/sound-juicer/nl/figures/prefs.png
+share/gnome/help/sound-juicer/nl/figures/startup.png
+share/gnome/help/sound-juicer/nl/legal.xml
+share/gnome/help/sound-juicer/nl/sound-juicer.xml
share/gnome/help/sound-juicer/uk/fdl-appendix.xml
share/gnome/help/sound-juicer/uk/figures/prefs.png
share/gnome/help/sound-juicer/uk/figures/startup.png
@@ -17,17 +22,21 @@ share/gnome/help/sound-juicer/uk/legal.xml
share/gnome/help/sound-juicer/uk/sound-juicer.xml
share/gnome/omf/sound-juicer/sound-juicer-C.omf
share/gnome/omf/sound-juicer/sound-juicer-es.omf
+share/gnome/omf/sound-juicer/sound-juicer-nl.omf
share/gnome/omf/sound-juicer/sound-juicer-uk.omf
-share/gnome/pixmaps/sound-juicer.png
-share/gnome/sound-juicer/orange-slice.png
share/gnome/sound-juicer/sj-play.png
share/gnome/sound-juicer/sj-record.png
share/gnome/sound-juicer/sound-juicer.glade
+share/icons/hicolor/16x16/apps/sound-juicer.png
+share/icons/hicolor/22x22/apps/sound-juicer.png
+share/icons/hicolor/24x24/apps/sound-juicer.png
+share/icons/hicolor/scalable/apps/sound-juicer.svg
share/locale/ar/LC_MESSAGES/sound-juicer.mo
share/locale/az/LC_MESSAGES/sound-juicer.mo
share/locale/be/LC_MESSAGES/sound-juicer.mo
share/locale/bg/LC_MESSAGES/sound-juicer.mo
share/locale/bn/LC_MESSAGES/sound-juicer.mo
+share/locale/br/LC_MESSAGES/sound-juicer.mo
share/locale/ca/LC_MESSAGES/sound-juicer.mo
share/locale/cs/LC_MESSAGES/sound-juicer.mo
share/locale/cy/LC_MESSAGES/sound-juicer.mo
@@ -44,13 +53,13 @@ share/locale/fi/LC_MESSAGES/sound-juicer.mo
share/locale/fr/LC_MESSAGES/sound-juicer.mo
share/locale/gl/LC_MESSAGES/sound-juicer.mo
share/locale/gu/LC_MESSAGES/sound-juicer.mo
-share/locale/he/LC_MESSAGES/sound-juicer.mo
share/locale/hi/LC_MESSAGES/sound-juicer.mo
share/locale/hr/LC_MESSAGES/sound-juicer.mo
share/locale/hu/LC_MESSAGES/sound-juicer.mo
share/locale/id/LC_MESSAGES/sound-juicer.mo
share/locale/it/LC_MESSAGES/sound-juicer.mo
share/locale/ja/LC_MESSAGES/sound-juicer.mo
+share/locale/ka/LC_MESSAGES/sound-juicer.mo
share/locale/ko/LC_MESSAGES/sound-juicer.mo
share/locale/lt/LC_MESSAGES/sound-juicer.mo
share/locale/mk/LC_MESSAGES/sound-juicer.mo
@@ -77,13 +86,21 @@ share/locale/th/LC_MESSAGES/sound-juicer.mo
share/locale/tr/LC_MESSAGES/sound-juicer.mo
share/locale/ug/LC_MESSAGES/sound-juicer.mo
share/locale/uk/LC_MESSAGES/sound-juicer.mo
+share/locale/vi/LC_MESSAGES/sound-juicer.mo
share/locale/xh/LC_MESSAGES/sound-juicer.mo
share/locale/zh_CN/LC_MESSAGES/sound-juicer.mo
+share/locale/zh_HK/LC_MESSAGES/sound-juicer.mo
share/locale/zh_TW/LC_MESSAGES/sound-juicer.mo
+@dirrmtry share/locale/br/LC_MESSAGES
+@dirrmtry share/locale/br
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
@dirrm share/gnome/sound-juicer
@dirrm share/gnome/omf/sound-juicer
@dirrm share/gnome/help/sound-juicer/uk/figures
@dirrm share/gnome/help/sound-juicer/uk
+@dirrm share/gnome/help/sound-juicer/nl/figures
+@dirrm share/gnome/help/sound-juicer/nl
@dirrm share/gnome/help/sound-juicer/es/figures
@dirrm share/gnome/help/sound-juicer/es
@dirrm share/gnome/help/sound-juicer/C/figures