aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-03-01 19:49:36 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-03-01 19:49:36 +0000
commit3b67e7aff43e111c825dd50fbd6b715819e0f083 (patch)
tree100bdba5e4fd3cf2ff3726117ae9dffdcb6243a1 /audio
parent7027d395cb4ecfdd19c1c49f16af6c16222aef22 (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/musicpd/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 8632bed2aa61..5a2dedaf549f 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= musicpd
PORTVERSION= 0.16.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio ipv6
MASTER_SITES= SF/${PORTNAME}/mpd/${PORTVERSION}
DISTNAME= mpd-${PORTVERSION}
@@ -226,9 +226,13 @@ CONFIGURE_ARGS+=--enable-lsr
.endif
post-patch:
+# Fix issues with garbled sound for 24-bit on FreeBSD. This is fixed in git,
+# so should be removed with next update.
+ @${REINPLACE_CMD} -e '383,395d;421,430d' \
+ ${WRKSRC}/src/output/oss_plugin.c
@${REINPLACE_CMD} -e "s/%%MPDDIR%%/${PREFIX:C/\//\\\//g}\/${MPDDIR:C/\//\\\//g}/g" -e "s/%%MPDUSER%%/${MPDUSER}/g" \
${WRKSRC}/doc/mpdconf.example
- ${REINPLACE_CMD} -e 's/tremor == xno/tremor = xno/' \
+ @${REINPLACE_CMD} -e 's/tremor == xno/tremor = xno/' \
${WRKSRC}/configure
.if (${OSVERSION} < 800000)
${REINPLACE_CMD} -e 's/nan[f]\{0,1\}(\"\")/NAN/g' \