aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2012-09-10 19:20:41 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2012-09-10 19:20:41 +0000
commit42602d5f21bc468d09a51c2c40c099e7c9529d2a (patch)
tree7ea5a79eeb61f954a98eb563e37c33b475c6ec68 /audio
parent734349b51e45b3b7ca3962ef3081939860edc649 (diff)
downloadports-42602d5f21bc468d09a51c2c40c099e7c9529d2a.tar.gz
ports-42602d5f21bc468d09a51c2c40c099e7c9529d2a.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/pianobar/Makefile10
-rw-r--r--audio/pianobar/distinfo4
-rw-r--r--audio/pianobar/files/patch-Makefile21
3 files changed, 26 insertions, 9 deletions
diff --git a/audio/pianobar/Makefile b/audio/pianobar/Makefile
index 8c6510cf411a..c4c6c6742205 100644
--- a/audio/pianobar/Makefile
+++ b/audio/pianobar/Makefile
@@ -6,22 +6,22 @@
#
PORTNAME= pianobar
-PORTVERSION= 2012.06.24
+PORTVERSION= 2012.09.07
CATEGORIES= audio
MASTER_SITES= http://6xq.net/projects/${PORTNAME}/
MAINTAINER= john@pcbsd.org
COMMENT= Command line Pandora player
+LICENSE= MIT
+
LIB_DEPENDS= ao:${PORTSDIR}/audio/libao \
faad:${PORTSDIR}/audio/faad \
mad:${PORTSDIR}/audio/libmad \
- gnutls.47:${PORTSDIR}/security/gnutls \
- json.0:${PORTSDIR}/devel/json-c \
+ gnutls:${PORTSDIR}/security/gnutls \
+ json:${PORTSDIR}/devel/json-c \
gcrypt:${PORTSDIR}/security/libgcrypt
-LICENSE= MIT
-
MAN1= pianobar.1
MAN_COMPRESSED= no
diff --git a/audio/pianobar/distinfo b/audio/pianobar/distinfo
index aea45d4e351d..e0d62385944f 100644
--- a/audio/pianobar/distinfo
+++ b/audio/pianobar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pianobar-2012.06.24.tar.bz2) = a80307dcfc8786c28d6025f54820664eca0cf26f888bd608c95d486762f908aa
-SIZE (pianobar-2012.06.24.tar.bz2) = 47580
+SHA256 (pianobar-2012.09.07.tar.bz2) = 1790d1f70f1516ddb3000ee95d43d42659530e8e786807edd4f4895bcbb2aa1c
+SIZE (pianobar-2012.09.07.tar.bz2) = 49641
diff --git a/audio/pianobar/files/patch-Makefile b/audio/pianobar/files/patch-Makefile
index 55577eff1756..9a1034de83ae 100644
--- a/audio/pianobar/files/patch-Makefile
+++ b/audio/pianobar/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2011-12-11 10:39:27.000000000 -0800
-+++ Makefile 2011-12-17 22:41:34.000000000 -0800
+--- Makefile.orig 2012-09-07 07:44:39.000000000 -0700
++++ Makefile 2012-09-07 14:52:09.940335486 -0700
@@ -4,7 +4,7 @@
BINDIR:=${PREFIX}/bin
LIBDIR:=${PREFIX}/lib
@@ -9,3 +9,20 @@
DYNLINK:=0
# Respect environment variables set by user; does not work with :=
+@@ -14,6 +14,7 @@
+ ifeq (${CC},cc)
+ CC=c99
+ endif
++DEPCC=cc
+
+ PIANOBAR_DIR=src
+ PIANOBAR_SRC=\
+@@ -119,7 +120,7 @@
+ # build dependency files
+ %.d: %.c
+ @set -e; rm -f $@; \
+- $(CC) -M ${CFLAGS} -I ${LIBPIANO_INCLUDE} -I ${LIBWAITRESS_INCLUDE} \
++ $(DEPCC) -M ${CFLAGS} -I ${LIBPIANO_INCLUDE} -I ${LIBWAITRESS_INCLUDE} \
+ ${LIBFAAD_CFLAGS} ${LIBMAD_CFLAGS} ${LIBGNUTLS_CFLAGS} \
+ ${LIBGCRYPT_CFLAGS} ${LIBJSONC_CFLAGS} $< > $@.$$$$; \
+ sed '1 s,^.*\.o[ :]*,$*.o $@ : ,g' < $@.$$$$ > $@; \