aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-12 19:40:09 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-12 19:40:09 +0000
commit61fd61528f137c833c7231e633277d7058be4c44 (patch)
tree21795dfff23343fcf35a7cac31809bd2bac73b08 /audio
parent891e3e2506bb793d8ae265ff9e838ea3ef434cb3 (diff)
downloadports-61fd61528f137c833c7231e633277d7058be4c44.tar.gz
ports-61fd61528f137c833c7231e633277d7058be4c44.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-wma/Makefile1
-rw-r--r--audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c50
2 files changed, 51 insertions, 0 deletions
diff --git a/audio/xmms-wma/Makefile b/audio/xmms-wma/Makefile
index ede2db62edea..1ee44708bf86 100644
--- a/audio/xmms-wma/Makefile
+++ b/audio/xmms-wma/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmms-wma
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://mcmcc.bat.ru/xmms-wma/
diff --git a/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c b/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
new file mode 100644
index 000000000000..bd02acd7ca97
--- /dev/null
+++ b/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
@@ -0,0 +1,50 @@
+--- ffmpeg-strip-wma/asf.c.orig Sun Jul 11 06:51:15 2004
++++ ffmpeg-strip-wma/asf.c Sun Jul 11 06:53:34 2004
+@@ -18,8 +18,6 @@
+ */
+ #include "avformat.h"
+ #include "avi.h"
+-//#include "mpegaudio.h"
+-#include <iconv.h>
+
+ #undef NDEBUG
+ #include <assert.h>
+@@ -830,6 +828,7 @@
+ return str;
+ }
+
++/*
+ static void tag_recode(char *before, int len)
+ {
+ int result;
+@@ -859,21 +858,22 @@
+ return;
+ return;
+ }
++*/
+
+ static void get_str16_nolen(ByteIOContext *pb, int len, char *buf, int buf_size)
+ {
+- int c, lenz;
++ int c;
+ char *q;
+
+ q = buf;
+- lenz = len;
+ while (len > 0) {
+- c = get_byte(pb);
+- if ((q - buf) < buf_size-1)
+- *q++ = c;
+- len--;
+- }
+- tag_recode(buf, lenz);
++ c = get_le16(pb);
++ if ((q - buf) < buf_size - 1)
++ *q++ = c;
++ len-=2;
++ }
++
++ *q = '\0';
+ }
+
+ static int asf_probe(AVProbeData *pd)