aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-07-08 18:42:15 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-07-08 18:42:15 +0000
commit6fe706fd4b9b0b87916cfce74ab6107039a1f1fe (patch)
tree95c3e5e00266f9da92ed052b260dfa7698b52a62 /audio
parent1af651482e6f078a83a382d14ff88fc7c50a67f3 (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/audacious-dumb/Makefile8
-rw-r--r--audio/gbsplay/Makefile3
-rw-r--r--audio/libmodplug/Makefile8
-rw-r--r--audio/libxmp/Makefile2
-rw-r--r--audio/mikmod/Makefile2
-rw-r--r--audio/ocp/Makefile3
-rw-r--r--audio/playgsf/Makefile2
-rw-r--r--audio/resid/Makefile6
-rw-r--r--audio/uade/Makefile4
-rw-r--r--audio/wav2cdr/Makefile6
-rw-r--r--audio/xmms-ahx/Makefile8
-rw-r--r--audio/xmms-nsf/Makefile6
-rw-r--r--audio/xmms-openspc/Makefile6
-rw-r--r--audio/xmms-sapplug/Makefile2
-rw-r--r--audio/xmms-volnorm/Makefile6
-rw-r--r--audio/xmms-xymms/Makefile6
-rw-r--r--audio/xmp/Makefile3
17 files changed, 21 insertions, 60 deletions
diff --git a/audio/audacious-dumb/Makefile b/audio/audacious-dumb/Makefile
index 9d87d66d92e3..9221a146ffd7 100644
--- a/audio/audacious-dumb/Makefile
+++ b/audio/audacious-dumb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: audacious-dumb
-# Date created: 27 May 2007
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= audacious-dumb
PORTVERSION= 0.82
@@ -20,7 +16,7 @@ RUN_DEPENDS= audacious:${PORTSDIR}/multimedia/audacious
BUILD_DEPENDS= audacious:${PORTSDIR}/multimedia/audacious \
${LOCALBASE}/lib/libdumb.a:${PORTSDIR}/audio/dumb
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/audio/gbsplay/Makefile b/audio/gbsplay/Makefile
index 2b8007ded3fc..365c655a525f 100644
--- a/audio/gbsplay/Makefile
+++ b/audio/gbsplay/Makefile
@@ -12,8 +12,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT?= Emulates the sound hardware of the Nintendo Game Boy(TM)
HAS_CONFIGURE= yes
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
MAKE_JOBS_SAFE= yes
USE_CSTD= gnu89
diff --git a/audio/libmodplug/Makefile b/audio/libmodplug/Makefile
index 0be13587e584..d39752207eaf 100644
--- a/audio/libmodplug/Makefile
+++ b/audio/libmodplug/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libmodplug
-# Date created: 3 February 2004
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= libmodplug
PORTVERSION= 0.8.8.4
@@ -13,8 +9,8 @@ MASTER_SITES= SF/modplug-xmms/${PORTNAME}/${PORTVERSION} CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= ModPlug mod-like music shared libraries
+USES= gmake
USE_LDCONFIG= yes
-USE_GMAKE= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/audio/libxmp/Makefile b/audio/libxmp/Makefile
index af9387574792..312cc6ca75fc 100644
--- a/audio/libxmp/Makefile
+++ b/audio/libxmp/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF/xmp/${PORTNAME}/${PORTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Module rendering library for xmp
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/audio/mikmod/Makefile b/audio/mikmod/Makefile
index 44b68b1637ae..14042cbb5f29 100644
--- a/audio/mikmod/Makefile
+++ b/audio/mikmod/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= mikmod:${PORTSDIR}/audio/libmikmod
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
index ea7406ffeee1..57bcdacfbb91 100644
--- a/audio/ocp/Makefile
+++ b/audio/ocp/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= id3tag:${PORTSDIR}/audio/libid3tag \
ONLY_FOR_ARCHS= i386 amd64
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= ncurses
+USES= ncurses gmake
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
index 307f96cd923b..b99c7a0025cb 100644
--- a/audio/playgsf/Makefile
+++ b/audio/playgsf/Makefile
@@ -13,7 +13,7 @@ COMMENT= Command-line player for gsf audio files
LIB_DEPENDS= ao:${PORTSDIR}/audio/libao
-USE_GMAKE= yes
+USES= gmake
USE_DOS2UNIX= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/audio/resid/Makefile b/audio/resid/Makefile
index 5f6462c380ab..9d2c1471ef4c 100644
--- a/audio/resid/Makefile
+++ b/audio/resid/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: resid
-# Date created: 6 October 2002
-# Whom: Anders Nordby <anders@FreeBSD.org>
-#
+# Created by: Anders Nordby <anders@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= resid
PORTVERSION= 0.16
diff --git a/audio/uade/Makefile b/audio/uade/Makefile
index 689e346922d0..cae9e61a48b8 100644
--- a/audio/uade/Makefile
+++ b/audio/uade/Makefile
@@ -1,4 +1,4 @@
-# Created by: Martin Blapp <mbr@freebsd.org>
+# Created by: Martin Blapp <mbr@FreeBSD.org>
# $FreeBSD$
PORTNAME= uade
@@ -13,9 +13,9 @@ COMMENT= Unix Amiga Delitracker Emulator
LIB_DEPENDS= ao:${PORTSDIR}/audio/libao
+USES= gmake
HAS_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
DOCSDIR= ${PREFIX}/share/doc/uade2
diff --git a/audio/wav2cdr/Makefile b/audio/wav2cdr/Makefile
index 2bb04ff660cb..5fd552927f52 100644
--- a/audio/wav2cdr/Makefile
+++ b/audio/wav2cdr/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wav2cdr
-# Date created: 9 Sep 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= wav2cdr
PORTVERSION= 2.3.3
diff --git a/audio/xmms-ahx/Makefile b/audio/xmms-ahx/Makefile
index fa8a9792c8e6..86cb9b938d64 100644
--- a/audio/xmms-ahx/Makefile
+++ b/audio/xmms-ahx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmms-ahx
-# Date created: 2 June 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= xmms-ahx
PORTVERSION= 0.6
@@ -25,7 +21,7 @@ PLIST_FILES= lib/xmms/Input/libahx.la \
lib/xmms/Input/libahx.so
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_GNOME= gtk12
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/audio/xmms-nsf/Makefile b/audio/xmms-nsf/Makefile
index c38d4b8db73b..3ccff3df8794 100644
--- a/audio/xmms-nsf/Makefile
+++ b/audio/xmms-nsf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmms-nsf
-# Date created: 18 Aug 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= xmms-nsf
PORTVERSION= 0.0.3
diff --git a/audio/xmms-openspc/Makefile b/audio/xmms-openspc/Makefile
index 3a3cf5686e6f..68817d35a4f0 100644
--- a/audio/xmms-openspc/Makefile
+++ b/audio/xmms-openspc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmms-openspc
-# Date created: 11 June 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= openspc
PORTVERSION= 0.0.3
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index ec9846a7ecd1..e83381444f14 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-USE_GMAKE= yes
+USES= gmake
USE_GNOME= glib12
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/audio/xmms-volnorm/Makefile b/audio/xmms-volnorm/Makefile
index 8647f29bbff4..abf8bc09798f 100644
--- a/audio/xmms-volnorm/Makefile
+++ b/audio/xmms-volnorm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmms-volnorm
-# Date created: Fri Aug 17 12:17:23 EDT 2001
-# Whom: Patrick Li <pat@databits.net>
-#
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
-#
PORTNAME= volnorm
PORTVERSION= 0.8.3
diff --git a/audio/xmms-xymms/Makefile b/audio/xmms-xymms/Makefile
index 7c43c5f8bd92..118b7cc5ee4c 100644
--- a/audio/xmms-xymms/Makefile
+++ b/audio/xmms-xymms/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmms-xymms
-# Date created: 27 Jun 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= xymms
DISTVERSION= 0.9.1
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index c160ac7369aa..71969464f983 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= xmp:${PORTSDIR}/audio/libxmp
-USES= pkgconfig
-USE_GMAKE= yes
+USES= pkgconfig gmake
WANT_GNOME= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes