aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2012-12-02 11:28:40 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2012-12-02 11:28:40 +0000
commitfa8b6d84583a1fee96bd53d32a00ba9c81fb5196 (patch)
tree28bfec9fb73393314f8f5d8eabde174576aee348 /audio
parent7f7b08fe5419ff111ffa5e2584211f96b7a21e8d (diff)
. create a link from native asound configuration file at LINUXBASE/etc; [1]
. bump PORTREVISION; . trim headers to two line style; . remove the article from COMMENT. PR: ports/169896 [1] Submitted by: Jan Beich <jbeich@tormail.org> [1] Feature safe: yes
Notes
Notes: svn path=/head/; revision=308098
Diffstat (limited to 'audio')
-rw-r--r--audio/linux-f10-alsa-lib/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/audio/linux-f10-alsa-lib/Makefile b/audio/linux-f10-alsa-lib/Makefile
index 72657bf2908c..dbf030f20004 100644
--- a/audio/linux-f10-alsa-lib/Makefile
+++ b/audio/linux-f10-alsa-lib/Makefile
@@ -1,20 +1,16 @@
-# New ports collection makefile for: audio/linux-f10-alsa-lib
-# Date created: 2009-05-03
-# Whom: bsam
-#
# $FreeBSD$
-#
+# Created by: Boris Samorodov <bsam@FreeBSD.org>
PORTNAME= alsa-lib
PORTVERSION= 1.0.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio linux
MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
PKGNAMEPREFIX= linux-f10-
DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= emulation@FreeBSD.org
-COMMENT= The Advanced Linux Sound Architecture libraries (Linux Fedora 10)
+COMMENT= Advanced Linux Sound Architecture libraries (Linux Fedora 10)
CONFLICTS= linux-alsa-lib-[0-9]* linux-f8-alsa-lib-[0-9]*
@@ -25,4 +21,11 @@ RPMVERSION= 2.fc10
BRANDELF_FILES= usr/bin/aserver
USE_LDCONFIG= yes
+# We will use some other configuration file, so delete a linux one
+post-extract:
+ @${RM} -r ${WRKSRC}/etc
+
+post-install:
+ @${LN} -s ${LOCALBASE}/etc/asound.conf ${PREFIX}/etc/asound.conf
+
.include <bsd.port.mk>