aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 08:49:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 08:49:46 +0000
commit019f2422aaa071ea4b35d1bc3b69068878ea93d5 (patch)
treee9e009fc092528bdc298f66c506930624e74cb2c /audio
parent4dfe867ac40f1b052a2f64bf10a0f33f79b55dbe (diff)
downloadports-019f2422aaa071ea4b35d1bc3b69068878ea93d5.tar.gz
ports-019f2422aaa071ea4b35d1bc3b69068878ea93d5.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/bmp-songchange/Makefile8
-rw-r--r--audio/cantus_3/Makefile2
-rw-r--r--audio/cowbell/Makefile2
-rw-r--r--audio/gqmpeg-devel/Makefile2
-rw-r--r--audio/hexter/Makefile2
-rw-r--r--audio/ipod-sharp/Makefile2
-rw-r--r--audio/jack_mixer/Makefile8
-rw-r--r--audio/padevchooser/Makefile2
-rw-r--r--audio/paman/Makefile2
-rw-r--r--audio/paprefs/Makefile2
-rw-r--r--audio/pavucontrol/Makefile2
-rw-r--r--audio/pavumeter/Makefile2
-rw-r--r--audio/solfege/Makefile2
-rw-r--r--audio/xmms-crossfade/Makefile1
-rw-r--r--audio/xmms-modplug/Makefile1
15 files changed, 19 insertions, 21 deletions
diff --git a/audio/bmp-songchange/Makefile b/audio/bmp-songchange/Makefile
index 8283358d3851..98465c334876 100644
--- a/audio/bmp-songchange/Makefile
+++ b/audio/bmp-songchange/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bmp-song_change
-# Date created: 27 January, 2005
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= bmp-songchange
PORTVERSION= 0.0.2
@@ -19,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player
+USES= pkgconfig
+
GNU_CONFIGURE= yes
PLIST_FILES= lib/bmp/General/libsong_change.so
diff --git a/audio/cantus_3/Makefile b/audio/cantus_3/Makefile
index 6230383bf8c9..d0d1cb4b65a9 100644
--- a/audio/cantus_3/Makefile
+++ b/audio/cantus_3/Makefile
@@ -21,7 +21,7 @@ CONFLICTS= cantus-1*
LATEST_LINK= ${PORTNAME}3
-USES= gmake pathfix gettext
+USES= gmake pathfix gettext pkgconfig
USE_GNOME= gnomeprefix libglade2 glib20
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/audio/cowbell/Makefile b/audio/cowbell/Makefile
index 755236f66d85..1ded81b09407 100644
--- a/audio/cowbell/Makefile
+++ b/audio/cowbell/Makefile
@@ -12,7 +12,7 @@ COMMENT= Elegant music organizer
LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib
-USES= gmake pathfix gettext iconv
+USES= gmake pathfix gettext iconv pkgconfig
USE_GNOME= gnomeprefix intltool gtksharp20
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/audio/gqmpeg-devel/Makefile b/audio/gqmpeg-devel/Makefile
index 43bf60bcd36d..73395ffe8456 100644
--- a/audio/gqmpeg-devel/Makefile
+++ b/audio/gqmpeg-devel/Makefile
@@ -12,6 +12,8 @@ COMMENT= Another gtk-based MP3 frontend
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+USES= pkgconfig
+
.if defined(WITH_MPG321)
RUN_DEPENDS+= mpg321:${PORTSDIR}/audio/mpg321
.else
diff --git a/audio/hexter/Makefile b/audio/hexter/Makefile
index 63f28ba28680..f30adcad785b 100644
--- a/audio/hexter/Makefile
+++ b/audio/hexter/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= dssialsacompat:${PORTSDIR}/audio/libdssialsacompat \
BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake pkgconfig
USE_GNOME= gtk20
PORTDOCS= AUTHORS ChangeLog README TODO
diff --git a/audio/ipod-sharp/Makefile b/audio/ipod-sharp/Makefile
index 34cd7215811b..4c0a56b3da1b 100644
--- a/audio/ipod-sharp/Makefile
+++ b/audio/ipod-sharp/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/podsleuth.pc:${PORTSDIR}/misc/podsle
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USES= gmake pathfix
+USES= gmake pathfix pkgconfig
USE_GNOME= gtksharp20
.include <bsd.port.mk>
diff --git a/audio/jack_mixer/Makefile b/audio/jack_mixer/Makefile
index ed3fe4f18423..9d182cad79b8 100644
--- a/audio/jack_mixer/Makefile
+++ b/audio/jack_mixer/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection Makefile for: jack_mixer
-# Date created: 13 August 2010
-# Whom: gahr
-#
+# Created by: gahr
# $FreeBSD$
-#
PORTNAME= jack_mixer
PORTVERSION= 9
@@ -20,6 +15,7 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/fpconst.py:${PORTSDIR}/math/py-fpconst \
${LOCALBASE}/include/pygtk-2.0/pygtk/pygtk.h:${PORTSDIR}/x11-toolkits/py-gtk2
RUN_DEPENDS:= ${BUILD_DEPENDS}
+USES= pkgconfig
USE_PYTHON= yes
USE_GNOME= gconf2
GCONF_SCHEMAS= jack_mixer.schemas
diff --git a/audio/padevchooser/Makefile b/audio/padevchooser/Makefile
index 0441f25401a2..e611f6ba6fce 100644
--- a/audio/padevchooser/Makefile
+++ b/audio/padevchooser/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
RUN_DEPENDES= dbus-daemon:${PORTSDIR}/devel/dbus
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake pkgconfig
CONFIGURE_ARGS= --disable-lynx
diff --git a/audio/paman/Makefile b/audio/paman/Makefile
index 11cb4a5153da..41e5e3b38590 100644
--- a/audio/paman/Makefile
+++ b/audio/paman/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
pulse.0:${PORTSDIR}/audio/pulseaudio
GNU_CONFIGURE= yes
-USES= gmake pathfix
+USES= gmake pathfix pkgconfig
CONFIGURE_ARGS= --disable-lynx
diff --git a/audio/paprefs/Makefile b/audio/paprefs/Makefile
index 566460bb27ae..d7aed2372e98 100644
--- a/audio/paprefs/Makefile
+++ b/audio/paprefs/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
pulse.0:${PORTSDIR}/audio/pulseaudio
GNU_CONFIGURE= yes
-USES= gmake pathfix
+USES= gmake pathfix pkgconfig
USE_GNOME= gnomeprefix intltool
CONFIGURE_ARGS= --disable-lynx
diff --git a/audio/pavucontrol/Makefile b/audio/pavucontrol/Makefile
index 93369d277d3c..ef7ce504bc16 100644
--- a/audio/pavucontrol/Makefile
+++ b/audio/pavucontrol/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
canberra:${PORTSDIR}/audio/libcanberra
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake pkgconfig
USE_GNOME= intltool
CONFIGURE_ARGS= --disable-lynx
diff --git a/audio/pavumeter/Makefile b/audio/pavumeter/Makefile
index b5af97aff7ca..d99621cb9f3b 100644
--- a/audio/pavumeter/Makefile
+++ b/audio/pavumeter/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
pulse.0:${PORTSDIR}/audio/pulseaudio
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake pkgconfig
CONFIGURE_ARGS= --disable-lynx
diff --git a/audio/solfege/Makefile b/audio/solfege/Makefile
index 728a2e709be4..db8a8f8ffc1b 100644
--- a/audio/solfege/Makefile
+++ b/audio/solfege/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${STYLESHEET}:${PORTSDIR}/textproc/docbook-xsl \
USE_GNOME= pygtk2
WANT_GNOME= yes
USE_PYTHON= yes
-USES= gettext gmake display pathfix
+USES= gettext gmake display pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_XML2PO=""
CONFIGURE_ARGS= --disable-oss-sound \
diff --git a/audio/xmms-crossfade/Makefile b/audio/xmms-crossfade/Makefile
index 8754e5d73a74..dfad156bd4e5 100644
--- a/audio/xmms-crossfade/Makefile
+++ b/audio/xmms-crossfade/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS?= xmms.4:${PORTSDIR}/multimedia/xmms
HAS_CONFIGURE= yes
USE_CSTD= gnu89
+USES= pkgconfig
APP?= xmms
.if ${APP} == bmp
PORTVERSION= 0.3.12
diff --git a/audio/xmms-modplug/Makefile b/audio/xmms-modplug/Makefile
index e093bb24a28f..81c0f276f298 100644
--- a/audio/xmms-modplug/Makefile
+++ b/audio/xmms-modplug/Makefile
@@ -15,6 +15,7 @@ COMMENT= ModPlug-based plugin for XMMS
LIB_DEPENDS?= xmms:${PORTSDIR}/multimedia/xmms
LIB_DEPENDS+= modplug:${PORTSDIR}/audio/libmodplug
+USES= pkgconfig
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
PLUGDIR?= lib/xmms/Input