aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-07-03 02:59:58 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-07-03 02:59:58 +0000
commit0cc0a163428edf7025c12e0bbfdc4f6e2105b35a (patch)
tree10c36d10041ebc7b2adddf48b0db867b2d8dbebc /audio
parent27c23f8ab371e4106de11d208c7659323bf3d810 (diff)
downloadports-0cc0a163428edf7025c12e0bbfdc4f6e2105b35a.tar.gz
ports-0cc0a163428edf7025c12e0bbfdc4f6e2105b35a.zip
MFH: r541065
audio/audacity: Update to 2.4.2 - This should fix hangs on startup on FreeBSD 11.4 - Remove NYQUIST option since it is mandatory and disabling it does not work Changes: https://www.audacityteam.org/audacity-2-4-2-released/ PR: 247604 Submitted by: maintainer Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2020Q3/; revision=541066
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity/Makefile12
-rw-r--r--audio/audacity/distinfo6
-rw-r--r--audio/audacity/files/patch-cmake-proxies_CMakeLists.txt6
-rw-r--r--audio/audacity/files/patch-cmake-proxies_sbsms_CMakeLists.txt10
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h2
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h2
-rw-r--r--audio/audacity/files/patch-src_AboutDialog.cpp11
-rw-r--r--audio/audacity/files/patch-src_AudioIO.cpp6
-rw-r--r--audio/audacity/files/patch-src_FFmpeg.h6
-rw-r--r--audio/audacity/pkg-plist1
10 files changed, 31 insertions, 31 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 6e52d5bf2d4e..73f750cae3a6 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 2.4.1
+PORTVERSION= 2.4.2
DISTVERSIONPREFIX= Audacity-
CATEGORIES= audio
@@ -35,18 +35,19 @@ CMAKE_ARGS= -Daudacity_lib_preference:STRING=system \
-Daudacity_use_portsmf:STRING=local \
-Daudacity_use_portmixer:STRING=local \
-Daudacity_use_portaudio:STRING=system
+CMAKE_OFF= audacity_use_pch
OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME LV2 MAD \
- MIDI NYQUIST OGG SBSMS SOUNDTOUCH TWOLAME VAMP \
+ MIDI OGG SBSMS SOUNDTOUCH TWOLAME VAMP \
VORBIS VST
-OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD MIDI NYQUIST OGG SBSMS \
+OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD MIDI OGG SBSMS \
SOUNDTOUCH TWOLAME VAMP VORBIS VST
+OPTIONS_EXCLUDE_i386= SBSMS
LAME_DESC= Use lame for import and export support
LV2_DESC= Add LV2 plug-in support
MAD_DESC= Use libmad for mp2/3 decoding support
MIDI_DESC= MIDI support
-NYQUIST_DESC= Nyquist synthesis and composition support
SBSMS_DESC= Use libsbsms for pitch and tempo changing
SOUNDTOUCH_DESC= Use libSoundTouch for pitch and tempo changing
TWOLAME_DESC= Use libtwolame for MP2 export support
@@ -99,9 +100,6 @@ MIDI_CMAKE_OFF= -Daudacity_use_midi:STRING=off
# TODO: fix NLS support properly
PLIST_SUB+= NLS=""
-NYQUIST_CMAKE_ON= -Daudacity_use_nyquist:STRING=local
-NYQUIST_CMAKE_OFF= -Daudacity_use_nyquist:STRING=off
-
OGG_CMAKE_ON= -Daudacity_use_ogg:STRING=system
OGG_CMAKE_OFF= -Daudacity_use_ogg:STRING=local
OGG_LIB_DEPENDS= libogg.so:audio/libogg
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index 908045f09f2e..f0de0d092a4f 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589881433
-SHA256 (audacity-audacity-Audacity-2.4.1_GH0.tar.gz) = 50240f07471373a7e5c2df65cc26eeeaaced9a0850ad1f95cb795f171ea3009f
-SIZE (audacity-audacity-Audacity-2.4.1_GH0.tar.gz) = 63935461
+TIMESTAMP = 1593304211
+SHA256 (audacity-audacity-Audacity-2.4.2_GH0.tar.gz) = cdb4800c8e9d1d4ca19964caf8d24000f80286ebd8a4db566c2622449744c099
+SIZE (audacity-audacity-Audacity-2.4.2_GH0.tar.gz) = 61248430
diff --git a/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt b/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
index 21ef4fdde283..4f1dbe0e6300 100644
--- a/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
+++ b/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
@@ -1,7 +1,7 @@
---- cmake-proxies/CMakeLists.txt.orig 2020-05-19 09:43:53 UTC
+--- cmake-proxies/CMakeLists.txt.orig 2020-06-19 15:16:47 UTC
+++ cmake-proxies/CMakeLists.txt
-@@ -150,7 +150,7 @@ addlib( lame lame LAME YES
- addlib( lib-widget-extra libextra EXTRA YES YES "" )
+@@ -132,7 +132,7 @@ addlib( expat expat EXPAT YES
+ addlib( lame lame LAME YES YES "lame >= 3.100" )
addlib( libsndfile sndfile SNDFILE YES YES "sndfile >= 1.0.28" )
addlib( libsoxr soxr SOXR YES YES "soxr >= 0.1.1" )
-addlib( portaudio-v19 portaudio PORTAUDIO YES YES "" )
diff --git a/audio/audacity/files/patch-cmake-proxies_sbsms_CMakeLists.txt b/audio/audacity/files/patch-cmake-proxies_sbsms_CMakeLists.txt
deleted file mode 100644
index d135faa0794f..000000000000
--- a/audio/audacity/files/patch-cmake-proxies_sbsms_CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- cmake-proxies/sbsms/CMakeLists.txt.orig 2020-05-19 09:43:53 UTC
-+++ cmake-proxies/sbsms/CMakeLists.txt
-@@ -28,6 +28,7 @@ list( APPEND INCLUDES
- list( APPEND OPTIONS
- PRIVATE
- $<$<C_COMPILER_ID:AppleClang,Clang,GNU>:-Wno-enum-compare>
-+ ${SSE_FLAG}
- )
-
- find_package( Threads )
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
index 035825c57c69..30388586d0be 100644
--- a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
+++ b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
@@ -1,6 +1,6 @@
--- lib-src/libnyquist/nyquist/cmt/cext.h.orig 2018-10-01 14:07:33 UTC
+++ lib-src/libnyquist/nyquist/cmt/cext.h
-@@ -58,7 +58,7 @@ EXIT(n) -- calls exit(n) after shutting down/dealloca
+@@ -61,7 +61,7 @@ EXIT(n) -- calls exit(n) after shutting down/dealloca
#include <malloc.h>
#endif
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
index 6b9914f06e76..cbf7ec305e7c 100644
--- a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
+++ b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
@@ -1,6 +1,6 @@
--- lib-src/libnyquist/nyquist/xlisp/xlisp.h.orig 2016-07-26 13:34:06 UTC
+++ lib-src/libnyquist/nyquist/xlisp/xlisp.h
-@@ -160,6 +160,15 @@ extern long ptrtoabs();
+@@ -161,6 +161,15 @@ extern long ptrtoabs();
#endif
#endif
diff --git a/audio/audacity/files/patch-src_AboutDialog.cpp b/audio/audacity/files/patch-src_AboutDialog.cpp
new file mode 100644
index 000000000000..36cf61b58bff
--- /dev/null
+++ b/audio/audacity/files/patch-src_AboutDialog.cpp
@@ -0,0 +1,11 @@
+--- src/AboutDialog.cpp.orig 2020-06-28 06:25:54 UTC
++++ src/AboutDialog.cpp
+@@ -63,7 +63,7 @@ hold information about one contributor to Audacity.
+ // RevisionIdent.h may contain #defines like these ones:
+ //#define REV_LONG "28864acb238cb3ca71dda190a2d93242591dd80e"
+ //#define REV_TIME "Sun Apr 12 12:40:22 2015 +0100"
+-#include <RevisionIdent.h>
++//#include <RevisionIdent.h>
+
+ #ifndef REV_TIME
+ #define REV_TIME "unknown date and time"
diff --git a/audio/audacity/files/patch-src_AudioIO.cpp b/audio/audacity/files/patch-src_AudioIO.cpp
index ea9211797476..6cc523faba46 100644
--- a/audio/audacity/files/patch-src_AudioIO.cpp
+++ b/audio/audacity/files/patch-src_AudioIO.cpp
@@ -1,6 +1,6 @@
---- src/AudioIO.cpp.orig 2018-10-01 14:07:33 UTC
+--- src/AudioIO.cpp.orig 2020-06-19 15:16:47 UTC
+++ src/AudioIO.cpp
-@@ -480,7 +480,6 @@ TimeTrack and AudioIOListener and whether the playback
+@@ -491,7 +491,6 @@ time warp info and AudioIOListener and whether the pla
#define ROUND(x) (int) ((x)+0.5)
//#include <string.h>
// #include "../lib-src/portmidi/pm_common/portmidi.h"
@@ -8,7 +8,7 @@
#include "NoteTrack.h"
#endif
-@@ -793,13 +797,22 @@ struct AudioIO::ScrubState (private)
+@@ -815,13 +814,22 @@ struct AudioIoCallback::ScrubState (private)
// return the system time as a double
static double streamStartTime = 0; // bias system time to small number
diff --git a/audio/audacity/files/patch-src_FFmpeg.h b/audio/audacity/files/patch-src_FFmpeg.h
index ab1b2088aad3..de19b2a86437 100644
--- a/audio/audacity/files/patch-src_FFmpeg.h
+++ b/audio/audacity/files/patch-src_FFmpeg.h
@@ -1,6 +1,6 @@
--- src/FFmpeg.h.orig 2018-10-01 14:07:33 UTC
+++ src/FFmpeg.h
-@@ -667,7 +667,7 @@ extern "C" {
+@@ -685,7 +685,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
AVOutputFormat*,
av_oformat_next,
@@ -9,7 +9,7 @@
(f)
);
#endif
-@@ -748,7 +748,7 @@ extern "C" {
+@@ -766,7 +766,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
int,
av_fifo_size,
@@ -18,7 +18,7 @@
(f)
);
#endif
-@@ -810,7 +810,7 @@ extern "C" {
+@@ -828,7 +828,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
AVDictionaryEntry *,
av_dict_get,
diff --git a/audio/audacity/pkg-plist b/audio/audacity/pkg-plist
index 89c9bdced953..22a98a03a8e4 100644
--- a/audio/audacity/pkg-plist
+++ b/audio/audacity/pkg-plist
@@ -3,6 +3,7 @@ man/man1/audacity.1.gz
share/appdata/audacity.appdata.xml
share/applications/audacity.desktop
%%DATADIR%%/EQDefaultCurves.xml
+%%DATADIR%%/modules/mod-script-pipe.so
%%DATADIR%%/nyquist/aud-do-support.lsp
%%DATADIR%%/nyquist/dspprims.lsp
%%DATADIR%%/nyquist/envelopes.lsp