aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-06-25 03:58:49 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-06-25 03:58:49 +0000
commit3f61da87d7a765c58a34c959778f1e2d410e4de8 (patch)
treed8dd2044be2621ede6217af79aa001e002a6d524 /audio
parent9d9b615b5285580a5ac1eef294edbfe0c3e0e17c (diff)
downloadports-3f61da87d7a765c58a34c959778f1e2d410e4de8.tar.gz
ports-3f61da87d7a765c58a34c959778f1e2d410e4de8.zip
audio/ripperx: Use gnudb.org by default, freedb.org is gone
Notes
Notes: svn path=/head/; revision=540365
Diffstat (limited to 'audio')
-rw-r--r--audio/ripperx/Makefile2
-rw-r--r--audio/ripperx/files/patch-src_config__rw.c9
2 files changed, 9 insertions, 2 deletions
diff --git a/audio/ripperx/Makefile b/audio/ripperx/Makefile
index 364966596d6b..573df9c37352 100644
--- a/audio/ripperx/Makefile
+++ b/audio/ripperx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ripperx
PORTVERSION= 2.7.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= SF
DISTNAME= ripperX-${PORTVERSION}
diff --git a/audio/ripperx/files/patch-src_config__rw.c b/audio/ripperx/files/patch-src_config__rw.c
index f8cdbba1c0b4..308fe90c2f23 100644
--- a/audio/ripperx/files/patch-src_config__rw.c
+++ b/audio/ripperx/files/patch-src_config__rw.c
@@ -1,6 +1,6 @@
--- src/config_rw.c.orig 2008-01-25 09:53:50 UTC
+++ src/config_rw.c
-@@ -87,9 +87,9 @@ static struct {
+@@ -87,15 +87,15 @@ static struct {
{ "Encoder::Plugin", config.encoder.plugin,
STRING, 0, "ripperX_plugin-lame" },
{ "CdPlayer::Play_command", config.cd_player.play_command,
@@ -12,3 +12,10 @@
{ "WavPlayer::Command", config.wav_player.command,
STRING, 0, "play %" },
{ "Mp3Player::Command", config.mp3_player.command,
+ STRING, 0, "mpg123 %" },
+ { "CDDBConfig::Server", config.cddb_config.server,
+- STRING, 0, "freedb.freedb.org/~cddb/cddb.cgi" },
++ STRING, 0, "gnudb.gnudb.org/~cddb/cddb.cgi" },
+ { "CDDBConfig::Port", &config.cddb_config.port,
+ INT, 0, "80" },
+ { "CDDBConfig::UseHttp", &config.cddb_config.use_http,