aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2011-02-05 16:56:54 +0000
committerDima Panov <fluffy@FreeBSD.org>2011-02-05 16:56:54 +0000
commit6e0427c402095b579ca869b7202211c226187afe (patch)
tree9f65c6ccf43e535fdd30f6e2a07209e270a28952 /audio
parentfe8dc59bb02ff5167d5c73cbecf16c074264955c (diff)
downloadports-6e0427c402095b579ca869b7202211c226187afe.tar.gz
ports-6e0427c402095b579ca869b7202211c226187afe.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/amarok-kde4/Makefile11
-rw-r--r--audio/amarok-kde4/distinfo5
-rw-r--r--audio/amarok-kde4/files/patch-src__EngineController.cpp19
-rw-r--r--audio/amarok-kde4/pkg-plist114
4 files changed, 92 insertions, 57 deletions
diff --git a/audio/amarok-kde4/Makefile b/audio/amarok-kde4/Makefile
index 049188d8a330..519b0f8f257a 100644
--- a/audio/amarok-kde4/Makefile
+++ b/audio/amarok-kde4/Makefile
@@ -5,17 +5,19 @@
# $FreeBSD$
PORTNAME= amarok
-PORTVERSION= 2.3.2
+PORTVERSION= 2.4.0
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
-MAINTAINER= datahead4@gmail.com
+MAINTAINER= kde@FreeBSD.org
COMMENT= Media player for KDE4
LIB_DEPENDS= tag.1:${PORTSDIR}/audio/taglib \
tag-extras.1:${PORTSDIR}/audio/taglib-extras \
lastfm.0:${PORTSDIR}/audio/liblastfm \
+ ofa:${PORTSDIR}/audio/libofa \
+ avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
qca.2:${PORTSDIR}/devel/qca
BUILD_DEPENDS= ${LOCALBASE}/lib/qt4/plugins/script/libqtscript_core.so.1.0.0:${PORTSDIR}/devel/qtscriptgenerator \
@@ -26,7 +28,7 @@ LATEST_LINK= ${PORTNAME}-kde4
MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
-USE_KDE4= kdehier kdeprefix kdelibs automoc4
+USE_KDE4= kdehier kdeprefix kdelibs runtime automoc4
USE_QT_VER= 4
QT_COMPONENTS= corelib gui network opengl script svg webkit \
qmake_build moc_build rcc_build uic_build phonon
@@ -77,7 +79,6 @@ post-extract:
${WRKSRC}/cmake/modules/FindMySQLAmarok.cmake
${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
${WRKSRC}/cmake/modules/FindIpod.cmake \
- ${WRKSRC}/cmake/modules/FindLoudmouth.cmake \
- ${WRKSRC}/cmake/modules/FindGdk.cmake
+ ${WRKSRC}/cmake/modules/FindLoudmouth.cmake
.include <bsd.port.mk>
diff --git a/audio/amarok-kde4/distinfo b/audio/amarok-kde4/distinfo
index eecc2237ef1c..69c97e736452 100644
--- a/audio/amarok-kde4/distinfo
+++ b/audio/amarok-kde4/distinfo
@@ -1,3 +1,2 @@
-MD5 (amarok-2.3.2.tar.bz2) = 4e03dc009f8b44d9b8dfb5f6d1034081
-SHA256 (amarok-2.3.2.tar.bz2) = 842569da06b4ebfc334f3530a77f900ea30b3b8968698bda8082b4b991488237
-SIZE (amarok-2.3.2.tar.bz2) = 13948250
+SHA256 (amarok-2.4.0.tar.bz2) = 52be0e926d1362828a4bf64e2a174dc009c85f6f33da4ca589f0f09ab9b7085c
+SIZE (amarok-2.4.0.tar.bz2) = 15219572
diff --git a/audio/amarok-kde4/files/patch-src__EngineController.cpp b/audio/amarok-kde4/files/patch-src__EngineController.cpp
deleted file mode 100644
index a1e023bac072..000000000000
--- a/audio/amarok-kde4/files/patch-src__EngineController.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/src/EngineController.cpp b/src/EngineController.cpp
-index 521e570..3d57dad 100644
---- ./src/EngineController.cpp
-+++ ./src/EngineController.cpp
-@@ -172,10 +172,14 @@
- connect( m_controller, SIGNAL( titleChanged( int ) ), SLOT( slotTitleChanged( int ) ) );
-
-
-+ // Gapless Playback is temporarily disabled. Reason: Trying to find a bug in this code that makes
-+ // the EngineController stop after each track, with all Phonon backends except the xine backend.
-+#if 0
- if( AmarokConfig::trackDelayLength() > -1 )
- m_media->setTransitionTime( AmarokConfig::trackDelayLength() ); // Also Handles gapless.
- else if( AmarokConfig::crossfadeLength() > 0 ) // TODO: Handle the possible options on when to crossfade.. the values are not documented anywhere however
- m_media->setTransitionTime( -AmarokConfig::crossfadeLength() );
-+#endif
- }
-
-
diff --git a/audio/amarok-kde4/pkg-plist b/audio/amarok-kde4/pkg-plist
index 051475154845..b923d27819bd 100644
--- a/audio/amarok-kde4/pkg-plist
+++ b/audio/amarok-kde4/pkg-plist
@@ -10,7 +10,9 @@ lib/kde4/amarok_collection-daapcollection.so
%%MTP%%lib/kde4/amarok_collection-mtpcollection.so
lib/kde4/amarok_collection-mysqlecollection.so
lib/kde4/amarok_collection-mysqlservercollection.so
+lib/kde4/amarok_collection-playdarcollection.so
lib/kde4/amarok_collection-umscollection.so
+lib/kde4/amarok_collection-upnpcollection.so
lib/kde4/amarok_containment_vertical.so
lib/kde4/amarok_context_applet_albums.so
lib/kde4/amarok_context_applet_currenttrack.so
@@ -19,6 +21,7 @@ lib/kde4/amarok_context_applet_labels.so
lib/kde4/amarok_context_applet_lyrics.so
lib/kde4/amarok_context_applet_photos.so
lib/kde4/amarok_context_applet_similarArtists.so
+lib/kde4/amarok_context_applet_tabs.so
lib/kde4/amarok_context_applet_upcomingEvents.so
lib/kde4/amarok_context_applet_videoclip.so
lib/kde4/amarok_context_applet_wikipedia.so
@@ -28,6 +31,7 @@ lib/kde4/amarok_data_engine_labels.so
lib/kde4/amarok_data_engine_lyrics.so
lib/kde4/amarok_data_engine_photos.so
lib/kde4/amarok_data_engine_similarArtists.so
+lib/kde4/amarok_data_engine_tabs.so
lib/kde4/amarok_data_engine_upcomingEvents.so
lib/kde4/amarok_data_engine_videoclip.so
lib/kde4/amarok_data_engine_wikipedia.so
@@ -46,6 +50,9 @@ lib/kde4/kcm_amarok_service_magnatunestore.so
lib/libamarok-sqlcollection.so
lib/libamarok-sqlcollection.so.1
lib/libamarok-sqlcollection.so.1.0.0
+lib/libamarok-transcoding.so
+lib/libamarok-transcoding.so.1
+lib/libamarok-transcoding.so.1.0.0
lib/libamarokcore.so
lib/libamarokcore.so.1
lib/libamarokcore.so.1.0.0
@@ -58,8 +65,10 @@ lib/libamarokocsclient.so.5.0.1
lib/libamarokpud.so
lib/libamarokpud.so.1
lib/libamarokpud.so.1.0.0
-lib/strigi/strigita_audible.so
-lib/strigi/strigita_mp4.so
+lib/libamarokqtjson.so
+lib/libamarokqtjson.so.1
+lib/libamarokqtjson.so.1.0.0
+lib/libampache_account_login.so
share/applications/kde4/amarok.desktop
share/applications/kde4/amarok_containers.desktop
share/apps/amarok/amarok.notifyrc
@@ -71,6 +80,7 @@ share/apps/amarok/data/bullet.gif
share/apps/amarok/data/first_run_jingle.ogg
share/apps/amarok/data/hover_info_template.html
share/apps/amarok/data/info_frontpage.html
+share/apps/amarok/data/upcoming-events-map.html
share/apps/amarok/icons/hicolor/128x128/status/audio-volume-high-amarok.png
share/apps/amarok/icons/hicolor/128x128/status/audio-volume-low-amarok.png
share/apps/amarok/icons/hicolor/128x128/status/audio-volume-medium-amarok.png
@@ -114,7 +124,7 @@ share/apps/amarok/icons/hicolor/16x16/actions/filename-title-amarok.png
share/apps/amarok/icons/hicolor/16x16/actions/filename-track-amarok.png
share/apps/amarok/icons/hicolor/16x16/actions/filename-underscore-amarok.png
share/apps/amarok/icons/hicolor/16x16/actions/filename-year-amarok.png
-share/apps/amarok/icons/hicolor/16x16/actions/lastfm-loved-radio-amarok.png
+share/apps/amarok/icons/hicolor/16x16/actions/lastfm-mix-radio-amarok.png
share/apps/amarok/icons/hicolor/16x16/actions/lastfm-neighbour-radio-amarok.png
share/apps/amarok/icons/hicolor/16x16/actions/lastfm-personal-radio-amarok.png
share/apps/amarok/icons/hicolor/16x16/actions/lastfm-recommended-radio-amarok.png
@@ -325,6 +335,7 @@ share/apps/amarok/icons/hicolor/48x48/actions/filename-track-amarok.png
share/apps/amarok/icons/hicolor/48x48/actions/filename-underscore-amarok.png
share/apps/amarok/icons/hicolor/48x48/actions/filename-year-amarok.png
share/apps/amarok/icons/hicolor/48x48/actions/info-amarok.png
+share/apps/amarok/icons/hicolor/48x48/actions/label-amarok.png
share/apps/amarok/icons/hicolor/48x48/actions/love-amarok.png
share/apps/amarok/icons/hicolor/48x48/actions/media-album-cover-manager-amarok.png
share/apps/amarok/icons/hicolor/48x48/actions/media-album-repeat-amarok.png
@@ -365,6 +376,10 @@ share/apps/amarok/icons/hicolor/48x48/actions/view-services-lastfm-amarok.png
share/apps/amarok/icons/hicolor/48x48/actions/view-services-magnatune-amarok.png
share/apps/amarok/icons/hicolor/48x48/actions/view-services-mp3tunes-amarok.png
share/apps/amarok/images/FilenameLayoutDialogHint.png
+share/apps/amarok/images/amarok-tabs-bass.png
+share/apps/amarok/images/amarok-tabs-drum.png
+share/apps/amarok/images/amarok-tabs-guitar.png
+share/apps/amarok/images/amarok-tabs-piano.png
share/apps/amarok/images/amarok-videoclip-dailymotion.png
share/apps/amarok/images/amarok-videoclip-vimeo.png
share/apps/amarok/images/amarok-videoclip-youtube.png
@@ -413,6 +428,9 @@ share/apps/amarok/images/likeback_feature.png
share/apps/amarok/images/likeback_like.png
share/apps/amarok/images/loading1.png
share/apps/amarok/images/loading2.png
+share/apps/amarok/images/mb_aicon.png
+share/apps/amarok/images/mb_licon.png
+share/apps/amarok/images/mb_ticon.png
share/apps/amarok/images/navigation_arrows.svg
share/apps/amarok/images/nocover.png
share/apps/amarok/images/opendesktop-22.png
@@ -470,24 +488,55 @@ share/config/amarokapplets.knsrc
share/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
share/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
share/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
+share/dbus-1/interfaces/org.kde.amarok.App.xml
share/dbus-1/interfaces/org.kde.amarok.Collection.xml
-share/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
+share/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
+share/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
share/doc/HTML/de/amarok/common
share/doc/HTML/de/amarok/index.cache.bz2
share/doc/HTML/de/amarok/index.docbook
-share/doc/HTML/en/amarok/Amarok2.1center.png
-share/doc/HTML/en/amarok/Amarok2.1contextviewconfig.png
+share/doc/HTML/en/amarok/Addingmusic.png
+share/doc/HTML/en/amarok/Amarok-addingmusic2.png
+share/doc/HTML/en/amarok/Amarok-context.png
+share/doc/HTML/en/amarok/Amarok-contextadd.png
+share/doc/HTML/en/amarok/Amarok-removefromplaylist.png
+share/doc/HTML/en/amarok/Amarok-renameplaylist.png
share/doc/HTML/en/amarok/Amarok2.1covermanager.png
share/doc/HTML/en/amarok/Amarok2.1dynamicplaylist.png
-share/doc/HTML/en/amarok/Amarok2.1internetservices.png
share/doc/HTML/en/amarok/Amarok2.1ipod.png
-share/doc/HTML/en/amarok/Amarok2.1left.png
share/doc/HTML/en/amarok/Amarok2.1pleditor.png
-share/doc/HTML/en/amarok/Amarok2.1popup.png
share/doc/HTML/en/amarok/Amarok2.1rating.png
share/doc/HTML/en/amarok/Amarok2.1right.png
share/doc/HTML/en/amarok/Amarok2.1scriptmanager.png
-share/doc/HTML/en/amarok/Amarok2.1svn965006.png
+share/doc/HTML/en/amarok/Amarok_-_internet_services.png
+share/doc/HTML/en/amarok/Amarokbreadcrumb.png
+share/doc/HTML/en/amarok/Amarokcollection.png
+share/doc/HTML/en/amarok/Amarokfull.png
+share/doc/HTML/en/amarok/Amarokmediasources-files.png
+share/doc/HTML/en/amarok/Amarokmediasources-home.png
+share/doc/HTML/en/amarok/Amarokrightmenu.png
+share/doc/HTML/en/amarok/Amarokripcd.png
+share/doc/HTML/en/amarok/Amaroksystray.png
+share/doc/HTML/en/amarok/Applications-internet.png
+share/doc/HTML/en/amarok/Cd_collection_sansa.png
+share/doc/HTML/en/amarok/Configurecollection.png
+share/doc/HTML/en/amarok/Context-applets-amarok.png
+share/doc/HTML/en/amarok/Controlamarok.png
+share/doc/HTML/en/amarok/Document-save.png
+share/doc/HTML/en/amarok/Edit-redo.png
+share/doc/HTML/en/amarok/Edit-undo.png
+share/doc/HTML/en/amarok/Firstruncollection2.png
+share/doc/HTML/en/amarok/Folder-amarok.png
+share/doc/HTML/en/amarok/Hi32-action-collection-amarok.png
+share/doc/HTML/en/amarok/Hi48-action-clear-playlist-amarok.png
+share/doc/HTML/en/amarok/Hi48-action-media-standard-track-progression-amarok.png
+share/doc/HTML/en/amarok/Hi48-action-music-amarok.png
+share/doc/HTML/en/amarok/Hi48-action-podcast-amarok.png
+share/doc/HTML/en/amarok/Mediasources.png
+share/doc/HTML/en/amarok/Preferences-other.png
+share/doc/HTML/en/amarok/Pud-amarok.png
+share/doc/HTML/en/amarok/View-list-tree.png
+share/doc/HTML/en/amarok/View-media-playlist.png
share/doc/HTML/en/amarok/common
share/doc/HTML/en/amarok/index.cache.bz2
share/doc/HTML/en/amarok/index.docbook
@@ -573,19 +622,29 @@ share/doc/HTML/sv/amarok/index.docbook
share/doc/HTML/sv/amarok/quick.docbook
share/doc/HTML/sv/amarok/requirements.docbook
share/doc/HTML/sv/amarok/using.docbook
-share/doc/HTML/uk/amarok/Amarok2.1center.png
-share/doc/HTML/uk/amarok/Amarok2.1contextviewconfig.png
+share/doc/HTML/uk/amarok/Addingmusic.png
+share/doc/HTML/uk/amarok/Amarok-context.png
+share/doc/HTML/uk/amarok/Amarok-contextadd.png
share/doc/HTML/uk/amarok/Amarok2.1covermanager.png
share/doc/HTML/uk/amarok/Amarok2.1dynamicplaylist.png
-share/doc/HTML/uk/amarok/Amarok2.1internetservices.png
share/doc/HTML/uk/amarok/Amarok2.1ipod.png
-share/doc/HTML/uk/amarok/Amarok2.1left.png
share/doc/HTML/uk/amarok/Amarok2.1pleditor.png
-share/doc/HTML/uk/amarok/Amarok2.1popup.png
share/doc/HTML/uk/amarok/Amarok2.1rating.png
share/doc/HTML/uk/amarok/Amarok2.1right.png
share/doc/HTML/uk/amarok/Amarok2.1scriptmanager.png
share/doc/HTML/uk/amarok/Amarok2.1svn965006.png
+share/doc/HTML/uk/amarok/Amarok_-_context_view_configuration.png
+share/doc/HTML/uk/amarok/Amarok_-_internet_services.png
+share/doc/HTML/uk/amarok/Amarokbreadcrumb.png
+share/doc/HTML/uk/amarok/Amarokcollection.png
+share/doc/HTML/uk/amarok/Amarokfull.png
+share/doc/HTML/uk/amarok/Amarokmediasources-home.png
+share/doc/HTML/uk/amarok/Amarokrightmenu.png
+share/doc/HTML/uk/amarok/Amarokripcd.png
+share/doc/HTML/uk/amarok/Configurecollection.png
+share/doc/HTML/uk/amarok/Context-applets-amarok.png
+share/doc/HTML/uk/amarok/Firstruncollection2.png
+share/doc/HTML/uk/amarok/Mediasources.png
share/doc/HTML/uk/amarok/common
share/doc/HTML/uk/amarok/index.cache.bz2
share/doc/HTML/uk/amarok/index.docbook
@@ -604,6 +663,7 @@ share/kde4/services/amarok-context-applet-labels.desktop
share/kde4/services/amarok-context-applet-lyrics.desktop
share/kde4/services/amarok-context-applet-photos.desktop
share/kde4/services/amarok-context-applet-similarArtists.desktop
+share/kde4/services/amarok-context-applet-tabs.desktop
share/kde4/services/amarok-context-applet-upcomingEvents.desktop
share/kde4/services/amarok-context-applet-videoclip.desktop
share/kde4/services/amarok-context-applet-wikipedia.desktop
@@ -613,6 +673,7 @@ share/kde4/services/amarok-data-engine-labels.desktop
share/kde4/services/amarok-data-engine-lyrics.desktop
share/kde4/services/amarok-data-engine-photos.desktop
share/kde4/services/amarok-data-engine-similarArtists.desktop
+share/kde4/services/amarok-data-engine-tabs.desktop
share/kde4/services/amarok-data-engine-upcomingEvents.desktop
share/kde4/services/amarok-data-engine-videoclip.desktop
share/kde4/services/amarok-data-engine-wikipedia.desktop
@@ -625,7 +686,9 @@ share/kde4/services/amarok_collection-daapcollection.desktop
%%MTP%%share/kde4/services/amarok_collection-mtpcollection.desktop
share/kde4/services/amarok_collection-mysqlecollection.desktop
share/kde4/services/amarok_collection-mysqlservercollection.desktop
+share/kde4/services/amarok_collection-playdarcollection.desktop
share/kde4/services/amarok_collection-umscollection.desktop
+share/kde4/services/amarok_collection-upnpcollection.desktop
share/kde4/services/amarok_massstorage-device.desktop
share/kde4/services/amarok_service_ampache.desktop
share/kde4/services/amarok_service_ampache_config.desktop
@@ -643,11 +706,6 @@ share/kde4/servicetypes/amarok_codecinstall.desktop
share/kde4/servicetypes/amarok_context_applet.desktop
share/kde4/servicetypes/amarok_data_engine.desktop
share/kde4/servicetypes/amarok_plugin.desktop
-share/locale/af/LC_MESSAGES/amarok.mo
-share/locale/bg/LC_MESSAGES/amarok.mo
-share/locale/bg/LC_MESSAGES/amarok_scriptengine_qscript.mo
-share/locale/bg/LC_MESSAGES/amarokcollectionscanner_qt.mo
-share/locale/bg/LC_MESSAGES/amarokpkg.mo
share/locale/ca/LC_MESSAGES/amarok.mo
share/locale/ca/LC_MESSAGES/amarok_scriptengine_qscript.mo
share/locale/ca/LC_MESSAGES/amarokcollectionscanner_qt.mo
@@ -668,10 +726,6 @@ share/locale/de/LC_MESSAGES/amarok.mo
share/locale/de/LC_MESSAGES/amarok_scriptengine_qscript.mo
share/locale/de/LC_MESSAGES/amarokcollectionscanner_qt.mo
share/locale/de/LC_MESSAGES/amarokpkg.mo
-share/locale/el/LC_MESSAGES/amarok.mo
-share/locale/el/LC_MESSAGES/amarok_scriptengine_qscript.mo
-share/locale/el/LC_MESSAGES/amarokcollectionscanner_qt.mo
-share/locale/el/LC_MESSAGES/amarokpkg.mo
share/locale/en_GB/LC_MESSAGES/amarok.mo
share/locale/en_GB/LC_MESSAGES/amarok_scriptengine_qscript.mo
share/locale/en_GB/LC_MESSAGES/amarokcollectionscanner_qt.mo
@@ -743,10 +797,6 @@ share/locale/ru/LC_MESSAGES/amarok.mo
share/locale/ru/LC_MESSAGES/amarok_scriptengine_qscript.mo
share/locale/ru/LC_MESSAGES/amarokcollectionscanner_qt.mo
share/locale/ru/LC_MESSAGES/amarokpkg.mo
-share/locale/sk/LC_MESSAGES/amarok.mo
-share/locale/sk/LC_MESSAGES/amarok_scriptengine_qscript.mo
-share/locale/sk/LC_MESSAGES/amarokcollectionscanner_qt.mo
-share/locale/sk/LC_MESSAGES/amarokpkg.mo
share/locale/sl/LC_MESSAGES/amarok.mo
share/locale/sl/LC_MESSAGES/amarok_scriptengine_qscript.mo
share/locale/sl/LC_MESSAGES/amarokcollectionscanner_qt.mo
@@ -771,16 +821,20 @@ share/locale/sv/LC_MESSAGES/amarok.mo
share/locale/sv/LC_MESSAGES/amarok_scriptengine_qscript.mo
share/locale/sv/LC_MESSAGES/amarokcollectionscanner_qt.mo
share/locale/sv/LC_MESSAGES/amarokpkg.mo
-share/locale/th/LC_MESSAGES/amarok.mo
-share/locale/th/LC_MESSAGES/amarokpkg.mo
share/locale/uk/LC_MESSAGES/amarok.mo
share/locale/uk/LC_MESSAGES/amarok_scriptengine_qscript.mo
share/locale/uk/LC_MESSAGES/amarokcollectionscanner_qt.mo
share/locale/uk/LC_MESSAGES/amarokpkg.mo
+share/locale/wa/LC_MESSAGES/amarok.mo
+share/locale/wa/LC_MESSAGES/amarokcollectionscanner_qt.mo
share/locale/zh_CN/LC_MESSAGES/amarok.mo
share/locale/zh_CN/LC_MESSAGES/amarok_scriptengine_qscript.mo
share/locale/zh_CN/LC_MESSAGES/amarokcollectionscanner_qt.mo
share/locale/zh_CN/LC_MESSAGES/amarokpkg.mo
+share/locale/zh_TW/LC_MESSAGES/amarok.mo
+share/locale/zh_TW/LC_MESSAGES/amarok_scriptengine_qscript.mo
+share/locale/zh_TW/LC_MESSAGES/amarokcollectionscanner_qt.mo
+share/locale/zh_TW/LC_MESSAGES/amarokpkg.mo
@dirrmtry share/locale/x-test/LC_MESSAGES
@dirrmtry share/locale/x-test
@dirrm share/doc/HTML/uk/amarok