aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-12-29 14:17:15 +0000
committerChris Rees <crees@FreeBSD.org>2013-12-29 14:17:15 +0000
commit757ae83b727ee6f65ffe0fd6557df0199caf4ee5 (patch)
tree938fec78ed55e0ce817f2ff451ff25fdfead0420 /audio
parent1c55544dd8903e3221e0c20ed692fe4a5f253d5b (diff)
downloadports-757ae83b727ee6f65ffe0fd6557df0199caf4ee5.tar.gz
ports-757ae83b727ee6f65ffe0fd6557df0199caf4ee5.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/id3ren/Makefile16
-rw-r--r--audio/rebot3/Makefile13
-rw-r--r--audio/tkeca/Makefile22
-rw-r--r--audio/tkeca/pkg-plist2
4 files changed, 21 insertions, 32 deletions
diff --git a/audio/id3ren/Makefile b/audio/id3ren/Makefile
index e48ddc4f796f..b9b473a6aca6 100644
--- a/audio/id3ren/Makefile
+++ b/audio/id3ren/Makefile
@@ -16,10 +16,7 @@ GH_ACCOUNT= sebcode
GH_TAGNAME= 322ee77
GH_COMMIT= 322ee77
-NO_STAGE= yes
-PLIST_FILES= bin/id3ren
-MAN1= id3ren.1
-MANCOMPRESSED= yes
+PLIST_FILES= bin/id3ren man/man1/id3ren.1.gz
PORTDOCS= AUTHORS ChangeLog FEATURES FEEDBACK INSTALL PORTS \
README THANKS TODO USAGE
@@ -30,10 +27,13 @@ pre-patch:
${WRKSRC}/src/id3ren.c ${WRKSRC}/src/id3misc.c
${RM} ${WRKSRC}/src/id3ren
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1.gz \
+ ${STAGEDIR}${PREFIX}/man/man1/
+
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/audio/rebot3/Makefile b/audio/rebot3/Makefile
index 8b6c28026c9a..c9cd9f69f2fc 100644
--- a/audio/rebot3/Makefile
+++ b/audio/rebot3/Makefile
@@ -15,13 +15,9 @@ RUN_DEPENDS= p5-CDDB>=0:${PORTSDIR}/audio/p5-CDDB \
p5-MP3-ID3v1Tag>=0:${PORTSDIR}/audio/p5-MP3-ID3v1Tag
USES= perl5
-NO_STAGE= yes
NO_BUILD= yes
-MAN1= ${PORTNAME}.1
-PLIST_FILES= bin/${PORTNAME}
-
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
post-patch:
# Yes, we know it's perl, but we don't want to type '.pl' the whole time.
@@ -31,8 +27,9 @@ post-patch:
${WRKSRC}/${PORTNAME}.pl ${WRKSRC}/${PORTNAME}.pl.1
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.pl.1 \
- ${MAN1PREFIX}/man/man1/${PORTNAME}.1
+ ${STAGEDIR}${PREFIX}/man/man1/${PORTNAME}.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/tkeca/Makefile b/audio/tkeca/Makefile
index ddf46a75ed9d..7b6094ee871d 100644
--- a/audio/tkeca/Makefile
+++ b/audio/tkeca/Makefile
@@ -13,27 +13,21 @@ LICENSE= GPLv2
RUN_DEPENDS= normalize:${PORTSDIR}/audio/normalize \
ecasound:${PORTSDIR}/audio/ecasound
-USE_GNOME= desktopfileutils
-NO_STAGE= yes
-USE_TCL= yes
-USE_TK= yes
+USES= desktop-file-utils tk
NO_BUILD= yes
PORTDOCS= *
-.include <bsd.port.options.mk>
-
post-patch:
${REINPLACE_CMD} -e '3s,^exec wish,exec ${WISH},' ${WRKSRC}/tkeca.tcl
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/tkeca.tcl ${PREFIX}/bin/tkeca
- ${INSTALL_DATA} ${WRKSRC}/tkeca.png ${PREFIX}/share/pixmaps/
- ${INSTALL_DATA} ${WRKSRC}/tkeca.desktop ${PREFIX}/share/applications/
- -@update-desktop-database
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/tkeca.html ${WRKSRC}/README.tkeca ${DOCSDIR}/
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/tkeca.tcl ${STAGEDIR}${PREFIX}/bin/tkeca
+ ${INSTALL_DATA} ${WRKSRC}/tkeca.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/tkeca.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tkeca.html ${WRKSRC}/README.tkeca \
+ ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/audio/tkeca/pkg-plist b/audio/tkeca/pkg-plist
index 16e1fe512576..b34cd894d3bf 100644
--- a/audio/tkeca/pkg-plist
+++ b/audio/tkeca/pkg-plist
@@ -1,5 +1,3 @@
bin/tkeca
share/applications/tkeca.desktop
share/pixmaps/tkeca.png
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true