aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-21 08:24:07 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-21 08:24:07 +0000
commitafdc7719a6f7de8da171140bec4233e5a391360f (patch)
tree9db6dbdf97aa38ab1f8de47521f2126998c9622c /audio
parent16c9a2fb6d7f8798a51d9dbae12a8ee37d893721 (diff)
downloadports-afdc7719a6f7de8da171140bec4233e5a391360f.tar.gz
ports-afdc7719a6f7de8da171140bec4233e5a391360f.zip
MFH: r542725
audio/bharvestr-lv2: fix build on GCC architectures Require C++11 compiler because of -std=c++11. Include climits in FileChooser.hpp because of INT64_MAX (GCC doesn't do that by default). PR: 248134 Approved by: portmgr (blanket: build fix)
Notes
Notes: svn path=/branches/2020Q3/; revision=542726
Diffstat (limited to 'audio')
-rw-r--r--audio/bharvestr-lv2/Makefile2
-rw-r--r--audio/bharvestr-lv2/files/patch-src_BWidgets_FileChooser.hpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/audio/bharvestr-lv2/Makefile b/audio/bharvestr-lv2/Makefile
index c6890da21ed0..e3493eca33b4 100644
--- a/audio/bharvestr-lv2/Makefile
+++ b/audio/bharvestr-lv2/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libsndfile.so:audio/libsndfile
-USES= gmake gnome pkgconfig xorg
+USES= compiler:c++11-lang gmake gnome pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= sjaehn
GH_PROJECT= BHarvestr
diff --git a/audio/bharvestr-lv2/files/patch-src_BWidgets_FileChooser.hpp b/audio/bharvestr-lv2/files/patch-src_BWidgets_FileChooser.hpp
new file mode 100644
index 000000000000..8d2f5329e0b6
--- /dev/null
+++ b/audio/bharvestr-lv2/files/patch-src_BWidgets_FileChooser.hpp
@@ -0,0 +1,10 @@
+--- src/BWidgets/FileChooser.hpp.orig 2020-07-20 09:39:49 UTC
++++ src/BWidgets/FileChooser.hpp
+@@ -24,6 +24,7 @@
+ #include "PopupListBox.hpp"
+ #include "TextButton.hpp"
+ #include <regex>
++#include <climits>
+
+ namespace BWidgets
+ {