aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-07 04:56:15 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-07 04:56:15 +0000
commit17743c66c1d99a368f2cabd99ac6e55bd3c3a2ee (patch)
treef5d4089be347fbd930d9254c4259bb68549ba724 /audio
parentf6d38fb40849da2f9abe123c07f4a3fb695d92ea (diff)
downloadports-17743c66c1d99a368f2cabd99ac6e55bd3c3a2ee.tar.gz
ports-17743c66c1d99a368f2cabd99ac6e55bd3c3a2ee.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/flac/Makefile2
-rw-r--r--audio/grip/Makefile2
-rw-r--r--audio/id3lib/Makefile23
-rw-r--r--audio/id3lib/distinfo2
-rw-r--r--audio/id3lib/files/patch-Makefile.am14
-rw-r--r--audio/id3lib/files/patch-Makefile.in13
-rw-r--r--audio/id3lib/files/patch-configure.in14
-rw-r--r--audio/id3lib/files/patch-src_tag__file.cpp72
-rw-r--r--audio/id3lib/files/patch-src_tag__parse.cpp23
-rw-r--r--audio/id3lib/files/patch-src_tag__parse__lyrics3.cpp23
-rw-r--r--audio/id3lib/files/patch-src_tag__parse__musicmatch.cpp53
-rw-r--r--audio/id3lib/files/patch-src_tag__parse__v1.cpp14
-rw-r--r--audio/id3lib/files/patch-src_utils.cpp41
-rw-r--r--audio/id3lib/pkg-plist18
-rw-r--r--audio/id3v2/Makefile8
-rw-r--r--audio/id3v2/distinfo2
-rw-r--r--audio/id3v2/files/patch-aa33
-rw-r--r--audio/id3v2/files/patch-ab74
-rw-r--r--audio/id3v2/files/patch-ac77
19 files changed, 64 insertions, 444 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index e6c7bbd2f058..c7c430743d4e 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
.if defined(WITH_XMMS)
# id3lib is only used by the XMMS plugin
BUILD_DEPENDS+= xmms-config:${PORTSDIR}/multimedia/xmms
-LIB_DEPENDS+= id3-3.7.13:${PORTSDIR}/audio/id3lib \
+LIB_DEPENDS+= id3-3.8.2:${PORTSDIR}/audio/id3lib \
xmms.3:${PORTSDIR}/multimedia/xmms
CONFIGURE_ARGS+=--with-id3lib="${LOCALBASE}"
PLIST_SUB= XMMS=""
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 864a68a05ec1..eded348952f9 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR=grip
MAINTAINER= alane@FreeBSD.org
-LIB_DEPENDS= id3-3.7.13:${PORTSDIR}/audio/id3lib \
+LIB_DEPENDS= id3-3.8.2:${PORTSDIR}/audio/id3lib \
ghttp.1:${PORTSDIR}/www/libghttp
USE_X_PREFIX= yes
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index becde3771bd4..a85f492e3817 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -6,25 +6,30 @@
#
PORTNAME= id3lib
-PORTVERSION= 3.7.13
+PORTVERSION= 3.8.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= roman@xpert.com
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
-USE_AUTOMAKE= yes
-USE_GMAKE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+BROKEN= "Doesn't link properly, std::char_traits<wchar_t> thingie"
+.endif
+
post-extract:
-.for i in zlib popt
- ${RM} -rf ${WRKSRC}/$i
-.endfor
+ @${RM} -rf ${WRKSRC}/zlib
+
+post-install:
+ @${RM} -f ${LOCALBASE}/lib/libid3.la
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/id3lib/distinfo b/audio/id3lib/distinfo
index 223e085b16eb..80e965257f64 100644
--- a/audio/id3lib/distinfo
+++ b/audio/id3lib/distinfo
@@ -1 +1 @@
-MD5 (id3lib-3.7.13.tar.gz) = 19ab352ac8d522ebcabb85f2445bfced
+MD5 (id3lib-3.8.2.tar.gz) = b5da9d2f714203eb6f78f63d1725ff39
diff --git a/audio/id3lib/files/patch-Makefile.am b/audio/id3lib/files/patch-Makefile.am
deleted file mode 100644
index 837430a55f2b..000000000000
--- a/audio/id3lib/files/patch-Makefile.am
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.am.orig Fri Sep 15 02:13:51 2000
-+++ Makefile.am Sun Jul 21 15:13:19 2002
-@@ -32,7 +32,7 @@
- popt_subdir =
- endif
-
--SUBDIRS = . m4 $(popt_subdir) $(zlib_subdir) doc include src examples
-+SUBDIRS = . m4 doc include src examples
- DIST_SUBDIRS = . m4 popt zlib doc include src examples
-
- INCLUDES = @ID3LIB_DEBUG_FLAGS@
diff --git a/audio/id3lib/files/patch-Makefile.in b/audio/id3lib/files/patch-Makefile.in
new file mode 100644
index 000000000000..5214338a8125
--- /dev/null
+++ b/audio/id3lib/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in.orig Fri Dec 6 10:37:42 2002
++++ Makefile.in Fri Dec 6 10:38:10 2002
+@@ -132,8 +132,8 @@
+ @ID3_NEEDZLIB_TRUE@zlib_subdir = zlib
+ @ID3_NEEDZLIB_FALSE@zlib_subdir =
+
+-SUBDIRS = . m4 $(zlib_subdir) doc include id3com src examples
+-DIST_SUBDIRS = . m4 zlib doc include id3com src examples prj libprj
++SUBDIRS = . m4 doc include id3com src examples
++DIST_SUBDIRS = . m4 doc include id3com src examples prj libprj
+
+ INCLUDES = @ID3LIB_DEBUG_FLAGS@
+
diff --git a/audio/id3lib/files/patch-configure.in b/audio/id3lib/files/patch-configure.in
deleted file mode 100644
index c9b7b12866f9..000000000000
--- a/audio/id3lib/files/patch-configure.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- configure.in.orig Fri Sep 15 02:03:02 2000
-+++ configure.in Sun Jul 21 15:13:19 2002
-@@ -143,7 +143,7 @@
- )
- AC_LANG_SAVE
- AC_LANG_CPLUSPLUS
--AC_CHECK_HEADER(iostream.h iomanip.h)
-+AC_CHECK_HEADERS(iostream.h iomanip.h)
-
- dnl Check for functions.
- AC_FUNC_MEMCMP
diff --git a/audio/id3lib/files/patch-src_tag__file.cpp b/audio/id3lib/files/patch-src_tag__file.cpp
deleted file mode 100644
index 3fed50e74ff1..000000000000
--- a/audio/id3lib/files/patch-src_tag__file.cpp
+++ /dev/null
@@ -1,72 +0,0 @@
-
-$FreeBSD$
-
---- src/tag_file.cpp.orig Mon Sep 11 09:46:32 2000
-+++ src/tag_file.cpp Sun Jul 21 15:13:19 2002
-@@ -184,7 +184,7 @@
- }
- }
-
-- file.write(sTag, tag_size);
-+ file.write((const char*) sTag, tag_size);
-
- return tag_size;
- }
-@@ -221,7 +221,7 @@
- file.seekp(0, ios::beg);
- if (buffer)
- {
-- file.write(buffer, tag_size);
-+ file.write((const char*) buffer, tag_size);
- }
- }
- else
-@@ -282,8 +282,9 @@
- remove(sTempFile);
- ID3_THROW_DESC(ID3E_NoFile, "couldn't open temp file");
- }
--
-- ofstream tmpOut(fd);
-+
-+ close(fd);
-+ ofstream tmpOut(sTempFile);
- if (!tmpOut)
- {
- tmpOut.close();
-@@ -292,15 +293,15 @@
- }
- if (buffer)
- {
-- tmpOut.write(buffer, tag_size);
-+ tmpOut.write((const char*) buffer, tag_size);
- }
- file.seekg(tag.GetPrependedBytes(), ios::beg);
- uchar buffer2[BUFSIZ];
- while (file)
- {
-- file.read(buffer2, BUFSIZ);
-+ file.read((char*) buffer2, BUFSIZ);
- size_t nBytes = file.gcount();
-- tmpOut.write(buffer2, nBytes);
-+ tmpOut.write((const char*) buffer2, nBytes);
- }
-
- tmpOut.close();
-@@ -431,7 +432,7 @@
- while (!file.eof())
- {
- size_t nBytesToRead = MIN(nBytesRemaining - nBytesCopied, BUFSIZ);
-- file.read(aucBuffer, nBytesToRead);
-+ file.read((char*) aucBuffer, nBytesToRead);
- size_t nBytesRead = file.gcount();
-
- if (nBytesRead != nBytesToRead)
-@@ -444,7 +445,7 @@
- {
- long offset = nBytesRead + this->GetPrependedBytes();
- file.seekp(-offset, ios::cur);
-- file.write(aucBuffer, nBytesRead);
-+ file.write((const char*) aucBuffer, nBytesRead);
- file.seekg(this->GetPrependedBytes(), ios::cur);
- nBytesCopied += nBytesRead;
- }
diff --git a/audio/id3lib/files/patch-src_tag__parse.cpp b/audio/id3lib/files/patch-src_tag__parse.cpp
deleted file mode 100644
index b685a7353795..000000000000
--- a/audio/id3lib/files/patch-src_tag__parse.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- src/tag_parse.cpp.orig Fri Sep 15 01:54:08 2000
-+++ src/tag_parse.cpp Sun Jul 21 15:13:19 2002
-@@ -178,7 +178,7 @@
- return 0;
- }
- uchar header[ID3_TAGHEADERSIZE];
-- file.read(header, ID3_TAGHEADERSIZE);
-+ file.read((char*) header, ID3_TAGHEADERSIZE);
- if (file.gcount() != ID3_TAGHEADERSIZE)
- {
- return 0;
-@@ -188,7 +188,7 @@
- if (tagSize > 0)
- {
- uchar* bin = new uchar[tagSize];
-- file.read(bin, tagSize - ID3_TagHeader::SIZE);
-+ file.read((char*) bin, tagSize - ID3_TagHeader::SIZE);
- if (tagSize != (size_t)file.gcount())
- {
- // log this...
diff --git a/audio/id3lib/files/patch-src_tag__parse__lyrics3.cpp b/audio/id3lib/files/patch-src_tag__parse__lyrics3.cpp
deleted file mode 100644
index 17ee04f6349d..000000000000
--- a/audio/id3lib/files/patch-src_tag__parse__lyrics3.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- src/tag_parse_lyrics3.cpp.orig Mon Sep 11 08:34:06 2000
-+++ src/tag_parse_lyrics3.cpp Sun Jul 21 15:13:19 2002
-@@ -200,7 +200,7 @@
- // reserve enough space for lyrics3 + id3v1 tag
- const size_t max_lyr_size = 11 + 5100 + 9 + 128;
-
-- size_t lyr_buffer_size = MIN(max_lyr_size, file.tellg());
-+ size_t lyr_buffer_size = MIN(max_lyr_size, (size_t) file.tellg());
-
- file.seekg(- static_cast<long>(lyr_buffer_size), ios::cur);
- if (!file)
-@@ -274,7 +274,7 @@
-
- // Using binary minus rather than unary minus to avoid compiler warning
-
-- file.seekg(- MIN(file.tellg(),
-+ file.seekg(- MIN((size_t) file.tellg(),
- (static_cast<long>(lyr_size) + 6 + 9 + 3)), ios::cur);
- if (!file)
- {
diff --git a/audio/id3lib/files/patch-src_tag__parse__musicmatch.cpp b/audio/id3lib/files/patch-src_tag__parse__musicmatch.cpp
deleted file mode 100644
index efc5c2629094..000000000000
--- a/audio/id3lib/files/patch-src_tag__parse__musicmatch.cpp
+++ /dev/null
@@ -1,53 +0,0 @@
-
-$FreeBSD$
-
---- src/tag_parse_musicmatch.cpp.orig Mon Sep 11 09:46:32 2000
-+++ src/tag_parse_musicmatch.cpp Sun Jul 21 15:13:19 2002
-@@ -221,7 +221,7 @@
- return 0;
- }
-
-- file.seekg(tag_end - tag_size);
-+ file.seekg((size_t) tag_end - tag_size);
- tag_beg = file.tellg();
-
- // Now calculate the actual offsets
-@@ -229,17 +229,17 @@
- offsets[0] = tag_beg;
- for (size_t i = 0; i < 4; ++i)
- {
-- offsets[i+1] = offsets[i] + section_sizes[i];
-+ offsets[i+1] = offsets[i] + (streampos) section_sizes[i];
- }
-
- // now check for a tag header and adjust the tag_beg pointer appropriately
- if (tag_beg >= 256)
- {
-- file.seekg(tag_beg - 256);
-+ file.seekg((size_t) tag_beg - 256);
- file.read(sig, 8);
- if (memcmp(sig, "18273645", 8) == 0)
- {
-- file.seekg(tag_beg - 256);
-+ file.seekg((size_t) tag_beg - 256);
- tag_beg = file.tellg();
- file.ignore(256);
- }
-@@ -267,7 +267,7 @@
- {
- // no image binary. don't do anything.
- }
-- else if (offsets[0] + 4 + nImgSize > static_cast<size_t>(offsets[2]))
-+ else if ((size_t) offsets[0] + 4 + nImgSize > static_cast<size_t>(offsets[2]))
- {
- // Ack! The image size given extends beyond the next offset! This is
- // not good... log?
-@@ -275,7 +275,7 @@
- else
- {
- uchar* img_data = new uchar[nImgSize];
-- file.read(img_data, nImgSize);
-+ file.read((char*) img_data, nImgSize);
- ID3_Frame* frame = new ID3_Frame(ID3FID_PICTURE);
- if (frame)
- {
diff --git a/audio/id3lib/files/patch-src_tag__parse__v1.cpp b/audio/id3lib/files/patch-src_tag__parse__v1.cpp
deleted file mode 100644
index 0fa75dbffe55..000000000000
--- a/audio/id3lib/files/patch-src_tag__parse__v1.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/tag_parse_v1.cpp.orig Mon Sep 11 08:34:06 2000
-+++ src/tag_parse_v1.cpp Sun Jul 21 15:13:19 2002
-@@ -67,7 +67,7 @@
- {
- const size_t data_size = ID3_V1_LEN - ID3_V1_LEN_ID;
- uchar tag_bytes[data_size];
-- file.read(tag_bytes, data_size);
-+ file.read((char*) tag_bytes, data_size);
- if (file.gcount() != data_size)
- {
- return num_bytes;
diff --git a/audio/id3lib/files/patch-src_utils.cpp b/audio/id3lib/files/patch-src_utils.cpp
deleted file mode 100644
index 582967c26659..000000000000
--- a/audio/id3lib/files/patch-src_utils.cpp
+++ /dev/null
@@ -1,41 +0,0 @@
-
-$FreeBSD$
-
---- src/utils.cpp.orig Mon Sep 11 09:46:32 2000
-+++ src/utils.cpp Sun Jul 21 15:13:19 2002
-@@ -231,7 +231,7 @@
-
- bool exists(const char *name)
- {
-- ifstream file(name, ios::nocreate);
-+ ifstream file(name/*, ios::nocreate*/);
- return file.is_open() != 0;
- }
-
-@@ -256,7 +256,7 @@
- size_t size = 0;
- if (file.is_open())
- {
-- streamoff curpos = file.tellp();
-+ streampos curpos = file.tellp();
- file.seekp(0, ios::end);
- size = file.tellp();
- file.seekp(curpos);
-@@ -275,7 +275,7 @@
- {
- file.close();
- }
-- file.open(name, ios::in | ios::out | ios::binary | ios::nocreate);
-+ file.open(name, ios::in | ios::out | ios::binary /*| ios::nocreate*/);
- if (!file)
- {
- return ID3E_ReadOnly;
-@@ -290,7 +290,7 @@
- {
- file.close();
- }
-- file.open(name, ios::in | ios::binary | ios::nocreate);
-+ file.open(name, ios::in | ios::binary /*| ios::nocreate*/);
- if (!file)
- {
- return ID3E_NoFile;
diff --git a/audio/id3lib/pkg-plist b/audio/id3lib/pkg-plist
index 1cc62be02676..ad07c9a0c499 100644
--- a/audio/id3lib/pkg-plist
+++ b/audio/id3lib/pkg-plist
@@ -3,19 +3,21 @@ bin/id3cp
bin/id3info
bin/id3tag
include/id3.h
-include/id3/error.h
include/id3/field.h
-include/id3/flags.h
-include/id3/frame.h
include/id3/globals.h
-include/id3/header.h
-include/id3/header_frame.h
-include/id3/header_tag.h
+include/id3/id3lib_frame.h
+include/id3/id3lib_streams.h
+include/id3/id3lib_strings.h
include/id3/misc_support.h
+include/id3/reader.h
+include/id3/readers.h
include/id3/sized_types.h
-include/id3/spec.h
include/id3/tag.h
-lib/libid3-3.7.so.13
+include/id3/utils.h
+include/id3/writer.h
+include/id3/writers.h
+lib/libid3-3.8.so
+lib/libid3-3.8.so.2
lib/libid3.a
lib/libid3.so
@dirrm include/id3
diff --git a/audio/id3v2/Makefile b/audio/id3v2/Makefile
index e7c0a63d6ad6..1bd555796039 100644
--- a/audio/id3v2/Makefile
+++ b/audio/id3v2/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= id3v2
-PORTVERSION= 0.1.2
+PORTVERSION= 0.1.7
CATEGORIES= audio
-MASTER_SITES= http://download.sourceforge.net/id3v2/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= id3v2
MAINTAINER= djm@pix.net
-LIB_DEPENDS= id3:${PORTSDIR}/audio/id3lib gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= id3-3.8.2:${PORTSDIR}/audio/id3lib \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
MAN1= id3v2.1
diff --git a/audio/id3v2/distinfo b/audio/id3v2/distinfo
index 982c101ac1f0..8a55cf8e31d6 100644
--- a/audio/id3v2/distinfo
+++ b/audio/id3v2/distinfo
@@ -1 +1 @@
-MD5 (id3v2-0.1.2.tar.gz) = 6bc856e78da102c2f012db63d516806e
+MD5 (id3v2-0.1.7.tar.gz) = 825cf4baf60e2951b7826b947a8f52fa
diff --git a/audio/id3v2/files/patch-aa b/audio/id3v2/files/patch-aa
index c28b486e1d59..13ca63b4dfdd 100644
--- a/audio/id3v2/files/patch-aa
+++ b/audio/id3v2/files/patch-aa
@@ -1,18 +1,21 @@
---- Makefile.orig Thu Apr 6 17:23:27 2000
-+++ Makefile Wed Oct 10 16:59:49 2001
-@@ -1,7 +1,12 @@
-+PREFIX = /usr/local
-+CXXFLAGS += -I${PREFIX}/include
-+LDFLAGS += -L${PREFIX}/lib
-+
- all: id3v2
+--- Makefile.orig Tue Apr 16 04:35:31 2002
++++ Makefile Sun Dec 22 03:51:30 2002
+@@ -1,10 +1,9 @@
+-all: id3v2
++CC= c++
++PROG= id3v2
++SRCS= id3v2.cpp list.cpp convert.cpp
++CXXFLAGS+= -I${DESTDIR}${PREFIX}/include
++LDADD+= -L${DESTDIR}${PREFIX}/lib -lid3 -lz -lgnugetopt
++DPADD+= ${LIBZ}
++DPADD+= ${DESTDIR}${PREFIX}/lib/libid3.a
-id3v2: Makefile convert.cpp list.cpp id3v2.cpp convert.cpp
-- g++ -lid3 -g -o id3v2 id3v2.cpp list.cpp convert.cpp
-+id3v2: convert.o list.o id3v2.o
-+ g++ ${LDFLAGS} -lid3 -lz -lgnugetopt -o $@ convert.o list.o id3v2.o
-
- install: all
+- g++ -lz -lid3 -g -o id3v2 id3v2.cpp list.cpp convert.cpp
+-
+-install: all
- cp id3v2 /usr/local/bin/
-+ install -c -s id3v2 ${PREFIX}/bin/id3v2
-+ nroff -man id3v2.1 > ${PREFIX}/man/man1/id3v2.1
+-
+-clean:
+- rm -f id3v2 core
++.include <bsd.prog.mk>
diff --git a/audio/id3v2/files/patch-ab b/audio/id3v2/files/patch-ab
deleted file mode 100644
index ac1941e3ffa9..000000000000
--- a/audio/id3v2/files/patch-ab
+++ /dev/null
@@ -1,74 +0,0 @@
---- convert.cpp~ Fri Apr 7 14:11:22 2000
-+++ convert.cpp Wed Oct 10 15:50:16 2001
-@@ -14,22 +14,22 @@
- cout << argv[nIndex] << "\"...";
-
- myTag.Clear();
-- myTag.Link(argv[nIndex]);
-+ myTag.Link(argv[nIndex], ID3TT_ALL);
-
- luint nTags;
- switch(whichTags)
- {
- case 1:
-- nTags = myTag.Strip(V1_TAG);
-+ nTags = myTag.Strip(ID3TT_ID3V1);
- cout << "id3v1 ";
- break;
- case 2:
-- nTags = myTag.Strip(V2_TAG);
-+ nTags = myTag.Strip(ID3TT_ID3V2);
- cout << "id3v2 ";
- break;
- case 0:
- default:
-- nTags = myTag.Strip(BOTH_ID3_TAGS);
-+ nTags = myTag.Strip(ID3TT_ID3);
- cout << "id3v1 and v2 ";
- }
-
-@@ -61,11 +61,11 @@
- cout << argv[nIndex] << "...";
-
- myTag.Clear();
-- myTag.Link(argv[nIndex]);
-+ myTag.Link(argv[nIndex], ID3TT_ALL);
-
- luint nTags;
-
-- nTags = myTag.Update(V2_TAG);
-+ nTags = myTag.Update(ID3TT_ID3V2);
- cout << " converted ";
- cout << endl;
- }
---- id3v2.cpp~ Sat Apr 22 13:46:44 2000
-+++ id3v2.cpp Wed Oct 10 15:52:09 2001
-@@ -291,7 +291,7 @@
- // cout << "Tagging " << argv[nIndex] << ": ";
-
- // fix me - not checking to see if we can link to it
-- myTag.Link(argv[nIndex], false, false);
-+ myTag.Link(argv[nIndex], ID3TT_ID3V2);
-
- // loop thru the frames we need to add/modify
- for(ii = 0; ii < frameCounter; ii++)
-@@ -557,7 +557,7 @@
- }
- } // steping thru frames
-
-- luint nTags = myTag.Update(V2_TAG);
-+ luint nTags = myTag.Update(ID3TT_ID3V2);
-
- }
- catch(ID3_Error err)
---- list.cpp~ Sat Apr 22 13:47:43 2000
-+++ list.cpp Wed Oct 10 15:52:37 2001
-@@ -353,7 +353,7 @@
-
- if(!PrintID3v1Tag(argv[nIndex]))
- tags = true;
-- myTag.Link(argv[nIndex], false, false);
-+ myTag.Link(argv[nIndex], ID3TT_ID3V2);
- if(!PrintInformation(argv[nIndex],myTag))
- tags = true;
- if(!tags)
diff --git a/audio/id3v2/files/patch-ac b/audio/id3v2/files/patch-ac
deleted file mode 100644
index eaf32ce76626..000000000000
--- a/audio/id3v2/files/patch-ac
+++ /dev/null
@@ -1,77 +0,0 @@
---- /dev/null Wed Oct 10 15:39:32 2001
-+++ id3v2.1 Mon Dec 11 00:53:03 2000
-@@ -0,0 +1,74 @@
-+.TH ID3V2 1 "May 2000" "" "User Command"
-+.SH NAME
-+id3v2 \- Adds/Modifies/Removes/Views id3v2 tags, converts/lists id3v1 tags
-+.SH SYNOPSIS
-+.B id3v2
-+.RB [
-+.I OPTION
-+.RB ]
-+...
-+.RB [
-+.I FILE
-+.RB ]
-+...
-+.br
-+.SH OPTIONS
-+.TP
-+.B \-h, \-\-help
-+Display help and exit
-+.TP
-+.B \-f, \-\-list\-frames
-+Display all possible frames for id3v2
-+.TP
-+.B \-L, \-\-list\-genres
-+Lists all id3v1 genres
-+.TP
-+.B \-v, \-\-version
-+Display version information and exit
-+.TP
-+.B \-l, \-\-list
-+Lists the tag(s) on the file(s)
-+.TP
-+.B \-R, \-\-list-rfc822
-+Lists using an rfc822\-style format for output
-+.TP
-+.B \-d, \-\-delete\-v2
-+Deletes id3v2 tags
-+.TP
-+.B \-s, \-\-delete\-v1
-+Deletes id3v1 tags
-+.TP
-+.B \-D, \-\-delete\-all
-+ Deletes both id3v1 and id3v2 tags
-+.TP
-+.B \-C, \-\-convert
-+ Converts id3v1 tag to id3v2
-+.TP
-+.B \-a, \-\-artist ARTIST
-+Set the artist information
-+.TP
-+.B \-A, \-\-album ALBUM
-+Set the album title information
-+.TP
-+.B \-t, \-\-song SONG
-+Set the song title information
-+.TP
-+.B \-c, \-\-comment DESCRIPTION:COMMENT
-+Set the comment information
-+.TP
-+.B \-g, \-\-genre num
-+Set the genre number
-+.TP
-+.B \-y, \-\-year num
-+Set the year
-+.TP
-+.B \-T, \-\-track num/num
-+Set the track number/(optional) total tracks
-+
-+.SH SEE ALSO
-+id3tag(1), id3info(1), id3convert(1)
-+.SH AUTHOR
-+.B id3v2
-+is by myers <icepick@users.sourceforge.net> with major portions used from id3lib
-+examples. Manual page written for Debian GNU/Linux by Robert Woodcock
-+<rcw@debian.org>.