aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-04-26 20:12:27 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-04-26 20:12:27 +0000
commit46f4143759bb77d7bc1991ff8a2210d883c121ca (patch)
tree5a03487c336011b33ce2e5e58c66c15c1291268c /audio
parentcb3864f6b7691b492e220fde1960adce237117e4 (diff)
downloadports-46f4143759bb77d7bc1991ff8a2210d883c121ca.tar.gz
ports-46f4143759bb77d7bc1991ff8a2210d883c121ca.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/linux-f10-pulseaudio-libs/Makefile38
-rw-r--r--audio/linux-f10-pulseaudio-libs/distinfo.i3864
-rw-r--r--audio/linux-f10-pulseaudio-libs/files/patch-etc_pulse_client.conf-dist16
-rw-r--r--audio/linux-f10-pulseaudio-libs/pkg-descr4
-rw-r--r--audio/linux-f10-pulseaudio-libs/pkg-plist17
6 files changed, 80 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index ef43d9aae888..86d5537194ad 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -422,6 +422,7 @@
SUBDIR += linux-f10-nas-libs
SUBDIR += linux-f10-openal
SUBDIR += linux-f10-openal-soft
+ SUBDIR += linux-f10-pulseaudio-libs
SUBDIR += linux-f10-sdl_mixer
SUBDIR += linux-fmodapi
SUBDIR += linux-freealut
diff --git a/audio/linux-f10-pulseaudio-libs/Makefile b/audio/linux-f10-pulseaudio-libs/Makefile
new file mode 100644
index 000000000000..d16d0951d180
--- /dev/null
+++ b/audio/linux-f10-pulseaudio-libs/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: audio/linux-f10-pulseaudio-libs
+# Date created: 2011-04-01
+# Whom: avg
+#
+# $FreeBSD$
+#
+
+PORTNAME= pulseaudio-libs
+PORTVERSION= 0.9.14
+CATEGORIES= audio linux
+MASTER_SITES= LOCAL
+MASTER_SITE_SUBDIR= netchild/rpms/${LINUX_DIST}${LINUX_DIST_VER}
+PKGNAMEPREFIX= linux-f10-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Libraries for PulseAudio clients
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 10
+RPMVERSION= 4.fc10
+SRC_DISTFILES= ${PORTNAME:S/-libs//}-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}
+USE_LDCONFIG= yes
+
+CONF_FILE= etc/pulse/client.conf
+
+pre-patch:
+ @${MV} ${WRKSRC}/${CONF_FILE} ${WRKSRC}/${CONF_FILE}-dist
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.orig" -delete
+
+post-install:
+ @if [ ! -f ${PREFIX}/${CONF_FILE} ]; then \
+ ${CP} -p ${PREFIX}/${CONF_FILE}-dist ${PREFIX}/${CONF_FILE} ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/audio/linux-f10-pulseaudio-libs/distinfo.i386 b/audio/linux-f10-pulseaudio-libs/distinfo.i386
new file mode 100644
index 000000000000..b4dc1d69fafd
--- /dev/null
+++ b/audio/linux-f10-pulseaudio-libs/distinfo.i386
@@ -0,0 +1,4 @@
+SHA256 (rpm/i386/fedora/10/pulseaudio-libs-0.9.14-4.fc10.i386.rpm) = 2dd70441ff6d8a2525244392fb347697235d316a1b3aa69a6405e2df142a0e36
+SIZE (rpm/i386/fedora/10/pulseaudio-libs-0.9.14-4.fc10.i386.rpm) = 207583
+SHA256 (rpm/i386/fedora/10/pulseaudio-0.9.14-4.fc10.src.rpm) = d602962d4e17406f9e17f5f6a50f5271aac8ebff9a65093bf88baf995c6505d5
+SIZE (rpm/i386/fedora/10/pulseaudio-0.9.14-4.fc10.src.rpm) = 1319713
diff --git a/audio/linux-f10-pulseaudio-libs/files/patch-etc_pulse_client.conf-dist b/audio/linux-f10-pulseaudio-libs/files/patch-etc_pulse_client.conf-dist
new file mode 100644
index 000000000000..1ac209b0fa49
--- /dev/null
+++ b/audio/linux-f10-pulseaudio-libs/files/patch-etc_pulse_client.conf-dist
@@ -0,0 +1,16 @@
+--- etc/pulse/client.conf-dist.orig 2011-04-01 15:42:58.548733177 +0300
++++ etc/pulse/client.conf-dist 2011-04-01 15:53:03.306719164 +0300
+@@ -23,11 +23,11 @@
+ ; default-source =
+ ; default-server =
+
+-; autospawn = yes
++autospawn = no
+ ; daemon-binary = /usr/bin/pulseaudio
+ ; extra-arguments = --log-target=syslog
+
+ ; cookie-file =
+
+-; disable-shm = no
++disable-shm = yes
+ ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
diff --git a/audio/linux-f10-pulseaudio-libs/pkg-descr b/audio/linux-f10-pulseaudio-libs/pkg-descr
new file mode 100644
index 000000000000..b64586eebb91
--- /dev/null
+++ b/audio/linux-f10-pulseaudio-libs/pkg-descr
@@ -0,0 +1,4 @@
+This package contains the runtime libraries for any application that wishes
+to interface with a PulseAudio sound server.
+
+WWW: http://www.pulseaudio.org/
diff --git a/audio/linux-f10-pulseaudio-libs/pkg-plist b/audio/linux-f10-pulseaudio-libs/pkg-plist
new file mode 100644
index 000000000000..1c2943b720fa
--- /dev/null
+++ b/audio/linux-f10-pulseaudio-libs/pkg-plist
@@ -0,0 +1,17 @@
+@unexec if cmp -s %D/etc/pulse/client.conf-dist %D/etc/pulse/client.conf; then rm -f %D/etc/pulse/client.conf; fi
+etc/pulse/client.conf-dist
+@exec if [ ! -f %D/etc/pulse/client.conf ] ; then cp -p %D/%F %B/client.conf; fi
+usr/lib/libpulse-simple.so.0
+usr/lib/libpulse-simple.so.0.0.2
+usr/lib/libpulse.so.0
+usr/lib/libpulse.so.0.7.1
+usr/share/doc/pulseaudio-libs-0.9.14/GPL
+usr/share/doc/pulseaudio-libs-0.9.14/LGPL
+usr/share/doc/pulseaudio-libs-0.9.14/LICENSE
+usr/share/doc/pulseaudio-libs-0.9.14/README
+usr/share/locale/de/LC_MESSAGES/pulseaudio.mo
+usr/share/locale/el/LC_MESSAGES/pulseaudio.mo
+usr/share/locale/fr/LC_MESSAGES/pulseaudio.mo
+usr/share/locale/sv/LC_MESSAGES/pulseaudio.mo
+@dirrm usr/share/doc/pulseaudio-libs-0.9.14
+@dirrmtry etc/pulse