aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
commit534fffca27bb18f7529d548c46ee3326505a89c7 (patch)
treea09ac440edd299d85a3517dea62caa2b115543fc /audio
parent5bc499ce47fa1a8da853b36cc61cddf06075d203 (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/snack/Makefile3
-rw-r--r--audio/xmpeg3/Makefile4
2 files changed, 5 insertions, 2 deletions
diff --git a/audio/snack/Makefile b/audio/snack/Makefile
index ebad85621883..4a6142bd077a 100644
--- a/audio/snack/Makefile
+++ b/audio/snack/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.3 \
--with-tk=${LOCALBASE}/lib/tk8.3 \
@@ -43,7 +44,7 @@ pre-everything:
.endif
post-patch:
- @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile.in
.if !defined(NOPORTDOCS)
post-install:
diff --git a/audio/xmpeg3/Makefile b/audio/xmpeg3/Makefile
index dc2f29ba3e2a..09168e28322a 100644
--- a/audio/xmpeg3/Makefile
+++ b/audio/xmpeg3/Makefile
@@ -17,11 +17,13 @@ MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= amp:${PORTSDIR}/audio/amp \
wish8.2:${PORTSDIR}/x11-toolkits/tk82
+USE_REINPLACE= yes
+
WRKSRC= ${WRKDIR}/xmpeg3
NO_BUILD= yes
post-patch:
- @/usr/bin/perl -pi -e "s|\@\@PREFIX\@\@|${PREFIX}|;" ${WRKSRC}/xmpeg3
+ @${REINPLACE_CMD} -e 's|@@PREFIX@@|${PREFIX}|' ${WRKSRC}/xmpeg3
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/xmpeg3 ${PREFIX}/bin