aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-01-28 06:00:34 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-01-28 06:00:34 +0000
commit5365f1dbc729c23641bbe25a6193fc887baced22 (patch)
treefa839972043d9dd64b0f0e149104cad7ee18ea05 /audio
parent8c24200a6e8d6cf6aeb6f512329fbe132c17fbbd (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/gnump3d/Makefile4
-rw-r--r--audio/gnump3d/files/patch-aclocal.m410
-rw-r--r--audio/gnump3d/files/patch-config::ltmain.sh13
3 files changed, 13 insertions, 14 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
index 20ab6940c4ee..e9ff973c9057 100644
--- a/audio/gnump3d/Makefile
+++ b/audio/gnump3d/Makefile
@@ -20,7 +20,9 @@ USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 253
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= # none
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CONFIG_SHELL="${SH}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/audio/gnump3d/files/patch-aclocal.m4 b/audio/gnump3d/files/patch-aclocal.m4
new file mode 100644
index 000000000000..821999cc6fea
--- /dev/null
+++ b/audio/gnump3d/files/patch-aclocal.m4
@@ -0,0 +1,10 @@
+--- aclocal.m4.orig Mon Jan 27 21:52:25 2003
++++ aclocal.m4 Mon Jan 27 21:52:56 2003
+@@ -164,6 +164,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/gnump3d/files/patch-config::ltmain.sh b/audio/gnump3d/files/patch-config::ltmain.sh
deleted file mode 100644
index de649ecde73f..000000000000
--- a/audio/gnump3d/files/patch-config::ltmain.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- config/ltmain.sh.orig Sun Jul 14 01:53:50 2002
-+++ config/ltmain.sh Tue Aug 13 18:00:19 2002
-@@ -967,6 +967,7 @@
- ;;
-
- -avoid-version)
-+ build_old_libs=no
- avoid_version=yes
- continue
- ;;