aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2013-03-29 21:37:06 +0000
committerAlberto Villa <avilla@FreeBSD.org>2013-03-29 21:37:06 +0000
commit641f2150c31b6a859f9e3f500db8cf46f88dcef2 (patch)
treee7b53873efea806054d3721c200ae89f4abf58e0 /audio
parentf3d86acca567a437be1a4ee90bc1ce1e3a213326 (diff)
downloadports-641f2150c31b6a859f9e3f500db8cf46f88dcef2.tar.gz
ports-641f2150c31b6a859f9e3f500db8cf46f88dcef2.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/amarok-kde4/Makefile9
-rw-r--r--audio/amarok-kde4/pkg-plist18
2 files changed, 20 insertions, 7 deletions
diff --git a/audio/amarok-kde4/Makefile b/audio/amarok-kde4/Makefile
index bb09867883ef..b519305c11b0 100644
--- a/audio/amarok-kde4/Makefile
+++ b/audio/amarok-kde4/Makefile
@@ -13,20 +13,20 @@ COMMENT= KDE music player
LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib \
tag-extras:${PORTSDIR}/audio/taglib-extras \
+ lastfm:${PORTSDIR}/audio/liblastfm \
ofa:${PORTSDIR}/audio/libofa \
avcodec:${PORTSDIR}/multimedia/ffmpeg \
qjson:${PORTSDIR}/devel/qjson \
qca:${PORTSDIR}/devel/qca \
- dbus-1:${PORTSDIR}/devel/dbus \
- nepomukcore:${PORTSDIR}/sysutils/nepomuk-core
+ dbus-1:${PORTSDIR}/devel/dbus
BUILD_DEPENDS= ${LOCALBASE}/lib/qt4/plugins/script/libqtscript_core.so.1.0.0:${PORTSDIR}/devel/qtscriptgenerator
RUN_DEPENDS= ${LOCALBASE}/lib/qt4/plugins/script/libqtscript_core.so.1.0.0:${PORTSDIR}/devel/qtscriptgenerator \
${KDE4_PREFIX}/lib/kde4/kio_upnp_ms.so:${PORTSDIR}/net/kio-upnp-ms
LATEST_LINK= ${PORTNAME}-kde4
-USE_KDE4= kdehier kdelibs kdeprefix libkcddb \
- libkcompactdisc runtime automoc4 sharedmime strigi
+USE_KDE4= kdehier kdelibs kdeprefix libkcddb libkcompactdisc \
+ nepomuk-core runtime automoc4 sharedmime strigi
USE_MYSQL= embedded
USE_QT4= dbus designer gui network opengl \
phonon script sql svg webkit xml \
@@ -103,6 +103,5 @@ post-install:
${PREFIX}/share/mime/packages
${INSTALL_SCRIPT} ${WRKSRC}/utilities/amzdownloader/amzdownloader.desktop \
${PREFIX}/share/applications/kde4
- @-update-mime-database ${PREFIX}/share/mime
.include <bsd.port.mk>
diff --git a/audio/amarok-kde4/pkg-plist b/audio/amarok-kde4/pkg-plist
index 350db09a68fe..ceba20cee4a9 100644
--- a/audio/amarok-kde4/pkg-plist
+++ b/audio/amarok-kde4/pkg-plist
@@ -22,24 +22,30 @@ lib/kde4/amarok_context_applet_info.so
lib/kde4/amarok_context_applet_labels.so
lib/kde4/amarok_context_applet_lyrics.so
lib/kde4/amarok_context_applet_photos.so
+lib/kde4/amarok_context_applet_similarArtists.so
lib/kde4/amarok_context_applet_tabs.so
+lib/kde4/amarok_context_applet_upcomingEvents.so
lib/kde4/amarok_context_applet_wikipedia.so
lib/kde4/amarok_data_engine_current.so
lib/kde4/amarok_data_engine_info.so
lib/kde4/amarok_data_engine_labels.so
lib/kde4/amarok_data_engine_lyrics.so
lib/kde4/amarok_data_engine_photos.so
+lib/kde4/amarok_data_engine_similarArtists.so
lib/kde4/amarok_data_engine_tabs.so
+lib/kde4/amarok_data_engine_upcomingEvents.so
lib/kde4/amarok_data_engine_wikipedia.so
lib/kde4/amarok_runnerscript_javascript.so
lib/kde4/amarok_service_amazonstore.so
lib/kde4/amarok_service_ampache.so
lib/kde4/amarok_service_jamendo.so
+lib/kde4/amarok_service_lastfm.so
lib/kde4/amarok_service_magnatunestore.so
%%MP3TUNES%%lib/kde4/amarok_service_mp3tunes.so
lib/kde4/amarok_service_opmldirectory.so
lib/kde4/kcm_amarok_service_amazonstore.so
lib/kde4/kcm_amarok_service_ampache.so
+lib/kde4/kcm_amarok_service_lastfm.so
lib/kde4/kcm_amarok_service_magnatunestore.so
%%MP3TUNES%%lib/kde4/kcm_amarok_service_mp3tunes.so
lib/libamarok-sqlcollection.so
@@ -48,6 +54,7 @@ lib/libamarok-sqlcollection.so.1.0.0
lib/libamarok-transcoding.so
lib/libamarok-transcoding.so.1
lib/libamarok-transcoding.so.1.0.0
+lib/libamarok_service_lastfm_shared.so
lib/libamarokcore.so
lib/libamarokcore.so.1
lib/libamarokcore.so.1.0.0
@@ -74,6 +81,7 @@ share/apps/amarok/data/first_run_jingle.ogg
share/apps/amarok/data/hover_info_template.html
share/apps/amarok/data/info_frontpage.html
share/apps/amarok/data/podcast_directory.opml
+share/apps/amarok/data/upcoming-events-map.html
share/apps/amarok/icons/hicolor/128x128/status/audio-volume-high-amarok.png
share/apps/amarok/icons/hicolor/128x128/status/audio-volume-low-amarok.png
share/apps/amarok/icons/hicolor/128x128/status/audio-volume-medium-amarok.png
@@ -401,6 +409,7 @@ share/apps/amarok/images/hover_info_dynamic_playlists.png
share/apps/amarok/images/hover_info_files.png
share/apps/amarok/images/hover_info_internet.png
share/apps/amarok/images/hover_info_jamendo.png
+share/apps/amarok/images/hover_info_lastfm.png
share/apps/amarok/images/hover_info_magnatune.png
share/apps/amarok/images/hover_info_playlists.png
share/apps/amarok/images/hover_info_podcasts.png
@@ -1074,14 +1083,18 @@ share/kde4/services/amarok-context-applet-info.desktop
share/kde4/services/amarok-context-applet-labels.desktop
share/kde4/services/amarok-context-applet-lyrics.desktop
share/kde4/services/amarok-context-applet-photos.desktop
+share/kde4/services/amarok-context-applet-similarArtists.desktop
share/kde4/services/amarok-context-applet-tabs.desktop
+share/kde4/services/amarok-context-applet-upcomingEvents.desktop
share/kde4/services/amarok-context-applet-wikipedia.desktop
share/kde4/services/amarok-data-engine-current.desktop
share/kde4/services/amarok-data-engine-info.desktop
share/kde4/services/amarok-data-engine-labels.desktop
share/kde4/services/amarok-data-engine-lyrics.desktop
share/kde4/services/amarok-data-engine-photos.desktop
+share/kde4/services/amarok-data-engine-similarArtists.desktop
share/kde4/services/amarok-data-engine-tabs.desktop
+share/kde4/services/amarok-data-engine-upcomingEvents.desktop
share/kde4/services/amarok-data-engine-wikipedia.desktop
share/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
share/kde4/services/amarok-scriptengine-runner-javascript.desktop
@@ -1101,12 +1114,15 @@ share/kde4/services/amarok_service_amazonstore_config.desktop
share/kde4/services/amarok_service_ampache.desktop
share/kde4/services/amarok_service_ampache_config.desktop
share/kde4/services/amarok_service_jamendo.desktop
+share/kde4/services/amarok_service_lastfm.desktop
+share/kde4/services/amarok_service_lastfm_config.desktop
share/kde4/services/amarok_service_magnatunestore.desktop
share/kde4/services/amarok_service_magnatunestore_config.desktop
%%MP3TUNES%%share/kde4/services/amarok_service_mp3tunes.desktop
%%MP3TUNES%%share/kde4/services/amarok_service_mp3tunes_config.desktop
share/kde4/services/amarok_service_opmldirectory.desktop
share/kde4/services/amarokitpc.protocol
+share/kde4/services/amaroklastfm.protocol
share/kde4/servicetypes/amarok_codecinstall.desktop
share/kde4/servicetypes/amarok_context_applet.desktop
share/kde4/servicetypes/amarok_data_engine.desktop
@@ -1288,5 +1304,3 @@ share/mime/packages/amzdownloader.xml
@dirrm share/apps/amarok/icons
@dirrm share/apps/amarok/data
@dirrm share/apps/amarok
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true