aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-11-22 20:11:52 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-11-22 20:11:52 +0000
commit89aaeef92e341636629440e365ad6770e8d810c5 (patch)
tree326b51ca69334cce5092ec6da3a040e742ee9ace /audio
parentd29b356b639f777945beca81bea6a1591f4b7fe5 (diff)
downloadports-89aaeef92e341636629440e365ad6770e8d810c5.tar.gz
ports-89aaeef92e341636629440e365ad6770e8d810c5.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity/Makefile66
-rw-r--r--audio/audacity/distinfo4
-rw-r--r--audio/audacity/files/patch-Makefile.in11
-rw-r--r--audio/audacity/files/patch-cext.h12
-rw-r--r--audio/audacity/files/patch-lib-src__libmad__configure20
-rw-r--r--audio/audacity/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h4
-rw-r--r--audio/audacity/files/patch-lib-src__libsoxr__configure9
-rw-r--r--audio/audacity/files/patch-lib-src__lv2__Makefile10
-rw-r--r--audio/audacity/files/patch-lib-src__soundtouch__source__SoundTouch__Makefile.am11
-rw-r--r--audio/audacity/files/patch-lib-src__soundtouch__source__SoundTouch__Makefile.in11
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h11
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h (renamed from audio/audacity/files/patch-xlisp.h)8
-rw-r--r--audio/audacity/files/patch-lib-src_portmixer_include_portmixer.h11
-rw-r--r--audio/audacity/files/patch-portaudio.h48
-rw-r--r--audio/audacity/files/patch-src_AudioIO.h11
-rw-r--r--audio/audacity/files/patch-src_DeviceManager.cpp11
-rw-r--r--audio/audacity/files/patch-src_FFmpeg.h8
-rw-r--r--audio/audacity/files/patch-src__Makefile.in4
-rw-r--r--audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp6
-rw-r--r--audio/audacity/files/patch-src_prefs_DevicePrefs.cpp11
-rw-r--r--audio/audacity/pkg-message3
-rw-r--r--audio/audacity/pkg-plist118
22 files changed, 232 insertions, 176 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 86e715236e40..ef46616cade7 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 2.1.0
-PORTREVISION= 5
+PORTVERSION= 2.1.1
CATEGORIES= audio
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
-DISTNAME= ${PORTNAME}-minsrc-${PORTVERSION}
+MASTER_SITES= https://github.com/audacity/audacity/archive/
+DISTNAME= Audacity-${PORTVERSION}
MAINTAINER= xxjack12xx@gmail.com
COMMENT= GUI editor for digital audio waveforms
@@ -16,23 +15,28 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
-WRKSRC= ${WRKDIR}/${PORTNAME}-minsrc-${PORTVERSION}
+BUILD_DEPENDS+= autogen:${PORTSDIR}/devel/autogen \
+ bash:${PORTSDIR}/shells/bash \
+ cmake:${PORTSDIR}/devel/cmake
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-Audacity-${PORTVERSION}
GNU_CONFIGURE= yes
-USES= cpe desktop-file-utils gettext gmake pkgconfig shared-mime-info \
- tar:xz
+USES= compiler:c11 cpe desktop-file-utils gmake pkgconfig shared-mime-info shebangfix dos2unix
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+OPTIONS_SUB= yes
USE_WX= 2.8+
-WX_UNICODE= yes
WX_COMPS= wx
INSTALLS_ICONS= yes
PORTDOCS= README.txt
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= NLS DEBUG DOCS FLAC ID3TAG LADSPA LAME MAD MIDI \
+ SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
+OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD MIDI \
+ SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
-OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME MAD MIDI NYQUIST \
- PORTMIXER SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
-OPTIONS_SINGLE= SAMPLERATED
-OPTIONS_SINGLE_SAMPLERATED= SAMPLERATE #SOXR
-OPTIONS_DEFAULT= FFMPEG FLAC ID3TAG LADSPA MAD MIDI NYQUIST \
- PORTMIXER SBSMS SOUNDTOUCH SAMPLERATE TWOLAME VAMP VORBIS VST
OPTIONS_DEFINE_amd64= SSE
OPTIONS_DEFINE_i386= SSE
OPTIONS_DEFAULT_amd64= SSE
@@ -42,13 +46,8 @@ DEBUG_DESC= Enable debug support
LAME_DESC= Use lame for import and export support
MAD_DESC= Use libmad for mp2/3 decoding support
MIDI_DESC= Use portSMF for Midi support
-NYQUIST_DESC= Nyquist plug-in support
-SAMPLERATE_DESC= Use libsamplerate for sample rate conversion
-SAMPLERATED_DESC= Default sample rate conversion support
-PORTMIXER_DESC= Compile with PortMixer support
SBSMS_DESC= Use libsbsms for pitch and tempo changing
SOUNDTOUCH_DESC= Use libSoundTouch for pitch and tempo changing
-#SOXR_DESC= Use libsoxr for sample rate conversion
TAGLIB_DESC= Use TagLib for metadata support
TWOLAME_DESC= Use libtwolame for MP2 export support
VAMP_DESC= Vamp plug-in support
@@ -56,17 +55,12 @@ VST_DESC= VST plug-in support
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
-CONFIGURE_ARGS+= --with-lib-preference="local system" \
- --enable-portaudio --enable-unicode
+CONFIGURE_ARGS+= --with-lib-preference="local system" --without-lv2 --without-ffmpeg \
+ --enable-portaudio --enable-unicode --with-libsoxr
-DEBUG_CONFIGURE_WITH= debug
+CONFIGURE_SHELL?=${LOCALBASE}/bin/bash
-FFMPEG_CONFIGURE_WITH= ffmpeg
-FFMPEG_RUN_DEPENDS= ${LOCALBASE}/bin/ffmpeg:${PORTSDIR}/multimedia/ffmpeg
-FFMPEG_LIB_DEPENDS= libavformat.so:${PORTSDIR}/multimedia/ffmpeg
-FFMPEG_CFLAGS= -I${LOCALBASE}/include/ffmpeg
-FFMPEG_CPPFLAGS= -I${LOCALBASE}/include/ffmpeg
-FFMPEG_CXXFLAGS= -I${LOCALBASE}/include/ffmpeg
+DEBUG_CONFIGURE_WITH= debug
FLAC_CONFIGURE_WITH= libflac
FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
@@ -87,21 +81,11 @@ MIDI_CONFIGURE_WITH= midi
LAME_CONFIGURE_WITH= lame
LAME_LIB_DEPENDS= libmp3lame.so:${PORTSDIR}/audio/lame
-NYQUIST_CONFIGURE_ENABLE= nyquist
-
-PORTMIXER_CONFIGURE_WITH= portmixer
-
-SAMPLERATE_CONFIGURE_WITH= libsamplerate
-SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
-
SBSMS_CONFIGURE_WITH= sbsms
SOUNDTOUCH_CONFIGURE_WITH= soundtouch
SOUNDTOUCH_LIB_DEPENDS= libSoundTouch.so:${PORTSDIR}/audio/soundtouch
-#SOXR_CONFIGURE_WITH= libsoxr
-#SOXR_BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
-
SSE_CONFIGURE_ENABLE= sse
TWOLAME_CONFIGURE_WITH= libtwolame
@@ -121,12 +105,6 @@ CFLAGS+= -I${WRKSRC}/lib-src/portsmf \
-I${WRKSRC}/lib-src/portaudio-v19/include \
-I${WRKSRC}/lib-src/lame -I${LOCALBASE}/include
-post-patch:
- @${REINPLACE_CMD} -e 's|inline void|static inline void|' ${WRKSRC}/lib-src/libnyquist/nyquist/ffts/src/fftlib.c
-
-post-patch-PORTMIXER-off:
- @${REINPLACE_CMD} -e 's/ portmixer / /' ${WRKSRC}/lib-src/Makefile.in
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index d34445b725c9..f39a73e74c86 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,2 +1,2 @@
-SHA256 (audacity-minsrc-2.1.0.tar.xz) = b0d98d89b38be233e88af81e1add649732484b6f8feec95dc5977accdde042b3
-SIZE (audacity-minsrc-2.1.0.tar.xz) = 5104924
+SHA256 (Audacity-2.1.1.tar.gz) = 15c5ff7ac1c0b19b08f4bdcb0f4988743da2f9ed3fab41d6f07600e67cb9ddb6
+SIZE (Audacity-2.1.1.tar.gz) = 24327048
diff --git a/audio/audacity/files/patch-Makefile.in b/audio/audacity/files/patch-Makefile.in
new file mode 100644
index 000000000000..d2c09f0c9d81
--- /dev/null
+++ b/audio/audacity/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2015-11-05 07:57:02 UTC
++++ Makefile.in
+@@ -476,7 +476,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = help images lib-src po src tests
+ ACLOCAL_AMFLAGS = -I m4
+-bin_SCRIPTS = audacity$(EXEEXT)
++bin_PROGRAMS = audacity$(EXEEXT)
+ dist_doc_DATA = LICENSE.txt README.txt
+ dist_pkgdata_DATA = presets/EQDefaultCurves.xml
+ nobase_dist_pkgdata_DATA = \
diff --git a/audio/audacity/files/patch-cext.h b/audio/audacity/files/patch-cext.h
deleted file mode 100644
index 5ca84120ced0..000000000000
--- a/audio/audacity/files/patch-cext.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- lib-src/libnyquist/nyquist/cmt/cext.h 2009-07-15 20:27:36.000000000 -0700
-+++ lib-src/libnyquist/nyquist/cmt/cext.h 2009-07-19 00:37:45.000000000 -0700
-
-@@ -58,7 +58,7 @@
- #include <malloc.h>
- #endif
-
--#if NEED_ULONG
-+#if NEED_ULONG || __FreeBSD__
- typedef unsigned long ulong;
- #endif
-
diff --git a/audio/audacity/files/patch-lib-src__libmad__configure b/audio/audacity/files/patch-lib-src__libmad__configure
new file mode 100644
index 000000000000..b04b7ed8c130
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src__libmad__configure
@@ -0,0 +1,20 @@
+--- lib-src/libmad/configure.orig 2015-07-11 10:02:22 UTC
++++ lib-src/libmad/configure
+@@ -11983,17 +11983,12 @@ then
+ : #x optimize="$optimize -fforce-addr"
+ : #x optimize="$optimize -finline-functions"
+ : #- optimize="$optimize -fstrength-reduce"
+- optimize="$optimize -fthread-jumps"
+- optimize="$optimize -fcse-follow-jumps"
+- optimize="$optimize -fcse-skip-blocks"
+ : #x optimize="$optimize -frerun-cse-after-loop"
+ : #x optimize="$optimize -frerun-loop-opt"
+ : #x optimize="$optimize -fgcse"
+ optimize="$optimize -fexpensive-optimizations"
+- optimize="$optimize -fregmove"
+ : #* optimize="$optimize -fdelayed-branch"
+ : #x optimize="$optimize -fschedule-insns"
+- optimize="$optimize -fschedule-insns2"
+ : #? optimize="$optimize -ffunction-sections"
+ : #? optimize="$optimize -fcaller-saves"
+ : #> optimize="$optimize -funroll-loops"
diff --git a/audio/audacity/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h b/audio/audacity/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h
index 0e3b2e97887c..a706d562532e 100644
--- a/audio/audacity/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h
+++ b/audio/audacity/files/patch-lib-src__libnyquist__nyquist__nyqstk__include__FileRead.h
@@ -1,5 +1,5 @@
---- ./lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h.orig 2011-05-04 17:18:48.000000000 +0200
-+++ ./lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h 2011-05-04 17:19:13.000000000 +0200
+--- lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h.orig 2015-07-11 10:02:22 UTC
++++ lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h
@@ -33,6 +33,7 @@
#define STK_FILEREAD_H
diff --git a/audio/audacity/files/patch-lib-src__libsoxr__configure b/audio/audacity/files/patch-lib-src__libsoxr__configure
new file mode 100644
index 000000000000..a29d32c90305
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src__libsoxr__configure
@@ -0,0 +1,9 @@
+--- lib-src/libsoxr/configure.orig 2015-07-11 10:02:22 UTC
++++ lib-src/libsoxr/configure
+@@ -12,6 +12,5 @@
+
+ srcdir="$@"
+ srcdir="${srcdir#*--srcdir=}"
+-srcdir="./${srcdir/ */}"
+
+ cmake -DBUILD_SHARED_LIBS=OFF -DWITH_OPENMP=OFF "${srcdir}"
diff --git a/audio/audacity/files/patch-lib-src__lv2__Makefile b/audio/audacity/files/patch-lib-src__lv2__Makefile
new file mode 100644
index 000000000000..9bee8cb8c588
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src__lv2__Makefile
@@ -0,0 +1,10 @@
+--- lib-src/lv2/Makefile.orig 2015-07-11 10:02:22 UTC
++++ lib-src/lv2/Makefile
+@@ -1,7 +1,6 @@
+ include srcdir.mk
+
+ all:
+- ./build --srcdir=$(srcdir)
+
+ check:
+
diff --git a/audio/audacity/files/patch-lib-src__soundtouch__source__SoundTouch__Makefile.am b/audio/audacity/files/patch-lib-src__soundtouch__source__SoundTouch__Makefile.am
new file mode 100644
index 000000000000..c974f74c389c
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src__soundtouch__source__SoundTouch__Makefile.am
@@ -0,0 +1,11 @@
+--- lib-src/soundtouch/source/SoundTouch/Makefile.am.orig 2015-07-11 10:02:22 UTC
++++ lib-src/soundtouch/source/SoundTouch/Makefile.am
+@@ -32,7 +32,7 @@ libSoundTouch_la_SOURCES=AAFilter.cpp FI
+
+
+ # Compiler flags
+-AM_CXXFLAGS=-O3 -fcheck-new -I../../include
++AM_CXXFLAGS=-O3 -I../../include
+
+ # Compile the files that need MMX and SSE individually.
+ libSoundTouch_la_LIBADD=libSoundTouchMMX.la libSoundTouchSSE.la
diff --git a/audio/audacity/files/patch-lib-src__soundtouch__source__SoundTouch__Makefile.in b/audio/audacity/files/patch-lib-src__soundtouch__source__SoundTouch__Makefile.in
new file mode 100644
index 000000000000..1dbe35652c66
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src__soundtouch__source__SoundTouch__Makefile.in
@@ -0,0 +1,11 @@
+--- lib-src/soundtouch/source/SoundTouch/Makefile.in.orig 2015-07-11 10:02:22 UTC
++++ lib-src/soundtouch/source/SoundTouch/Makefile.in
+@@ -346,7 +346,7 @@ lib_LTLIBRARIES = libSoundTouch.la
+ libSoundTouch_la_SOURCES = AAFilter.cpp FIRFilter.cpp FIFOSampleBuffer.cpp RateTransposer.cpp SoundTouch.cpp TDStretch.cpp cpu_detect_x86.cpp BPMDetect.cpp PeakFinder.cpp
+
+ # Compiler flags
+-AM_CXXFLAGS = -O3 -fcheck-new -I../../include
++AM_CXXFLAGS = -O3 -I../../include
+
+ # Compile the files that need MMX and SSE individually.
+ libSoundTouch_la_LIBADD = libSoundTouchMMX.la libSoundTouchSSE.la
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
new file mode 100644
index 000000000000..9456e1a74263
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
@@ -0,0 +1,11 @@
+--- lib-src/libnyquist/nyquist/cmt/cext.h.orig 2015-07-11 10:02:22 UTC
++++ lib-src/libnyquist/nyquist/cmt/cext.h
+@@ -58,7 +58,7 @@ EXIT(n) -- calls exit(n) after shutting
+ #include <malloc.h>
+ #endif
+
+-#if NEED_ULONG
++#if NEED_ULONG || __FreeBSD__
+ typedef unsigned long ulong;
+ #endif
+
diff --git a/audio/audacity/files/patch-xlisp.h b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
index 5ab42206bdfd..50b6e3109398 100644
--- a/audio/audacity/files/patch-xlisp.h
+++ b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
@@ -1,9 +1,9 @@
---- lib-src/libnyquist/nyquist/xlisp/xlisp.h 2009-07-15 20:27:36.000000000 -0700
-+++ lib-src/libnyquist/nyquist/xlisp/xlisp.h 2009-07-19 00:24:11.000000000 -0700
-@@ -152,6 +152,15 @@
+--- lib-src/libnyquist/nyquist/xlisp/xlisp.h.orig 2015-07-11 10:02:22 UTC
++++ lib-src/libnyquist/nyquist/xlisp/xlisp.h
+@@ -153,6 +153,15 @@ extern long ptrtoabs();
#endif
#endif
-
+
+/* FreeBSD */
+#ifdef __FreeBSD__
+#if __BYTE_ORDER == __LITTLE_ENDIAN
diff --git a/audio/audacity/files/patch-lib-src_portmixer_include_portmixer.h b/audio/audacity/files/patch-lib-src_portmixer_include_portmixer.h
new file mode 100644
index 000000000000..cccb5444d099
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src_portmixer_include_portmixer.h
@@ -0,0 +1,11 @@
+--- lib-src/portmixer/include/portmixer.h.orig 2015-07-11 10:02:22 UTC
++++ lib-src/portmixer/include/portmixer.h
+@@ -45,7 +45,7 @@ extern "C"
+ *
+ */
+
+-#include "portaudio.h"
++#include "../../portaudio-v19/include/portaudio.h"
+
+ typedef void PxMixer;
+
diff --git a/audio/audacity/files/patch-portaudio.h b/audio/audacity/files/patch-portaudio.h
deleted file mode 100644
index 5300e62adcab..000000000000
--- a/audio/audacity/files/patch-portaudio.h
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -ur lib-src/portmixer/include/portmixer.h lib-src/portmixer/include/portmixer.h
---- lib-src/portmixer/include/portmixer.h 2014-09-22 13:38:13.000000000 -0700
-+++ lib-src/portmixer/include/portmixer.h 2014-10-01 19:49:06.000000000 -0700
-@@ -45,7 +45,7 @@
- *
- */
-
--#include "portaudio.h"
-+#include "../../portaudio-v19/include/portaudio.h"
-
- typedef void PxMixer;
-
-diff -ur src/AudioIO.h src/AudioIO.h
---- src/AudioIO.h 2014-09-22 13:38:13.000000000 -0700
-+++ src/AudioIO.h 2014-10-01 19:48:46.000000000 -0700
-@@ -13,7 +13,7 @@
- #ifndef __AUDACITY_AUDIO_IO__
- #define __AUDACITY_AUDIO_IO__
-
--#include "portaudio.h"
-+#include "../lib-src/portaudio-v19/include/portaudio.h"
- #include "Audacity.h"
- #include "Experimental.h"
-
-diff -ur src/DeviceManager.cpp src/DeviceManager.cpp
---- src/DeviceManager.cpp 2014-09-22 13:38:13.000000000 -0700
-+++ src/DeviceManager.cpp 2014-10-01 19:48:52.000000000 -0700
-@@ -6,7 +6,7 @@
-
- ******************************************************************/
-
--#include "portaudio.h"
-+#include "../lib-src/portaudio-v19/include/portaudio.h"
- #ifdef __WXMSW__
- #include "pa_win_wasapi.h"
- #endif
-diff -ur src/prefs/DevicePrefs.cpp src/prefs/DevicePrefs.cpp
---- src/prefs/DevicePrefs.cpp 2014-09-22 13:38:13.000000000 -0700
-+++ src/prefs/DevicePrefs.cpp 2014-10-01 19:48:39.000000000 -0700
-@@ -30,7 +30,7 @@
- #include <wx/intl.h>
- #include <wx/log.h>
-
--#include "portaudio.h"
-+#include "../../lib-src/portaudio-v19/include/portaudio.h"
-
- #include "../AudioIO.h"
- #include "../Internat.h"
diff --git a/audio/audacity/files/patch-src_AudioIO.h b/audio/audacity/files/patch-src_AudioIO.h
new file mode 100644
index 000000000000..ed42adc80636
--- /dev/null
+++ b/audio/audacity/files/patch-src_AudioIO.h
@@ -0,0 +1,11 @@
+--- src/AudioIO.h.orig 2015-07-11 10:02:22 UTC
++++ src/AudioIO.h
+@@ -13,7 +13,7 @@
+ #ifndef __AUDACITY_AUDIO_IO__
+ #define __AUDACITY_AUDIO_IO__
+
+-#include "portaudio.h"
++#include "../lib-src/portaudio-v19/include/portaudio.h"
+ #include "Audacity.h"
+ #include "Experimental.h"
+
diff --git a/audio/audacity/files/patch-src_DeviceManager.cpp b/audio/audacity/files/patch-src_DeviceManager.cpp
new file mode 100644
index 000000000000..dd5c7462bdc1
--- /dev/null
+++ b/audio/audacity/files/patch-src_DeviceManager.cpp
@@ -0,0 +1,11 @@
+--- src/DeviceManager.cpp.orig 2015-07-11 10:02:22 UTC
++++ src/DeviceManager.cpp
+@@ -6,7 +6,7 @@
+
+ ******************************************************************/
+
+-#include "portaudio.h"
++#include "../lib-src/portaudio-v19/include/portaudio.h"
+ #ifdef __WXMSW__
+ #include "pa_win_wasapi.h"
+ #endif
diff --git a/audio/audacity/files/patch-src_FFmpeg.h b/audio/audacity/files/patch-src_FFmpeg.h
index 4b9caeaa6355..88bc2afb320c 100644
--- a/audio/audacity/files/patch-src_FFmpeg.h
+++ b/audio/audacity/files/patch-src_FFmpeg.h
@@ -1,6 +1,6 @@
---- src/FFmpeg.h.orig 2015-03-02 01:06:57 UTC
+--- src/FFmpeg.h.orig 2015-07-11 10:02:22 UTC
+++ src/FFmpeg.h
-@@ -688,7 +688,7 @@ extern "C" {
+@@ -689,7 +689,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
AVOutputFormat*,
av_oformat_next,
@@ -9,7 +9,7 @@
(f)
);
FFMPEG_FUNCTION_WITH_RETURN(
-@@ -755,7 +755,7 @@ extern "C" {
+@@ -756,7 +756,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
int,
av_fifo_size,
@@ -18,7 +18,7 @@
(f)
);
FFMPEG_FUNCTION_WITH_RETURN(
-@@ -801,7 +801,7 @@ extern "C" {
+@@ -802,7 +802,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
AVDictionaryEntry *,
av_dict_get,
diff --git a/audio/audacity/files/patch-src__Makefile.in b/audio/audacity/files/patch-src__Makefile.in
index 6e817c83a4d9..a2bf193086e3 100644
--- a/audio/audacity/files/patch-src__Makefile.in
+++ b/audio/audacity/files/patch-src__Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2014-09-22 20:38:13 UTC
+--- src/Makefile.in.orig 2015-07-11 10:02:22 UTC
+++ src/Makefile.in
-@@ -1055,8 +1055,7 @@
+@@ -1118,8 +1118,7 @@ audacity_CPPFLAGS = -D__STDC_CONSTANT_MA
# /usr/local/include/wx-2.8/wx/buffer.h:289:9: note: in expansion of macro 'wxCHECK_RET'
# wxCHECK_RET( m_bufdata->m_data, wxT("invalid wxMemoryBuffer") );
# ^
diff --git a/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp b/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp
index 26363d9d4077..8968344cf839 100644
--- a/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp
+++ b/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp
@@ -1,6 +1,6 @@
---- src/effects/VST/VSTEffect.cpp 2015-03-31 23:03:30.000000000 -0700
-+++ src/effects/VST/VSTEffect.cpp 2015-03-01 17:06:58.000000000 -0800
-@@ -2609,7 +2609,7 @@
+--- src/effects/VST/VSTEffect.cpp.orig 2015-07-11 10:02:22 UTC
++++ src/effects/VST/VSTEffect.cpp
+@@ -2576,7 +2576,7 @@ bool VSTEffect::Load()
// symbols.
//
// Once we define a proper external API, the flags can be removed.
diff --git a/audio/audacity/files/patch-src_prefs_DevicePrefs.cpp b/audio/audacity/files/patch-src_prefs_DevicePrefs.cpp
new file mode 100644
index 000000000000..261245610b7d
--- /dev/null
+++ b/audio/audacity/files/patch-src_prefs_DevicePrefs.cpp
@@ -0,0 +1,11 @@
+--- src/prefs/DevicePrefs.cpp.orig 2015-07-11 10:02:22 UTC
++++ src/prefs/DevicePrefs.cpp
+@@ -30,7 +30,7 @@ other settings.
+ #include <wx/intl.h>
+ #include <wx/log.h>
+
+-#include "portaudio.h"
++#include "../../lib-src/portaudio-v19/include/portaudio.h"
+
+ #include "../AudioIO.h"
+ #include "../Internat.h"
diff --git a/audio/audacity/pkg-message b/audio/audacity/pkg-message
new file mode 100644
index 000000000000..1435bccbcfad
--- /dev/null
+++ b/audio/audacity/pkg-message
@@ -0,0 +1,3 @@
+Starting with 2.1, Audacity's settings file format is not 100% compatible
+with previous versions. If Audacity fails to start up, the affected users
+can resolve the issue by removing the ~/.audacity-data directory.
diff --git a/audio/audacity/pkg-plist b/audio/audacity/pkg-plist
index ba760273f5b5..ead186832ef2 100644
--- a/audio/audacity/pkg-plist
+++ b/audio/audacity/pkg-plist
@@ -11,7 +11,6 @@ share/applications/audacity.desktop
%%DATADIR%%/include/audacity/ModuleInterface.h
%%DATADIR%%/include/audacity/PluginInterface.h
%%DATADIR%%/include/audacity/Types.h
-%%DATADIR%%/nyquist/bug.lsp
%%DATADIR%%/nyquist/dspprims.lsp
%%DATADIR%%/nyquist/envelopes.lsp
%%DATADIR%%/nyquist/equalizer.lsp
@@ -49,25 +48,34 @@ share/applications/audacity.desktop
%%DATADIR%%/nyquist/sndfnint.lsp
%%DATADIR%%/nyquist/stk.lsp
%%DATADIR%%/nyquist/system.lsp
+%%DATADIR%%/nyquist/test.lsp
+%%DATADIR%%/nyquist/upic.sal
+%%DATADIR%%/nyquist/velocity.lsp
%%DATADIR%%/nyquist/xlinit.lsp
%%DATADIR%%/nyquist/xm.lsp
%%DATADIR%%/plug-ins/SilenceMarker.ny
%%DATADIR%%/plug-ins/SoundFinder.ny
+%%DATADIR%%/plug-ins/SpectralEditMulti.ny
+%%DATADIR%%/plug-ins/SpectralEditParametricEQ.ny
+%%DATADIR%%/plug-ins/SpectralEditShelves.ny
%%DATADIR%%/plug-ins/StudioFadeOut.ny
%%DATADIR%%/plug-ins/adjustable-fade.ny
%%DATADIR%%/plug-ins/beat.ny
%%DATADIR%%/plug-ins/clicktrack.ny
%%DATADIR%%/plug-ins/clipfix.ny
+%%DATADIR%%/plug-ins/crossfadeclips.ny
%%DATADIR%%/plug-ins/crossfadetracks.ny
%%DATADIR%%/plug-ins/delay.ny
%%DATADIR%%/plug-ins/equalabel.ny
%%DATADIR%%/plug-ins/highpass.ny
+%%DATADIR%%/plug-ins/limiter.ny
%%DATADIR%%/plug-ins/lowpass.ny
%%DATADIR%%/plug-ins/notch.ny
%%DATADIR%%/plug-ins/pluck.ny
%%DATADIR%%/plug-ins/rissetdrum.ny
%%DATADIR%%/plug-ins/sample-data-export.ny
%%DATADIR%%/plug-ins/tremolo.ny
+%%DATADIR%%/plug-ins/vocalrediso.ny
%%DATADIR%%/plug-ins/vocalremover.ny
%%DATADIR%%/plug-ins/vocoder.ny
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
@@ -77,60 +85,60 @@ share/icons/hicolor/24x24/apps/audacity.png
share/icons/hicolor/32x32/apps/audacity.png
share/icons/hicolor/48x48/apps/audacity.png
share/icons/hicolor/scalable/apps/audacity.svg
-share/locale/af/LC_MESSAGES/audacity.mo
-share/locale/ar/LC_MESSAGES/audacity.mo
-share/locale/be/LC_MESSAGES/audacity.mo
-share/locale/bg/LC_MESSAGES/audacity.mo
-share/locale/bn/LC_MESSAGES/audacity.mo
-share/locale/bs/LC_MESSAGES/audacity.mo
-share/locale/ca/LC_MESSAGES/audacity.mo
-share/locale/ca@valencia/LC_MESSAGES/audacity.mo
-share/locale/cs/LC_MESSAGES/audacity.mo
-share/locale/cy/LC_MESSAGES/audacity.mo
-share/locale/da/LC_MESSAGES/audacity.mo
-share/locale/de/LC_MESSAGES/audacity.mo
-share/locale/el/LC_MESSAGES/audacity.mo
-share/locale/es/LC_MESSAGES/audacity.mo
-share/locale/eu/LC_MESSAGES/audacity.mo
-share/locale/fa/LC_MESSAGES/audacity.mo
-share/locale/fi/LC_MESSAGES/audacity.mo
-share/locale/fr/LC_MESSAGES/audacity.mo
-share/locale/ga/LC_MESSAGES/audacity.mo
-share/locale/gl/LC_MESSAGES/audacity.mo
-share/locale/he/LC_MESSAGES/audacity.mo
-share/locale/hi/LC_MESSAGES/audacity.mo
-share/locale/hr/LC_MESSAGES/audacity.mo
-share/locale/hu/LC_MESSAGES/audacity.mo
-share/locale/hy/LC_MESSAGES/audacity.mo
-share/locale/id/LC_MESSAGES/audacity.mo
-share/locale/it/LC_MESSAGES/audacity.mo
-share/locale/ja/LC_MESSAGES/audacity.mo
-share/locale/ka/LC_MESSAGES/audacity.mo
-share/locale/km/LC_MESSAGES/audacity.mo
-share/locale/ko/LC_MESSAGES/audacity.mo
-share/locale/lt/LC_MESSAGES/audacity.mo
-share/locale/mk/LC_MESSAGES/audacity.mo
-share/locale/my/LC_MESSAGES/audacity.mo
-share/locale/nb/LC_MESSAGES/audacity.mo
-share/locale/nl/LC_MESSAGES/audacity.mo
-share/locale/oc/LC_MESSAGES/audacity.mo
-share/locale/pl/LC_MESSAGES/audacity.mo
-share/locale/pt/LC_MESSAGES/audacity.mo
-share/locale/pt_BR/LC_MESSAGES/audacity.mo
-share/locale/ro/LC_MESSAGES/audacity.mo
-share/locale/ru/LC_MESSAGES/audacity.mo
-share/locale/sk/LC_MESSAGES/audacity.mo
-share/locale/sl/LC_MESSAGES/audacity.mo
-share/locale/sr_RS/LC_MESSAGES/audacity.mo
-share/locale/sr_RS@latin/LC_MESSAGES/audacity.mo
-share/locale/sv/LC_MESSAGES/audacity.mo
-share/locale/ta/LC_MESSAGES/audacity.mo
-share/locale/tg/LC_MESSAGES/audacity.mo
-share/locale/tr/LC_MESSAGES/audacity.mo
-share/locale/uk/LC_MESSAGES/audacity.mo
-share/locale/vi/LC_MESSAGES/audacity.mo
-share/locale/zh/LC_MESSAGES/audacity.mo
-share/locale/zh_TW/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/af/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/be/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/bn/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/bs/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ca_ES@valencia/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/cy/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/da/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/de/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/el/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/es/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/he/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/hi/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/hy/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/id/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/it/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/km/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/mk/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/my/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/sr_RS/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/sr_RS@latin/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/ta/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/tg/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/zh/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/audacity.mo
share/mime/packages/audacity.xml
share/pixmaps/audacity.xpm
share/pixmaps/audacity16.xpm