aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-17 13:10:25 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-17 13:10:25 +0000
commitae30b894a9f845fca5f09383c159dd002bd39854 (patch)
tree2877b07c02bedc142b19893b63f4d2a236bae385 /audio
parentf27c11db127e15ce51aa99381686bf4abfa42fbc (diff)
downloadports-ae30b894a9f845fca5f09383c159dd002bd39854.tar.gz
ports-ae30b894a9f845fca5f09383c159dd002bd39854.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/nyello/Makefile33
-rw-r--r--audio/nyello/distinfo3
-rw-r--r--audio/nyello/pkg-descr13
4 files changed, 50 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 83413bec52bb..4e46886164ea 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -349,6 +349,7 @@
SUBDIR += normalize
SUBDIR += nosefart
SUBDIR += nspmod
+ SUBDIR += nyello
SUBDIR += ocp
SUBDIR += ogg2mp3
SUBDIR += oggsplit
diff --git a/audio/nyello/Makefile b/audio/nyello/Makefile
new file mode 100644
index 000000000000..78f63b199c4b
--- /dev/null
+++ b/audio/nyello/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: nyello
+# Date created: 03 Mar 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nyello
+PORTVERSION= 0.4.1
+CATEGORIES= audio
+MASTER_SITES= http://sirius.cine7.net/nyello/releases/
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= An advanced command-line interface and shell for xmms2
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient.so:${PORTSDIR}/audio/xmms2
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+PLIST_FILES= bin/nyello
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not build on FreeBSD 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/nyello/distinfo b/audio/nyello/distinfo
new file mode 100644
index 000000000000..2359a81679d5
--- /dev/null
+++ b/audio/nyello/distinfo
@@ -0,0 +1,3 @@
+SHA256 (nyello-0.4.1.tar.bz2) = 74b6f8942521e0527c1150d542085f52a9e17cc700365f46e7c6eeb3f99d6fd7
+MD5 (nyello-0.4.1.tar.bz2) = 8ed6576966ded202fc482d5b61f81d3a
+SIZE (nyello-0.4.1.tar.bz2) = 96618
diff --git a/audio/nyello/pkg-descr b/audio/nyello/pkg-descr
new file mode 100644
index 000000000000..dd79d13646e2
--- /dev/null
+++ b/audio/nyello/pkg-descr
@@ -0,0 +1,13 @@
+nyello is a command-line XMMS2 client.
+
+It aims at providing a high-level interface to the XMMS2 server, with a concise
+and powerful interaction syntax. It boasts (or soon will boast) advanced
+features, such as rich pattern expressions to efficiently browse your library,
+smart completion of commands and custom song collections to organize your
+library.
+
+It can either run a single command or work like a shell (if started without
+argument). As a command-line program, it is mostly targetted at Unix
+power-users.
+
+WWW: http://sirius.cine7.net/nyello/index.php