aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-24 20:43:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-24 20:43:28 +0000
commitfdab10a6224ef060bbc144c2df9f80562c972f1f (patch)
tree0e6959101a54e4d33c02ecf728f4115dc722c876 /audio
parentb65b1a8c3ae1a59c5868f7a5b88ab616be9ab6be (diff)
downloadports-fdab10a6224ef060bbc144c2df9f80562c972f1f.tar.gz
ports-fdab10a6224ef060bbc144c2df9f80562c972f1f.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/nekobee/Makefile26
-rw-r--r--audio/nekobee/distinfo3
-rw-r--r--audio/nekobee/pkg-descr10
-rw-r--r--audio/nekobee/pkg-plist6
5 files changed, 46 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 785ceb28af60..c0fa28caba73 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -425,6 +425,7 @@
SUBDIR += napster
SUBDIR += nas
SUBDIR += ncmpc
+ SUBDIR += nekobee
SUBDIR += nogger
SUBDIR += normalize
SUBDIR += nosefart
diff --git a/audio/nekobee/Makefile b/audio/nekobee/Makefile
new file mode 100644
index 000000000000..81e4d8977aa3
--- /dev/null
+++ b/audio/nekobee/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: nekobee
+# Date created: 2007-01-20
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nekobee
+PORTVERSION= 0.1.5
+CATEGORIES= audio
+MASTER_SITES= http://static.nekosynth.co.uk/releases/
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= DSSI plugin that emulates the sound of the TB-303 Bassline
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.6:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+CFLAGS+= -I${LOCALBASE}/include/dssi
+
+.include <bsd.port.mk>
diff --git a/audio/nekobee/distinfo b/audio/nekobee/distinfo
new file mode 100644
index 000000000000..6be5877c15ef
--- /dev/null
+++ b/audio/nekobee/distinfo
@@ -0,0 +1,3 @@
+MD5 (nekobee-0.1.5.tar.gz) = ea44890a94318a1bd6dc2b8a1c1a03fc
+SHA256 (nekobee-0.1.5.tar.gz) = d08c0f1eb9a50dd2750374eedc15fbbc02b0f9274d8794535790157edb282638
+SIZE (nekobee-0.1.5.tar.gz) = 565550
diff --git a/audio/nekobee/pkg-descr b/audio/nekobee/pkg-descr
new file mode 100644
index 000000000000..e8a53b29d2c5
--- /dev/null
+++ b/audio/nekobee/pkg-descr
@@ -0,0 +1,10 @@
+nekobee is a DSSI soft synth plugin that emulates the sound of the
+TB-303 Bassline. It is not an exact copy; rather than make it "just
+like the real thing", the design concentrates on modelling the
+circuitry and was adjusted by comparing the sounds achievable with
+it to those heard on classic acid house tracks. It includes a
+switchable square/saw wave VCO, 24dB/octave VCF, an adjustable decay
+time for the VCF, a fixed decay time for the VCA, and an interesting
+bit of circuitry around the "Accent" control.
+
+WWW: http://freshmeat.net/projects/nekobee/
diff --git a/audio/nekobee/pkg-plist b/audio/nekobee/pkg-plist
new file mode 100644
index 000000000000..d25d3156f428
--- /dev/null
+++ b/audio/nekobee/pkg-plist
@@ -0,0 +1,6 @@
+lib/dssi/nekobee/nekobee_gtk
+lib/dssi/nekobee/knob.png
+lib/dssi/nekobee/switch.png
+lib/dssi/nekobee.so
+lib/dssi/nekobee.la
+@dirrm lib/dssi/nekobee