aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-05-17 20:17:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-05-17 20:17:07 +0000
commit73a4944055ac56dbde2079acee7af46281370492 (patch)
treea3eac8ff1a4e87c86f022f3caae6b3a930770954 /audio
parent40926f09317a0255fb02df450794b34c97fc2266 (diff)
downloadports-73a4944055ac56dbde2079acee7af46281370492.tar.gz
ports-73a4944055ac56dbde2079acee7af46281370492.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gstreamer-monkeysaudio/Makefile38
-rw-r--r--audio/gstreamer-monkeysaudio/distinfo2
-rw-r--r--audio/gstreamer-monkeysaudio/pkg-descr3
-rw-r--r--audio/gstreamer-monkeysaudio/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index cb9725a85a86..a808d33472df 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -133,6 +133,7 @@
SUBDIR += gsi
SUBDIR += gsm
SUBDIR += gspeakers
+ SUBDIR += gstreamer-monkeysaudio
SUBDIR += gtick
SUBDIR += gtkgep
SUBDIR += gtkpod
diff --git a/audio/gstreamer-monkeysaudio/Makefile b/audio/gstreamer-monkeysaudio/Makefile
new file mode 100644
index 000000000000..1e1d18e9b028
--- /dev/null
+++ b/audio/gstreamer-monkeysaudio/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gstreamer monkeysaudio
+# Date created: Thu May 13 14:04:31 CEST 2004
+# Whom: Koop Mast <kwm@rainbow-runner.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gstreamer
+PORTVERSION= 0.8.0
+CATEGORIES= audio
+MASTER_SITES= http://gstreamer.freedesktop.org/src/gst${PKGNAMESUFFIX}/
+PKGNAMESUFFIX= -monkeysaudio
+DISTNAME= gst${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= kwm@rainbow-runner.nl
+COMMENT= GStreamer plugin for monkeysaudio files
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER=13
+USE_GNOME= lthack gnomehack gnomeprefix gstreamerplugins
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB= VERSION="${GST_VERSION}"
+
+GST_VERSION=${PORTVERSION:C/..$//}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/GStreamer-monkeysaudio-permit \
+ ${DOCSDIR}/GStreamer-monkeysaudio-permit
+.endif
+# register plugins
+ -@${X11BASE}/bin/gst-register-${GST_VERSION} 2>/dev/null
+
+.include <bsd.port.mk>
diff --git a/audio/gstreamer-monkeysaudio/distinfo b/audio/gstreamer-monkeysaudio/distinfo
new file mode 100644
index 000000000000..9b86060bb366
--- /dev/null
+++ b/audio/gstreamer-monkeysaudio/distinfo
@@ -0,0 +1,2 @@
+MD5 (gst-monkeysaudio-0.8.0.tar.bz2) = cda60097072e9f48316a76ef2e4d9925
+SIZE (gst-monkeysaudio-0.8.0.tar.bz2) = 249562
diff --git a/audio/gstreamer-monkeysaudio/pkg-descr b/audio/gstreamer-monkeysaudio/pkg-descr
new file mode 100644
index 000000000000..2d66aad41c34
--- /dev/null
+++ b/audio/gstreamer-monkeysaudio/pkg-descr
@@ -0,0 +1,3 @@
+Gstreamer plugins for playing monkeysaudio (.ape) files.
+
+WWW: http://gstreamer.freedesktop.org
diff --git a/audio/gstreamer-monkeysaudio/pkg-plist b/audio/gstreamer-monkeysaudio/pkg-plist
new file mode 100644
index 000000000000..8dc11a0fce70
--- /dev/null
+++ b/audio/gstreamer-monkeysaudio/pkg-plist
@@ -0,0 +1,5 @@
+lib/gstreamer-%%VERSION%%/libgstmonkeysaudio.so
+%%PORTDOCS%%%%DOCSDIR%%/GStreamer-monkeysaudio-permit
+@exec %D/bin/gst-register 2>/dev/null || true
+%%PORTDOCS%%@unexec /bin/rmdir %%DOCSDIR%% 2>/dev/null || true
+@unexec %D/bin/gst-register 2>/dev/null || true