aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-08-22 21:38:19 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-08-22 21:38:19 +0000
commita49dc2fbbe608f21779a37a6e4106c1066efeb95 (patch)
tree58cf272bcde522f9a6fcb8819961fa45699539e8 /audio
parent294ed017261a14e9e472ef89279c325b9da90a10 (diff)
downloadports-a49dc2fbbe608f21779a37a6e4106c1066efeb95.tar.gz
ports-a49dc2fbbe608f21779a37a6e4106c1066efeb95.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/muse/Makefile6
-rw-r--r--audio/muse/files/extra-patch-broken-scandir11
2 files changed, 15 insertions, 2 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index df3d998d12fa..5d8c055e3382 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -19,8 +19,6 @@ COMMENT= Multiple Streaming Engine
LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
ogg.7:${PORTSDIR}/audio/libogg
-BROKEN= does not compile
-
USE_GETTEXT= yes
USE_GNOME= gnometarget
USE_GMAKE= yes
@@ -37,6 +35,10 @@ OPTIONS= X11 "Build with X11 support" on \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800501
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-broken-scandir
+.endif
+
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS+=--without-x --with-rubik
diff --git a/audio/muse/files/extra-patch-broken-scandir b/audio/muse/files/extra-patch-broken-scandir
new file mode 100644
index 000000000000..67f1bf3e52f8
--- /dev/null
+++ b/audio/muse/files/extra-patch-broken-scandir
@@ -0,0 +1,11 @@
+--- src/jmixer.cpp.orig 2004-12-16 03:04:31.000000000 -0800
++++ src/jmixer.cpp 2010-08-22 14:15:03.000000000 -0700
+@@ -640,7 +640,7 @@
+ /* this is the function selecting files for the scandir
+ on freebsd systems you should change the following line to:
+ int selector(struct dirent *dir) { */
+-int selector(const struct dirent *dir) {
++int selector(struct dirent *dir) {
+ if( strncasecmp(dir->d_name+strlen(dir->d_name)-4,".mp3",4)==0
+ #ifdef HAVE_VORBIS
+ || strncasecmp(dir->d_name+strlen(dir->d_name)-4,".ogg",4)==0