aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-27 22:44:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-27 22:44:20 +0000
commitb4b4aecee16a48da69d927487a0bc33033d6574c (patch)
tree780ca9948585ee44a6572a47349c11f3ad2e2a58 /audio
parent0d93374ffdb4a99a6f6aacceb129a7e4b3b49151 (diff)
downloadports-b4b4aecee16a48da69d927487a0bc33033d6574c.tar.gz
ports-b4b4aecee16a48da69d927487a0bc33033d6574c.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/praat/Makefile18
-rw-r--r--audio/praat/distinfo6
-rw-r--r--audio/praat/files/patch-makefiles_makefile.defs.freebsd.dynamic16
-rw-r--r--audio/praat/files/praat.139
-rw-r--r--audio/praat/pkg-descr2
5 files changed, 63 insertions, 18 deletions
diff --git a/audio/praat/Makefile b/audio/praat/Makefile
index ee3d179201e4..8ceb5b4826b5 100644
--- a/audio/praat/Makefile
+++ b/audio/praat/Makefile
@@ -6,22 +6,27 @@
#
PORTNAME= praat
-PORTVERSION= 4.4.10
-PORTREVISION= 1
+PORTVERSION= 4.6.39
CATEGORIES= audio science
-MASTER_SITES= http://www.neuro.mcw.edu/~bacon/Ports/distfiles/Praat/4410/
-DISTNAME= praat4410_sources
+MASTER_SITES= http://www.neuro.mcw.edu/~bacon/Ports/distfiles/Praat/4639/ \
+ http://www.fon.hum.uva.nl/praat/
+DISTNAME= praat4639_sources
MAINTAINER= bacon@smithers.neuro.mcw.edu
COMMENT= Phonetics by Computer
-USE_X_PREFIX= yes
+USE_DOS2UNIX= yes
+DOS2UNIX_REGEX= .*Makefile
+USE_XLIB= yes
USE_MOTIF= yes
-WRKSRC= ${WRKDIR}/sources_4410
+WRKSRC= ${WRKDIR}/sources_4639
MAKEFILE= makefile
PLIST_FILES= bin/praat
+MAN1= praat.1
+
post-patch:
+ @${REINPLACE_CMD} -e 's/ log2/ NUMlog2/' ${WRKSRC}/dwtools/Sound_extensions.c
@${FIND} ${WRKSRC} -name Makefile -exec \
${REINPLACE_CMD} -e 's|^CFLAGS =|CFLAGS +=|' "{}" \;
@${CP} ${WRKSRC}/makefiles/makefile.defs.freebsd.dynamic \
@@ -29,5 +34,6 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/praat ${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/praat.1 ${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/audio/praat/distinfo b/audio/praat/distinfo
index 50a626dd3ec4..03f5b91c5110 100644
--- a/audio/praat/distinfo
+++ b/audio/praat/distinfo
@@ -1,3 +1,3 @@
-MD5 (praat4410_sources.tar.gz) = 4ce2ff7ef39f20630ce399b8ea68f57f
-SHA256 (praat4410_sources.tar.gz) = 2e1e0108d0a575c22a546cedc211128ddc38e8d50bcbce6710140c3f8da66790
-SIZE (praat4410_sources.tar.gz) = 2442588
+MD5 (praat4639_sources.tar.gz) = ab8399affb727bd775271724b81becfd
+SHA256 (praat4639_sources.tar.gz) = eba69ae300c9e86bea8a6dd69953b4436efb6519fb3ae228a9fe7d9e8cfa0c05
+SIZE (praat4639_sources.tar.gz) = 4928560
diff --git a/audio/praat/files/patch-makefiles_makefile.defs.freebsd.dynamic b/audio/praat/files/patch-makefiles_makefile.defs.freebsd.dynamic
index 8d4368f72ac8..d69aee498028 100644
--- a/audio/praat/files/patch-makefiles_makefile.defs.freebsd.dynamic
+++ b/audio/praat/files/patch-makefiles_makefile.defs.freebsd.dynamic
@@ -1,14 +1,14 @@
---- makefiles/makefile.defs.freebsd.dynamic.orig Thu May 19 14:12:01 2005
-+++ makefiles/makefile.defs.freebsd.dynamic Mon Apr 3 04:24:51 2006
-@@ -4,9 +4,9 @@
- # Jason W. Bacon (jbacon@mcw.edu), December 6, 2003
- # Paul Boersma, May 19, 2005
+--- makefiles/makefile.defs.freebsd.dynamic.orig 2007-12-02 15:47:18.000000000 +0200
++++ makefiles/makefile.defs.freebsd.dynamic 2007-12-02 15:55:05.000000000 +0200
+@@ -3,9 +3,9 @@
+ # System: FreeBSD
+ # Paul Boersma, January 31, 2007
--CC = gcc -DUNIX -Dlinux -I /usr/X11R6/include -Wimplicit -Wreturn-type -Wunused -Wunused-parameter -Wuninitialized -O
-+CC += -DUNIX -Dlinux -I${X11BASE}/include -trigraphs
+-CC = gcc -std=gnu99 -DUNIX -Dlinux -I /usr/X11R6/include -Wimplicit -Wreturn-type -Wunused -Wunused-parameter -Wuninitialized -O
++CC += -std=gnu99 -DUNIX -Dlinux -I${X11BASE}/include -Wimplicit -Wreturn-type -Wunused -Wunused-parameter -Wuninitialized
-LIBS = /usr/X11R6/lib/libXm.a -L /usr/X11R6/lib -lXmu -lXp -lXt -lSM -lICE -lXext -lX11 -lm
-+LIBS = ${X11BASE}/lib/libXm.a -L${X11BASE}/lib -lXmu -lXp -lXt -lSM -lICE -lXext -lX11 -lm
++LIBS = ${X11BASE}/lib/libXm.a -L${X11BASE}/lib -lXmu -lXp -lXt -lSM -lICE -lXext -lX11 -lm
RANLIB = ls
ICON =
diff --git a/audio/praat/files/praat.1 b/audio/praat/files/praat.1
new file mode 100644
index 000000000000..28fe8ebbf9ec
--- /dev/null
+++ b/audio/praat/files/praat.1
@@ -0,0 +1,39 @@
+.TH PRAAT 1
+.SH NAME \" Section header
+.PP
+
+PRAAT \- Doing phonetics by computer.
+
+.SH SYNOPSIS
+.PP
+.nf
+.na
+praat
+.ad
+.fi
+
+\" Optional sections
+.SH "DESCRIPTION"
+
+Praat is a sophisticated graphical tool for analyzing and manipulating
+phonetic data.
+
+Praat supports a variety of sound file formats, and consists of tools
+to support speech analysis, labelling and segmentation, learning
+algorithms, graphing, speech synthesis, listening experiments,
+speech manipulation, and statistics. It also includes a scripting
+language to help automate the analysis process.
+
+For documentation, see the Help menu in praat, or visit the WEB site:
+http://www.praat.org.
+
+.SH "SEE ALSO"
+audacity(1)
+
+.SH AUTHOR
+.nf
+.na
+Paul Boersma and David Weenink
+Institute of Phonetic Sciences
+University of Amsterdam
+
diff --git a/audio/praat/pkg-descr b/audio/praat/pkg-descr
index 198a64366ef7..e2f97b289546 100644
--- a/audio/praat/pkg-descr
+++ b/audio/praat/pkg-descr
@@ -1,3 +1,3 @@
Praat: doing phonetics by computer.
-WWW: http://www.fon.hum.uva.nl/praat/
+WWW: http://www.praat.org