aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-11-27 10:53:04 +0000
committerWen Heping <wen@FreeBSD.org>2009-11-27 10:53:04 +0000
commit322b863a607f8db5a87bfe017b03f41cea90b6a6 (patch)
tree1663c906af51a0cb6c857b32397c87457fdd6da1 /audio
parent32565f020f66d28ee036b664f331eccea9fca132 (diff)
downloadports-322b863a607f8db5a87bfe017b03f41cea90b6a6.tar.gz
ports-322b863a607f8db5a87bfe017b03f41cea90b6a6.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3splt-gtk/Makefile31
-rw-r--r--audio/mp3splt-gtk/distinfo3
-rw-r--r--audio/mp3splt-gtk/pkg-descr10
-rw-r--r--audio/mp3splt-gtk/pkg-plist11
5 files changed, 56 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 9550e621310d..12af9b5a2d11 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -459,6 +459,7 @@
SUBDIR += mp3rename
SUBDIR += mp3riot
SUBDIR += mp3splt
+ SUBDIR += mp3splt-gtk
SUBDIR += mp3stat
SUBDIR += mp3towav-bundle
SUBDIR += mp3unicode
diff --git a/audio/mp3splt-gtk/Makefile b/audio/mp3splt-gtk/Makefile
new file mode 100644
index 000000000000..5ee248528ef5
--- /dev/null
+++ b/audio/mp3splt-gtk/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: audio/mp3splt-gtk
+# Date created: 05.09.2009
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+# $FreeBSD$
+
+PORTNAME= mp3splt-gtk
+PORTVERSION= 0.5.7a
+CATEGORIES= audio
+MASTER_SITES= SF/mp3splt/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Utility to split mp3 and ogg files (via GTK Interface)
+
+BUILD_DEPENDS= audacious2:${PORTSDIR}/multimedia/audacious
+LIB_DEPENDS= mp3splt:${PORTSDIR}/audio/libmp3splt \
+ mad.2:${PORTSDIR}/audio/libmad \
+ ogg.6:${PORTSDIR}/audio/libogg \
+ vorbis.4:${PORTSDIR}/audio/libvorbis \
+ id3tag.0:${PORTSDIR}/audio/libid3tag
+
+USE_AUTOTOOLS= libltdl
+USE_GSTREAMER= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
+CONFIGURE_ARGS+= --enable-audacious --with-mp3splt=${LOCALBASE} --with-mp3splt-includes=${LOCALBASE}/include --with-mp3splt-libraries=${LOCALBASE}/lib --disable-mp3splttest
+
+MAN1= mp3splt-gtk.1
+
+.include <bsd.port.mk>
diff --git a/audio/mp3splt-gtk/distinfo b/audio/mp3splt-gtk/distinfo
new file mode 100644
index 000000000000..3ae30b0af883
--- /dev/null
+++ b/audio/mp3splt-gtk/distinfo
@@ -0,0 +1,3 @@
+MD5 (mp3splt-gtk-0.5.7a.tar.gz) = 932eed8faf227e5f53dad3f3afba9bdf
+SHA256 (mp3splt-gtk-0.5.7a.tar.gz) = 732303cef770f16f8a926d0569ae087664df2a8bea014e4e11013b457d6692aa
+SIZE (mp3splt-gtk-0.5.7a.tar.gz) = 304058
diff --git a/audio/mp3splt-gtk/pkg-descr b/audio/mp3splt-gtk/pkg-descr
new file mode 100644
index 000000000000..d7aa98a4915f
--- /dev/null
+++ b/audio/mp3splt-gtk/pkg-descr
@@ -0,0 +1,10 @@
+Mp3Splt is a command line utility to split mp3 and ogg files selecting a begin
+and an end time position, without decoding. It's very useful to split large
+mp3/ogg to make smaller files or to split entire albums to obtain original
+tracks. If you want to split an album, you can select split points and
+filenames manually or you can get them automatically from CDDB (Internet or a
+local file) or from .cue files. Otherwise if you have a file created either
+with Mp3Wrap or AlbumWrap you can extract tracks just in few seconds. Supports
+VBR mp3.
+
+WWW: http://mp3splt.sourceforge.net/
diff --git a/audio/mp3splt-gtk/pkg-plist b/audio/mp3splt-gtk/pkg-plist
new file mode 100644
index 000000000000..ef6718b5875b
--- /dev/null
+++ b/audio/mp3splt-gtk/pkg-plist
@@ -0,0 +1,11 @@
+bin/mp3splt-gtk
+share/applications/mp3splt-gtk.desktop
+share/locale/de/LC_MESSAGES/mp3splt-gtk.mo
+share/locale/fr/LC_MESSAGES/mp3splt-gtk.mo
+share/pixmaps/mp3splt-gtk.png
+share/pixmaps/mp3splt-gtk_ico.png
+@dirrmtry share/locale/de/LC_MESSAGES
+@dirrmtry share/locale/de
+@dirrmtry share/locale/fr/LC_MESSAGES
+@dirrmtry share/locale/fr
+@dirrmtry share/pixmaps