aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-11 08:26:31 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-11 08:26:31 +0000
commitc65469d48a1ce66b0bfb9fe3a08cdc4cf42c96c3 (patch)
tree4e30be696ba9e768d0f8ddf8c95a3aa2e2072210 /audio
parentca1d1b7e2059966b6222d9563fafe093e824dd23 (diff)
downloadports-c65469d48a1ce66b0bfb9fe3a08cdc4cf42c96c3.tar.gz
ports-c65469d48a1ce66b0bfb9fe3a08cdc4cf42c96c3.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/zita-convolver/Makefile34
-rw-r--r--audio/zita-convolver/distinfo3
-rw-r--r--audio/zita-convolver/files/patch-Makefile34
-rw-r--r--audio/zita-convolver/pkg-descr5
5 files changed, 77 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index e5732815ec2b..b6733367593e 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -861,6 +861,7 @@
SUBDIR += xwave
SUBDIR += yell
SUBDIR += zinf
+ SUBDIR += zita-convolver
SUBDIR += zita-resampler
SUBDIR += zynaddsubfx
diff --git a/audio/zita-convolver/Makefile b/audio/zita-convolver/Makefile
new file mode 100644
index 000000000000..3c9214f17677
--- /dev/null
+++ b/audio/zita-convolver/Makefile
@@ -0,0 +1,34 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= zita-convolver
+PORTVERSION= 3.1.0
+CATEGORIES= audio
+MASTER_SITES= http://kokkinizita.linuxaudio.org/linuxaudio/downloads/
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Fast, partitioned convolution engine library
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/../COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
+LIB_DEPENDS= libfftw3f.so:math/fftw3-float
+
+USES= compiler:c++11-lib gmake localbase:ldflags tar:bz2
+USE_LDCONFIG= yes
+WRKSRC_SUBDIR= libs
+
+PLIST_FILES= include/zita-convolver.h \
+ lib/libzita-convolver.so \
+ lib/libzita-convolver.so.3 \
+ lib/libzita-convolver.so.${PORTVERSION}
+
+post-patch:
+ ${REINPLACE_CMD} 's/__APPLE__/__FreeBSD__/' \
+ ${WRKSRC}/zita-convolver.h
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libzita-convolver.so.${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/zita-convolver/distinfo b/audio/zita-convolver/distinfo
new file mode 100644
index 000000000000..65480e2c6995
--- /dev/null
+++ b/audio/zita-convolver/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501728395
+SHA256 (zita-convolver-3.1.0.tar.bz2) = bf7e93b582168b78d40666974460ad8142c2fa3c3412e327e4ab960b3fb31993
+SIZE (zita-convolver-3.1.0.tar.bz2) = 21485
diff --git a/audio/zita-convolver/files/patch-Makefile b/audio/zita-convolver/files/patch-Makefile
new file mode 100644
index 000000000000..cfab1e421c38
--- /dev/null
+++ b/audio/zita-convolver/files/patch-Makefile
@@ -0,0 +1,34 @@
+--- Makefile.orig 2011-11-20 21:30:54 UTC
++++ Makefile
+@@ -21,8 +21,8 @@
+ # Modify as required.
+ #
+ PREFIX = /usr/local
+-SUFFIX := $(shell uname -m | sed -e 's/^unknown/$//' -e 's/^i.86/$//' -e 's/^x86_64/$/64/')
+-LIBDIR = lib$(SUFFIX)
++#SUFFIX := $(shell uname -m | sed -e 's/^unknown/$//' -e 's/^i.86/$//' -e 's/^x86_64/$/64/')
++LIBDIR = lib
+
+
+ MAJVERS = 3
+@@ -45,9 +45,10 @@ ZITA-CONVOLVER_DEP = -lfftw3f -lpthread
+ ZITA-CONVOLVER_O = zita-convolver.o
+ ZITA-CONVOLVER_H = zita-convolver.h
+
++all: $(ZITA-CONVOLVER_MIN)
+
+ $(ZITA-CONVOLVER_MIN): $(ZITA-CONVOLVER_O)
+- g++ -shared $(LDFLAGS) -Wl,-soname,$(ZITA-CONVOLVER_MAJ) -o $(ZITA-CONVOLVER_MIN) $(ZITA-CONVOLVER_O) $(ZITA-CONVOLVER_DEP)
++ ${CXX} -shared $(LDFLAGS) -Wl,-soname,$(ZITA-CONVOLVER_MAJ) -o $(ZITA-CONVOLVER_MIN) $(ZITA-CONVOLVER_O) $(ZITA-CONVOLVER_DEP)
+
+
+ install: $(ZITA-CONVOLVER_MIN)
+@@ -56,7 +57,7 @@ install: $(ZITA-CONVOLVER_MIN)
+ install -m 644 $(ZITA-CONVOLVER_H) $(DESTDIR)$(PREFIX)/include
+ install -m 755 $(ZITA-CONVOLVER_MIN) $(DESTDIR)$(PREFIX)/$(LIBDIR)
+ ln -sf $(ZITA-CONVOLVER_MIN) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(ZITA-CONVOLVER_SO)
+- ldconfig
++ ln -sf $(ZITA-CONVOLVER_MIN) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(ZITA-CONVOLVER_MAJ)
+
+ clean:
+ /bin/rm -f *~ *.o *.a *.d *.so.*
diff --git a/audio/zita-convolver/pkg-descr b/audio/zita-convolver/pkg-descr
new file mode 100644
index 000000000000..851ea09a535b
--- /dev/null
+++ b/audio/zita-convolver/pkg-descr
@@ -0,0 +1,5 @@
+A C++ library implementing a real-time convolution matrix for up to 64 inputs
+and outputs. It uses multiple partition sizes to provide both low delay and
+efficient CPU use.
+
+WWW: http://kokkinizita.linuxaudio.org/linuxaudio/