aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-07-26 16:03:11 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-07-26 16:03:11 +0000
commitcfc85b000ac8e1a11685025b56364ab548298e8d (patch)
treed5605cacc04343c5ee575afcbc2fc965355059ba /audio
parent063a6acf984c5d889b4fb616204c9989af46bf6b (diff)
downloadports-cfc85b000ac8e1a11685025b56364ab548298e8d.tar.gz
ports-cfc85b000ac8e1a11685025b56364ab548298e8d.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/tse3/Makefile55
-rw-r--r--audio/tse3/distinfo2
-rw-r--r--audio/tse3/files/patch-OSS.cpp75
-rw-r--r--audio/tse3/files/patch-configure10
-rw-r--r--audio/tse3/pkg-descr1
-rw-r--r--audio/tse3/pkg-plist163
7 files changed, 307 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 9fbf768defda..cb484a241ee8 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -379,6 +379,7 @@
SUBDIR += tracker
SUBDIR += trm
SUBDIR += trommler
+ SUBDIR += tse3
SUBDIR += tuneradio
SUBDIR += ufmcontrol-i18n
SUBDIR += umix
diff --git a/audio/tse3/Makefile b/audio/tse3/Makefile
new file mode 100644
index 000000000000..d55d8e3c3a64
--- /dev/null
+++ b/audio/tse3/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: tse3
+# Date created: Wed Nov 12 14:10:12 PST 2003
+# Whom: Mathew Kanner <mat@hak.cnd.mcgill.ca>
+#
+# $FreeBSD$
+
+PORTNAME= tse3
+PORTVERSION= 0.2.7
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A MIDI library
+
+LIB_DEPENDS= artsc:${PORTSDIR}/audio/arts
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER=13
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+
+MAN1= tse3play.1
+MAN3= tse3.3
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} -n "checking for SNDCTL_SEQ_GETTIME in sys/soundcard.h... "
+ @if ${GREP} -q SNDCTL_SEQ_GETTIME /usr/include/sys/soundcard.h; then\
+ ${ECHO_MSG} "yes";\
+ ${ECHO_MSG};\
+ else\
+ ${ECHO_MSG} "no";\
+ ${ECHO_MSG};\
+ ${ECHO_MSG} "********************************************************************************";\
+ ${ECHO_MSG} "* This port requires: *";\
+ ${ECHO_MSG} "* *";\
+ ${ECHO_MSG} "* FreeBSD-CURRENT newer than Nov 22 03:27:09 2003 UTC (or FreeBSD 5.3-Release) *";\
+ ${ECHO_MSG} "* *";\
+ ${ECHO_MSG} "* OR *";\
+ ${ECHO_MSG} "* *";\
+ ${ECHO_MSG} "* FreeBSD-STABLE newer than Jul 20 13:49:30 2004 UTC (or FreeBSD 4.11-Release) *";\
+ ${ECHO_MSG} "********************************************************************************";\
+ ${ECHO_MSG};\
+ ${ECHO_MSG} "Aborting."; exit 1;\
+ fi
+
+pre-configure:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} -x -n 10 \
+ ${REINPLACE_CMD} -e 's|_LDFLAGS =|_LDFLAGS = ${PTHREAD_LIBS}|g'
+
+.include <bsd.port.post.mk>
diff --git a/audio/tse3/distinfo b/audio/tse3/distinfo
new file mode 100644
index 000000000000..2cb27e772d57
--- /dev/null
+++ b/audio/tse3/distinfo
@@ -0,0 +1,2 @@
+MD5 (tse3-0.2.7.tar.gz) = 6ccab942cc51a648af76653771479eed
+SIZE (tse3-0.2.7.tar.gz) = 603222
diff --git a/audio/tse3/files/patch-OSS.cpp b/audio/tse3/files/patch-OSS.cpp
new file mode 100644
index 000000000000..3c9d4a746d52
--- /dev/null
+++ b/audio/tse3/files/patch-OSS.cpp
@@ -0,0 +1,75 @@
+diff -r -c tse3-0.2.7.old/src/tse3/plt/OSS.cpp tse3-0.2.7/src/tse3/plt/OSS.cpp
+*** src/tse3/plt/OSS.cpp.orig Tue Oct 22 09:29:29 2002
+--- src/tse3/plt/OSS.cpp Wed Nov 12 16:13:39 2003
+***************
+*** 1484,1494 ****
+ #ifdef TSE3_WITH_OSS
+ // Happily, if you switch -pedantic on in gcc these macros will always
+ // throw up warnings. Marvel at the beauty of awe_voice.h for reasons why.
+!
+ AWE_SET_CHANNEL_MODE(deviceno, AWE_PLAY_MULTI);
+ AWE_SET_CHANNEL_MODE(deviceno, 1);
+ AWE_DRUM_CHANNELS(deviceno, 1<<9);
+ AWE_TERMINATE_ALL(deviceno);
+ seqbuf_dump();
+ #endif
+ }
+--- 1484,1495 ----
+ #ifdef TSE3_WITH_OSS
+ // Happily, if you switch -pedantic on in gcc these macros will always
+ // throw up warnings. Marvel at the beauty of awe_voice.h for reasons why.
+! #if 0
+ AWE_SET_CHANNEL_MODE(deviceno, AWE_PLAY_MULTI);
+ AWE_SET_CHANNEL_MODE(deviceno, 1);
+ AWE_DRUM_CHANNELS(deviceno, 1<<9);
+ AWE_TERMINATE_ALL(deviceno);
++ #endif
+ seqbuf_dump();
+ #endif
+ }
+***************
+*** 1996,2002 ****
+ // there is no soundcard
+ throw TSE3::MidiSchedulerError(TSE3::MidiSchedulerCreateErr);
+ }
+! ioctl(seqfd, SNDCTL_SEQ_NRMIDIS, &nomidis);
+ rate = 0;
+ ioctl(seqfd, SNDCTL_SEQ_CTRLRATE, &rate);
+ if (rate == -1 || rate <= 0) rate = 100;
+--- 1997,2004 ----
+ // there is no soundcard
+ throw TSE3::MidiSchedulerError(TSE3::MidiSchedulerCreateErr);
+ }
+! // ioctl(seqfd, SNDCTL_SEQ_NRMIDIS, &nomidis);
+! nomidis = 0;
+ rate = 0;
+ ioctl(seqfd, SNDCTL_SEQ_CTRLRATE, &rate);
+ if (rate == -1 || rate <= 0) rate = 100;
+***************
+*** 2044,2049 ****
+--- 2046,2059 ----
+ }
+ std::cout << ")\n";
+ }
++ #if 1
++ devices[n]
++ = new OSSMidiScheduler_AWEDevice(n, synthinfo[n], seqfd,
++ _seqbuf, _seqbuflen,
++ _seqbufptr);
++ }
++ }
++ #else
+ if (synthinfo[n].synth_type == SYNTH_TYPE_SAMPLE
+ && synthinfo[n].synth_subtype == SAMPLE_TYPE_AWE32)
+ {
+***************
+*** 2100,2105 ****
+--- 2110,2116 ----
+ }
+ }
+
++ #endif
+ // Now let the public API know about these devices
+ for (unsigned int n = 0; n < nodevices; ++n)
+ {
+Only in tse3-0.2.7/src/tse3/plt: OSS.cpp.orig
diff --git a/audio/tse3/files/patch-configure b/audio/tse3/files/patch-configure
new file mode 100644
index 000000000000..7ac516dccdd4
--- /dev/null
+++ b/audio/tse3/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu May 27 19:55:30 2004
++++ configure Thu May 27 19:55:39 2004
+@@ -7820,6 +7820,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/tse3/pkg-descr b/audio/tse3/pkg-descr
new file mode 100644
index 000000000000..ec2c369bc47b
--- /dev/null
+++ b/audio/tse3/pkg-descr
@@ -0,0 +1 @@
+TSE3 is a library and simple test application for MIDI.
diff --git a/audio/tse3/pkg-plist b/audio/tse3/pkg-plist
new file mode 100644
index 000000000000..f1b4dc3868f3
--- /dev/null
+++ b/audio/tse3/pkg-plist
@@ -0,0 +1,163 @@
+@comment $FreeBSD: /tmp/pcvs/ports/audio/tse3/pkg-plist,v 1.1 2004-07-26 16:03:11 lofi Exp $
+bin/tse3play
+doc/tse3-0.2.7/AUTHORS
+doc/tse3-0.2.7/About.html
+doc/tse3-0.2.7/Article.html
+doc/tse3-0.2.7/Bugs.html
+doc/tse3-0.2.7/Build.html
+doc/tse3-0.2.7/COPYING
+doc/tse3-0.2.7/Commands.html
+doc/tse3-0.2.7/Copyright.html
+doc/tse3-0.2.7/Error.html
+doc/tse3-0.2.7/Examples.html
+doc/tse3-0.2.7/Feedback.html
+doc/tse3-0.2.7/HOWTO.html
+doc/tse3-0.2.7/History
+doc/tse3-0.2.7/History.html
+doc/tse3-0.2.7/InsFiles.html
+doc/tse3-0.2.7/KDOC.html
+doc/tse3-0.2.7/Mutex.html
+doc/tse3-0.2.7/Notifier.html
+doc/tse3-0.2.7/Playable.html
+doc/tse3-0.2.7/Porting.html
+doc/tse3-0.2.7/Psalm150.html
+doc/tse3-0.2.7/Song.html
+doc/tse3-0.2.7/Structure.html
+doc/tse3-0.2.7/TSE3MDL.html
+doc/tse3-0.2.7/Trax.html
+doc/tse3-0.2.7/Trouble.html
+doc/tse3-0.2.7/Version.html
+doc/tse3-0.2.7/Whitepaper.html
+doc/tse3-0.2.7/index.html
+doc/tse3-0.2.7/pete.jpeg
+doc/tse3-0.2.7/songs/Ambient.tse3
+doc/tse3-0.2.7/songs/Bry.tse3
+doc/tse3-0.2.7/songs/Demo.tse2
+doc/tse3-0.2.7/songs/Demo.tse3
+doc/tse3-0.2.7/songs/Enigma.tse3
+doc/tse3-0.2.7/songs/FunkyJob.tse3
+doc/tse3-0.2.7/songs/Humphry.tse3
+doc/tse3-0.2.7/songs/Trip.tse3
+doc/tse3-0.2.7/trax.gif
+doc/tse3-0.2.7/tse3.gif
+doc/tse3-0.2.7/tse3logo.png
+include/tse3/DisplayParams.h
+include/tse3/Error.h
+include/tse3/EventTrack.h
+include/tse3/FileBlockParser.h
+include/tse3/Filter.h
+include/tse3/FlagTrack.h
+include/tse3/KeySigTrack.h
+include/tse3/Metronome.h
+include/tse3/Midi.h
+include/tse3/MidiCommandFilter.h
+include/tse3/MidiData.h
+include/tse3/MidiEcho.h
+include/tse3/MidiFile.h
+include/tse3/MidiFilter.h
+include/tse3/MidiMapper.h
+include/tse3/MidiParams.h
+include/tse3/MidiScheduler.h
+include/tse3/Mixer.h
+include/tse3/Mutex.h
+include/tse3/Notifier.h
+include/tse3/Panic.h
+include/tse3/Part.h
+include/tse3/Phrase.h
+include/tse3/PhraseEdit.h
+include/tse3/PhraseList.h
+include/tse3/Playable.h
+include/tse3/Progress.h
+include/tse3/RepeatTrack.h
+include/tse3/Serializable.h
+include/tse3/Song.h
+include/tse3/TSE2MDL.h
+include/tse3/TSE3.h
+include/tse3/TSE3MDL.h
+include/tse3/TempoTrack.h
+include/tse3/TimeSigTrack.h
+include/tse3/Track.h
+include/tse3/Transport.h
+include/tse3/app/Application.h
+include/tse3/app/Choices.h
+include/tse3/app/Modified.h
+include/tse3/app/PartDisplay.h
+include/tse3/app/PartSelection.h
+include/tse3/app/Record.h
+include/tse3/app/TrackSelection.h
+include/tse3/cmd/Command.h
+include/tse3/cmd/CommandGroup.h
+include/tse3/cmd/CommandHistory.h
+include/tse3/cmd/FlagTrack.h
+include/tse3/cmd/Part.h
+include/tse3/cmd/Phrase.h
+include/tse3/cmd/Song.h
+include/tse3/cmd/Track.h
+include/tse3/file/Write.h
+include/tse3/file/XML.h
+include/tse3/ins/Destination.h
+include/tse3/ins/Instrument.h
+include/tse3/listen/DisplayParams.h
+include/tse3/listen/EventTrack.h
+include/tse3/listen/FlagTrack.h
+include/tse3/listen/KeySigTrack.h
+include/tse3/listen/Metronome.h
+include/tse3/listen/MidiCommandFilter.h
+include/tse3/listen/MidiData.h
+include/tse3/listen/MidiEcho.h
+include/tse3/listen/MidiFile.h
+include/tse3/listen/MidiFilter.h
+include/tse3/listen/MidiMapper.h
+include/tse3/listen/MidiParams.h
+include/tse3/listen/MidiScheduler.h
+include/tse3/listen/Mixer.h
+include/tse3/listen/Panic.h
+include/tse3/listen/Part.h
+include/tse3/listen/Phrase.h
+include/tse3/listen/PhraseEdit.h
+include/tse3/listen/PhraseList.h
+include/tse3/listen/Playable.h
+include/tse3/listen/RepeatTrack.h
+include/tse3/listen/Song.h
+include/tse3/listen/TempoTrack.h
+include/tse3/listen/TimeSigTrack.h
+include/tse3/listen/Track.h
+include/tse3/listen/Transport.h
+include/tse3/listen/app/Modified.h
+include/tse3/listen/app/PartSelection.h
+include/tse3/listen/app/Record.h
+include/tse3/listen/app/TrackSelection.h
+include/tse3/listen/cmd/CommandHistory.h
+include/tse3/listen/ins/Destination.h
+include/tse3/plt/Alsa.h
+include/tse3/plt/Arts.h
+include/tse3/plt/Factory.h
+include/tse3/plt/OSS.h
+include/tse3/plt/RiscOS.cpp
+include/tse3/plt/RiscOS.h
+include/tse3/plt/Win32.cpp
+include/tse3/plt/Win32.h
+include/tse3/util/Demidify.h
+include/tse3/util/MidiScheduler.h
+include/tse3/util/MulDiv.h
+include/tse3/util/NoteNumber.h
+include/tse3/util/Phrase.h
+include/tse3/util/PowerQuantise.h
+include/tse3/util/Snap.h
+include/tse3/util/Song.h
+include/tse3/util/Track.h
+lib/libtse3.so
+lib/libtse3.so.0
+@dirrm include/tse3/util
+@dirrm include/tse3/plt
+@dirrm include/tse3/listen/ins
+@dirrm include/tse3/listen/cmd
+@dirrm include/tse3/listen/app
+@dirrm include/tse3/listen
+@dirrm include/tse3/ins
+@dirrm include/tse3/file
+@dirrm include/tse3/cmd
+@dirrm include/tse3/app
+@dirrm include/tse3
+@dirrm doc/tse3-0.2.7/songs
+@dirrm doc/tse3-0.2.7