aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-07 22:22:11 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-07 22:22:11 +0000
commitd6b1399c3bd49b715171c3b7379cea82c318ee6d (patch)
tree2145d35885231db59db744e0b9a6c640899af19c /audio
parent7071f0e41ce78f9df566b755d63848d61670d503 (diff)
downloadports-d6b1399c3bd49b715171c3b7379cea82c318ee6d.tar.gz
ports-d6b1399c3bd49b715171c3b7379cea82c318ee6d.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/luppp/Makefile40
-rw-r--r--audio/luppp/distinfo3
-rw-r--r--audio/luppp/pkg-descr6
4 files changed, 50 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f3bf6c08d20e..724a935de944 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -473,6 +473,7 @@
SUBDIR += lollypop
SUBDIR += lpac
SUBDIR += lua51-mpd
+ SUBDIR += luppp
SUBDIR += lv2
SUBDIR += lv2file
SUBDIR += lvtk
diff --git a/audio/luppp/Makefile b/audio/luppp/Makefile
new file mode 100644
index 000000000000..177e9aa28387
--- /dev/null
+++ b/audio/luppp/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= luppp
+DISTVERSIONPREFIX= release-
+DISTVERSION= 1.1.1-15
+DISTVERSIONSUFFIX= -gbe14f40
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Live looping music creation tool
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libjack.so:audio/jack \
+ liblo.so:audio/liblo \
+ libntk.so:x11-toolkits/ntk \
+ libsamplerate.so:audio/libsamplerate \
+ libsndfile.so:audio/libsndfile
+
+USES= cmake:outsource pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= openAVproductions
+GH_PROJECT= openAV-Luppp
+USE_GNOME= cairo
+USE_XORG= x11
+
+PLIST_FILES= bin/luppp
+
+post-patch:
+ @${REINPLACE_CMD} -e ' \
+ s|execute_process(COMMAND git log --oneline -n1|execute_process(COMMAND echo "n/a"|' \
+ ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e ' \
+ s| -O3||; \
+ s| -g||; \
+ s|"x86_64"|"amd64"|' \
+ ${WRKSRC}/src/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/audio/luppp/distinfo b/audio/luppp/distinfo
new file mode 100644
index 000000000000..5c712d4aac40
--- /dev/null
+++ b/audio/luppp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509828196
+SHA256 (openAVproductions-openAV-Luppp-release-1.1.1-15-gbe14f40_GH0.tar.gz) = 9d9462de18b7a11d1d65ac4d283464202b971aea26eb8311c5e6fe3c2f4507b7
+SIZE (openAVproductions-openAV-Luppp-release-1.1.1-15-gbe14f40_GH0.tar.gz) = 473228
diff --git a/audio/luppp/pkg-descr b/audio/luppp/pkg-descr
new file mode 100644
index 000000000000..14d522a9f146
--- /dev/null
+++ b/audio/luppp/pkg-descr
@@ -0,0 +1,6 @@
+Luppp is a music creation tool, intended for live use. The focus is on real
+time processing and a fast and intuitive workflow. With extensive MIDI mapping
+support, you can get looping just how you like! Luppp was formally announced
+at the Linux Audio Conference 2012 at CCRMA, Stanford University.
+
+WWW: http://openavproductions.com/luppp