aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-08-29 12:02:49 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-08-29 12:02:49 +0000
commit539c0aa7587824bea8bf90236f72ae435ba31a25 (patch)
tree23b3536b78fb07f4e48bad01b0c778a7f154d485 /audio
parent574bb87b2288ab9bf32fa73c81a9162d38e0655e (diff)
downloadports-539c0aa7587824bea8bf90236f72ae435ba31a25.tar.gz
ports-539c0aa7587824bea8bf90236f72ae435ba31a25.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/easytag/Makefile19
-rw-r--r--audio/easytag/files/patch-src-log.c14
2 files changed, 25 insertions, 8 deletions
diff --git a/audio/easytag/Makefile b/audio/easytag/Makefile
index c949258a3e7b..9393707c14af 100644
--- a/audio/easytag/Makefile
+++ b/audio/easytag/Makefile
@@ -10,25 +10,28 @@ MASTER_SITES= GNOME
MAINTAINER= novel@FreeBSD.org
COMMENT= GTK2 Tag editor for MP3 and OGG files
-LIB_DEPENDS= id3:${PORTSDIR}/audio/id3lib \
- id3tag:${PORTSDIR}/audio/libid3tag \
- vorbis:${PORTSDIR}/audio/libvorbis \
- FLAC:${PORTSDIR}/audio/flac \
- mp4v2:${PORTSDIR}/multimedia/mp4v2
+LIB_DEPENDS= libid3.so:${PORTSDIR}/audio/id3lib \
+ libid3tag.so:${PORTSDIR}/audio/libid3tag \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libFLAC.so:${PORTSDIR}/audio/flac \
+ libmp4v2.so:${PORTSDIR}/multimedia/mp4v2
MAN1= easytag.1
CONFLICTS= easytag-devel-[0-9]*
USE_XZ= yes
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
USE_GNOME= gnomehack gnomeprefix gtk20 desktopfileutils
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_GTK
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITH_WAVPACK)
+OPTIONS_DEFINE= WAVPACK
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWAVPACK}
LIB_DEPENDS+= wavpack:${PORTSDIR}/audio/wavpack
CONFIGURE_ARGS+= --enable-wavpack
.else
diff --git a/audio/easytag/files/patch-src-log.c b/audio/easytag/files/patch-src-log.c
new file mode 100644
index 000000000000..347502f700a1
--- /dev/null
+++ b/audio/easytag/files/patch-src-log.c
@@ -0,0 +1,14 @@
+--- src/log.c.orig 2013-02-05 23:42:37.000000000 +0100
++++ src/log.c 2013-08-07 10:52:19.934047139 +0200
+@@ -39,6 +39,11 @@
+ #include "win32/win32dep.h"
+ #endif /* G_OS_WIN32 */
+
++/* Disable -Wformat-nonliteral warning for this source file, since
++** all calls have safe format strings coming. */
++#ifdef __clang__
++#pragma clang diagnostic ignored "-Wformat-nonliteral"
++#endif
+
+ /****************
+ * Declarations *