aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2008-06-25 04:25:32 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2008-06-25 04:25:32 +0000
commit65a85408e3594d29c63697b229e4a33a8aa6a7bc (patch)
treee2dd36f94ce42ea8685986cf010e7f362e351def /audio
parent4056323dea918ecd83d7d41ab9f81360bd175fe9 (diff)
downloadports-65a85408e3594d29c63697b229e4a33a8aa6a7bc.tar.gz
ports-65a85408e3594d29c63697b229e4a33a8aa6a7bc.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/mp3splt/Makefile4
-rw-r--r--audio/mp3splt/files/patch-mp3splt.c16
2 files changed, 18 insertions, 2 deletions
diff --git a/audio/mp3splt/Makefile b/audio/mp3splt/Makefile
index 127b9dd1c22e..c422d5c1f5dd 100644
--- a/audio/mp3splt/Makefile
+++ b/audio/mp3splt/Makefile
@@ -7,13 +7,13 @@
PORTNAME= mp3splt
PORTVERSION= 2.1c
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= uspoerlein@gmail.com
+MAINTAINER= fk@fabiankeil.de
COMMENT= Utility to split mp3 and ogg files (via CUE sheets)
OPTIONS= VORBIS "Ogg Vorbis support" On
diff --git a/audio/mp3splt/files/patch-mp3splt.c b/audio/mp3splt/files/patch-mp3splt.c
new file mode 100644
index 000000000000..323aee6be945
--- /dev/null
+++ b/audio/mp3splt/files/patch-mp3splt.c
@@ -0,0 +1,16 @@
+--- mp3splt.c.orig 2008-06-25 00:19:32.000000000 -0400
++++ mp3splt.c 2008-06-25 00:20:37.000000000 -0400
+@@ -114,6 +114,13 @@
+ if (state->mstate) {
+ fclose(state->mstate->file_input);
+ mp3_state_free(state->mstate);
++ /*
++ * Explicitly setting mstate to NULL
++ * prevents encoding misdetection (resulting
++ * in a crash) if an mp3 file is followed by
++ * a vorbis file.
++ */
++ state->mstate = NULL;
+ }
+ #ifndef NO_OGG
+ else if (state->ostate) { // If file has been opened with ov_open we should close it using ov_clear()