aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-02-17 21:23:44 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-02-17 21:23:44 +0000
commit76569348dfb3793517ab9307581b9c39a12eab4d (patch)
treec4c6385f0f6943565bbc3e32c808966f2e115234 /audio
parentc6a5ac3f1b8355ddd0b406c0ca48f3844876787b (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/ncmpcpp/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index 469b9b803903..47697444564c 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ncmpcpp
PORTVERSION= 0.5.6
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://unkart.ovh.org/ncmpcpp/ \
http://mirror.mcx2.org/
@@ -33,6 +34,7 @@ OPTIONS= CURL "Enable fetching lyrics from the Internet" on \
CLOCK "Enable clock-screen support" on \
UTF8 "Enable UTF8 support" on \
TAGLIB "Enable taglib support" off \
+ OUTPUTS "Enable outputs screen" on \
VISUALIZER "Enable music visualizer screen" on
.include <bsd.port.pre.mk>
@@ -82,6 +84,12 @@ CONFIGURE_ARGS+= --with-taglib
CONFIGURE_ARGS+= --with-taglib=no
.endif
+.if !defined(WITHOUT_OUTPUTS)
+CONFIGURE_ARGS+= --enable-outputs
+.else
+CONFIGURE_ARGS+= --disable-outputs
+.endif
+
.if !defined(WITHOUT_VISUALIZER)
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
CONFIGURE_ARGS+= --enable-visualizer