aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-08 11:16:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-08 11:16:25 +0000
commit92f68630aadea626aa5f4a9aea7d6c159846e54c (patch)
tree722503b5165c4269599b67622c9a8c77f652ae4a /audio
parent037f81756f61ef9c922a0ec6f7ed99a00e3a9a7e (diff)
downloadports-92f68630aadea626aa5f4a9aea7d6c159846e54c.tar.gz
ports-92f68630aadea626aa5f4a9aea7d6c159846e54c.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/clementine-player/Makefile11
-rw-r--r--audio/clementine-player/files/patch-src_core_mergedproxymodel.h15
-rw-r--r--audio/clementine-player/files/patch-src_library_groupbydialog.h14
3 files changed, 35 insertions, 5 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index ac9f6a9c6b22..4348f5adb757 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -7,14 +7,11 @@ PORTREVISION= 7
CATEGORIES= audio
PKGNAMESUFFIX= -player
-USE_GITHUB= yes
-GH_ACCOUNT= ${PORTNAME}${PKGNAMESUFFIX}
-GH_PROJECT= Clementine
-
MAINTAINER= sbruno@FreeBSD.org
COMMENT= Cross-platform music player based on Amarok 1.4
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
libchromaprint.so:${PORTSDIR}/audio/chromaprint \
@@ -26,6 +23,10 @@ LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME}${PKGNAMESUFFIX}
+GH_PROJECT= Clementine
+
USES= compiler:c++11-lib cmake desktop-file-utils execinfo \
gettext-tools pkgconfig
USE_GL= glew
diff --git a/audio/clementine-player/files/patch-src_core_mergedproxymodel.h b/audio/clementine-player/files/patch-src_core_mergedproxymodel.h
new file mode 100644
index 000000000000..94996d1ef6d0
--- /dev/null
+++ b/audio/clementine-player/files/patch-src_core_mergedproxymodel.h
@@ -0,0 +1,15 @@
+--- src/core/mergedproxymodel.h.orig 2014-04-23 10:16:44 UTC
++++ src/core/mergedproxymodel.h
+@@ -25,10 +25,12 @@
+ using std::placeholders::_1;
+ using std::placeholders::_2;
+
++#ifndef Q_MOC_RUN
+ #include <boost/multi_index_container.hpp>
+ #include <boost/multi_index/member.hpp>
+ #include <boost/multi_index/ordered_index.hpp>
+ #include <boost/multi_index/hashed_index.hpp>
++#endif
+
+ using boost::multi_index::multi_index_container;
+ using boost::multi_index::indexed_by;
diff --git a/audio/clementine-player/files/patch-src_library_groupbydialog.h b/audio/clementine-player/files/patch-src_library_groupbydialog.h
new file mode 100644
index 000000000000..3a9ce9c68bfe
--- /dev/null
+++ b/audio/clementine-player/files/patch-src_library_groupbydialog.h
@@ -0,0 +1,14 @@
+--- src/library/groupbydialog.h.orig 2014-04-23 10:16:44 UTC
++++ src/library/groupbydialog.h
+@@ -25,9 +25,11 @@
+ using std::placeholders::_1;
+ using std::placeholders::_2;
+
++#ifndef Q_MOC_RUN
+ #include <boost/multi_index_container.hpp>
+ #include <boost/multi_index/member.hpp>
+ #include <boost/multi_index/ordered_index.hpp>
++#endif
+
+ #include "librarymodel.h"
+