aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-15 16:39:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-15 16:39:33 +0000
commit0c2c783d1a1d5ea415f0a715427c13604c6c3f6d (patch)
tree304eb9f28d5cfe69b29c2dc64caf8b72901a0302 /audio
parentfbfa26d78beb26367725b60fcdc912296aa0de46 (diff)
downloadports-0c2c783d1a1d5ea415f0a715427c13604c6c3f6d.tar.gz
ports-0c2c783d1a1d5ea415f0a715427c13604c6c3f6d.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xmms-sapplug/Makefile57
-rw-r--r--audio/xmms-sapplug/distinfo2
-rw-r--r--audio/xmms-sapplug/files/patch-Makefile47
-rw-r--r--audio/xmms-sapplug/pkg-descr7
-rw-r--r--audio/xmms-sapplug/pkg-message3
6 files changed, 117 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 5e649dfc6ee2..4e2f1fee7de4 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -543,6 +543,7 @@
SUBDIR += xmms-pipe
SUBDIR += xmms-quix3dn
SUBDIR += xmms-real-random
+ SUBDIR += xmms-sapplug
SUBDIR += xmms-scrobbler
SUBDIR += xmms-sexypsf
SUBDIR += xmms-shn
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
new file mode 100644
index 000000000000..4c84a4962007
--- /dev/null
+++ b/audio/xmms-sapplug/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: xmms-sapplug
+# Date created: 14 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-sapplug
+DISTVERSION= 0.3f
+CATEGORIES= audio
+MASTER_SITES= http://critical.ch/distfiles/ \
+ ftp://ftp.atari.art.pl/stuff/audio/8bit-music-archive/sap/plugins/xmms/
+DISTNAME= sapplug-xmms-${DISTVERSION}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= XMMS input plugin for playing 8bit Atari(TM) .sap audio files
+
+BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GNOME= glib12
+
+CXXFLAGS+= --no-exceptions
+WRKSRC= ${WRKDIR}/sapplug-${DISTVERSION}
+
+PLIST_FILES= lib/xmms/Input/libsap.so
+
+OPTIONS= OPTIMIZED_CXXLAGS "use optimized C++ flags" on \
+ OPTIMIZED_CFLAGS "use optimized C flags" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPTIMIZED_CXXLAGS)
+CXXFLAGS+= -fPIC -fpic -funroll-all-loops -fno-strength-reduce \
+ -finline-functions -fomit-frame-pointer
+.endif
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -fPIC -fpic -funroll-all-loops -fomit-frame-pointer \
+ -fno-strength-reduce
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(}\);\(\ //.*\)|\1\2|' \
+ ${WRKSRC}/saplib/pokeyNamespace.h
+ @${REINPLACE_CMD} -e 's|^\(C[[:alpha:]]*\)|\1?|' \
+ ${WRKSRC}/saplib/Makefile
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libsap.so ${PREFIX}/lib/xmms/Input/libsap.so
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/audio/xmms-sapplug/distinfo b/audio/xmms-sapplug/distinfo
new file mode 100644
index 000000000000..f521211db9f5
--- /dev/null
+++ b/audio/xmms-sapplug/distinfo
@@ -0,0 +1,2 @@
+MD5 (sapplug-xmms-0.3f.tar.gz) = 8d2bf058ff231e83c3bee22b83481518
+SIZE (sapplug-xmms-0.3f.tar.gz) = 47508
diff --git a/audio/xmms-sapplug/files/patch-Makefile b/audio/xmms-sapplug/files/patch-Makefile
new file mode 100644
index 000000000000..86355f8947c6
--- /dev/null
+++ b/audio/xmms-sapplug/files/patch-Makefile
@@ -0,0 +1,47 @@
+--- Makefile.orig Thu Jul 14 11:24:17 2005
++++ Makefile Thu Jul 14 11:34:05 2005
+@@ -19,15 +19,18 @@
+ #
+ ##########################################################################
+
+-CC = gcc
++CC?= gcc
++MAKE?= make
+
+-CFLAGS = -O2 -Wall -fPIC -fpic \
+- -finline-functions -ffast-math \
+- -funroll-all-loops -fomit-frame-pointer -fno-strength-reduce \
+- $(shell xmms-config --cflags)
++CFLAGS?= -O2 -Wall -fPIC -fpic \
++ -finline-functions -ffast-math \
++ -funroll-all-loops -fomit-frame-pointer -fno-strength-reduce
+
+-LINKER_FLAGS = -shared -Wl,-soname -Wl,$(TARGET) \
+- -Wl,-retain-symbols-file -Wl,syms
++CFLAGS+= $(shell xmms-config --cflags)
++
++
++LDFLAGS+= -shared -Wl,-soname -Wl,$(TARGET) \
++ -Wl,-retain-symbols-file -Wl,syms
+
+ TARGET = libsap.so
+
+@@ -43,15 +46,15 @@
+ plugin: $(OBJS)
+ @./scripts/gen_symbols sap_plug.o
+ @echo
+- $(CC) $(LINKER_FLAGS) $(OBJS) $(SAPLIB) -o $(TARGET)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(SAPLIB) -o $(TARGET)
+ @echo
+ library:
+ @echo
+- cd saplib && make
++ cd saplib && $(MAKE)
+ @echo
+ install:
+ cp $(TARGET) $(HOME)/.xmms/Plugins/Input
+ clean:
+ rm -f *.o *.so *.a .syms syms
+ realclean: clean
+- cd saplib && make clean
++ cd saplib && $(MAKE) clean
diff --git a/audio/xmms-sapplug/pkg-descr b/audio/xmms-sapplug/pkg-descr
new file mode 100644
index 000000000000..52670fe27ab4
--- /dev/null
+++ b/audio/xmms-sapplug/pkg-descr
@@ -0,0 +1,7 @@
+Sapplug is a XMMS input plugin for playing 8bit Atari(TM) .sap (Slight Atari
+Player) audio files.
+
+WWW: http://www.xmms.org/plugins.php?details=155
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/xmms-sapplug/pkg-message b/audio/xmms-sapplug/pkg-message
new file mode 100644
index 000000000000..2b197e25ebaf
--- /dev/null
+++ b/audio/xmms-sapplug/pkg-message
@@ -0,0 +1,3 @@
+===============================================================================
+A huge .sap file collection can be found at: http://asma.atari.org/
+===============================================================================